summaryrefslogtreecommitdiff
path: root/net-misc/ndppd
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/ndppd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/ndppd')
-rw-r--r--net-misc/ndppd/Manifest1
-rw-r--r--net-misc/ndppd/files/ndppd.initd14
-rw-r--r--net-misc/ndppd/metadata.xml11
-rw-r--r--net-misc/ndppd/ndppd-0.2.3.ebuild25
4 files changed, 51 insertions, 0 deletions
diff --git a/net-misc/ndppd/Manifest b/net-misc/ndppd/Manifest
new file mode 100644
index 00000000000..f44c7ea3c57
--- /dev/null
+++ b/net-misc/ndppd/Manifest
@@ -0,0 +1 @@
+DIST ndppd-0.2.3.tar.gz 31459 SHA256 047764681c0b6409f9ac011359f83140639d6f62697df2c9f4f2180985017f9c SHA512 3e9a1b84c2aea81c863d384514b528e1944f592ee057a42553d53804899c880519354f8a5049102a7753b30a99fe69dfbd16ef5686c890345160ffb22f3adca0 WHIRLPOOL dc5332dd84b03701b3050e818694de5f017594b2f7e2a0231b6fac437a7f14d74a1388cdbfca9549c2e4eb10894909d9525fd0dc84b4b52528878fe367c540c2
diff --git a/net-misc/ndppd/files/ndppd.initd b/net-misc/ndppd/files/ndppd.initd
new file mode 100644
index 00000000000..67d6de86f9c
--- /dev/null
+++ b/net-misc/ndppd/files/ndppd.initd
@@ -0,0 +1,14 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+command="/usr/sbin/ndppd"
+pidfile="/var/run/ndppd.pid"
+command_args="-p $pidfile -d"
+start_stop_daemon_args="--quiet"
+description="Proxies NDP messages between interfaces."
+
+depend() {
+ use net
+}
diff --git a/net-misc/ndppd/metadata.xml b/net-misc/ndppd/metadata.xml
new file mode 100644
index 00000000000..70b099927c1
--- /dev/null
+++ b/net-misc/ndppd/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zx2c4@gentoo.org</email>
+ <name>Jason A. Donenfeld</name>
+ </maintainer>
+ <longdescription>
+ ndppd, or NDP Proxy Daemon, is a daemon that proxies NDP (Neighbor Discovery Protocol) messages between interfaces.
+ </longdescription>
+</pkgmetadata>
diff --git a/net-misc/ndppd/ndppd-0.2.3.ebuild b/net-misc/ndppd/ndppd-0.2.3.ebuild
new file mode 100644
index 00000000000..a26fdf95061
--- /dev/null
+++ b/net-misc/ndppd/ndppd-0.2.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Proxies NDP messages between interfaces"
+HOMEPAGE="http://priv.nu/projects/ndppd/"
+SRC_URI="http://priv.nu/projects/ndppd/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_install()
+{
+ emake PREFIX=/usr DESTDIR="${D}" install
+ insinto /etc
+ newins ndppd.conf-dist ndppd.conf
+ newinitd "${FILESDIR}"/ndppd.initd ndppd
+}