summaryrefslogtreecommitdiff
path: root/net-misc/ocsync
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/ocsync
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/ocsync')
-rw-r--r--net-misc/ocsync/Manifest2
-rw-r--r--net-misc/ocsync/metadata.xml11
-rw-r--r--net-misc/ocsync/ocsync-0.90.4.ebuild58
-rw-r--r--net-misc/ocsync/ocsync-0.91.4.ebuild56
4 files changed, 127 insertions, 0 deletions
diff --git a/net-misc/ocsync/Manifest b/net-misc/ocsync/Manifest
new file mode 100644
index 00000000000..a6a19837c1d
--- /dev/null
+++ b/net-misc/ocsync/Manifest
@@ -0,0 +1,2 @@
+DIST ocsync-0.90.4.tar.bz2 4630698 SHA256 f2146577c977dc82a24e0baf84f3970efc3b004f2730669aae3816f48ff15728 SHA512 74bf6b083ae4d4c09e3915d777d916a04ebb19aefb21a5a14a49e2079e02c5c60f1f274aa0cab5c227147883eaf1a5f91b6c0546b818c960cc3575cdcdd93d57 WHIRLPOOL d71ed0a1f6483be579225d577482795e4773d32ed8b5eee441125f0d34cd77a9a72664cb40a6fdc9e4674bb6e6327da0b4bf7fd8cea0d935c21151ba937661a1
+DIST ocsync-0.91.4.tar.bz2 6010999 SHA256 9ce5d04ff0475be4c3d3bfff43a554980d88277e95de4128a3f18611529b2cb6 SHA512 ec942ace1a215120cb8c764abe35b81ae48d979469c87feee8fcacb00740b35479095ed1a913f711736acd6fc8d83e148e4d597baff6d7a2de721981410ac896 WHIRLPOOL 7a8db0fa94ffa690863e51d3c58201f6d63803a6af00a2124c03c68ed4ece911bf5bf8862158c86c372caf02ee1bea7bbf4a2cfb3473a36f08e605a515ccde60
diff --git a/net-misc/ocsync/metadata.xml b/net-misc/ocsync/metadata.xml
new file mode 100644
index 00000000000..f713f2a74b4
--- /dev/null
+++ b/net-misc/ocsync/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>voyageur@gentoo.org</email>
+ <name>Bernard Cafarelli</name>
+ </maintainer>
+ <use>
+ <flag name="sftp">Enable sftp transfer support via <pkg>net-libs/libssh</pkg></flag>
+ </use>
+</pkgmetadata>
diff --git a/net-misc/ocsync/ocsync-0.90.4.ebuild b/net-misc/ocsync/ocsync-0.90.4.ebuild
new file mode 100644
index 00000000000..dc954daced3
--- /dev/null
+++ b/net-misc/ocsync/ocsync-0.90.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="A file synchronizer especially designed for you, the normal user"
+HOMEPAGE="http://csync.org/"
+SRC_URI="http://download.owncloud.com/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc iconv samba +sftp test"
+
+RESTRICT="test"
+
+RDEPEND="
+ dev-db/sqlite:3
+ >=dev-libs/iniparser-3.1
+ net-libs/neon[ssl]
+ iconv? ( virtual/libiconv )
+ samba? ( net-fs/samba )
+ sftp? ( net-libs/libssh )
+ !net-misc/csync
+ !>=net-misc/owncloud-client-1.5.1
+"
+DEPEND="${DEPEND}
+ app-text/asciidoc
+ doc? ( app-doc/doxygen )
+ test? ( dev-libs/check dev-util/cmocka )
+"
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # proper docdir
+ sed -e "s:/doc/ocsync:/doc/${PF}:" \
+ -i doc/CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use test UNIT_TESTING)
+ $(cmake-utils_use_find_package doc Doxygen)
+ $(cmake-utils_use_find_package samba Libsmbclient)
+ $(cmake-utils_use_find_package sftp LibSSH)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ mv "${D}/usr/etc/ocsync" "${D}/etc/"
+ rm -r "${D}/usr/etc/"
+}
diff --git a/net-misc/ocsync/ocsync-0.91.4.ebuild b/net-misc/ocsync/ocsync-0.91.4.ebuild
new file mode 100644
index 00000000000..e6410a698f6
--- /dev/null
+++ b/net-misc/ocsync/ocsync-0.91.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="ownCloud fork of csync file synchronizer"
+HOMEPAGE="http://owncloud.org/"
+SRC_URI="http://download.owncloud.com/desktop/stable/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +iconv samba +sftp test"
+
+# Tests only work with iconv
+REQUIRED_USE="test? ( iconv )"
+
+RDEPEND=">=dev-db/sqlite-3.4:3
+ net-libs/neon[ssl]
+ iconv? ( virtual/libiconv )
+ samba? ( >=net-fs/samba-3.5 )
+ sftp? ( >=net-libs/libssh-0.5 )
+ !net-misc/csync
+ !>=net-misc/owncloud-client-1.5.1"
+DEPEND="${DEPEND}
+ doc? (
+ app-doc/doxygen
+ app-text/asciidoc
+ )
+ test? ( dev-util/cmocka )"
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # proper docdir
+ sed -e "s:/doc/${PN}:/doc/${PF}:" \
+ -i doc/CMakeLists.txt || die
+ # Fix compilation with USE=-iconv, #500860
+ sed -e "s/_TCHAR/mbchar_t/" \
+ -i src/std/c_string.c || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc
+ $(cmake-utils_use_with iconv ICONV)
+ $(cmake-utils_use test UNIT_TESTING)
+ $(cmake-utils_use_find_package doc Doxygen)
+ $(cmake-utils_use_find_package samba Libsmbclient)
+ $(cmake-utils_use_find_package sftp LibSSH)
+ )
+ cmake-utils_src_configure
+}