summaryrefslogtreecommitdiff
path: root/net-misc/omniORB
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/omniORB
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/omniORB')
-rw-r--r--net-misc/omniORB/Manifest1
-rw-r--r--net-misc/omniORB/files/ldflags.patch11
-rw-r--r--net-misc/omniORB/files/omniNames22
-rw-r--r--net-misc/omniORB/files/omniORB-4.1.4-format-security.patch16
-rw-r--r--net-misc/omniORB/files/omniORB-4.1.4-openssl-1.patch31
-rw-r--r--net-misc/omniORB/metadata.xml10
-rw-r--r--net-misc/omniORB/omniORB-4.1.4-r2.ebuild91
7 files changed, 182 insertions, 0 deletions
diff --git a/net-misc/omniORB/Manifest b/net-misc/omniORB/Manifest
new file mode 100644
index 00000000000..baac7e5ff48
--- /dev/null
+++ b/net-misc/omniORB/Manifest
@@ -0,0 +1 @@
+DIST omniORB-4.1.4.tar.gz 3093814 SHA256 84fb9790c25d6e46248c9773747e393b429573190da2150850d4a49debda4e8e SHA512 0ed989dd9a8c024a575ebbe1def137d11c4e52297727883d26cb1fdc87d2965e6d0152ee4b7b90097f2d97eb22501bb968eff0d070e88f80a9fef6b7439e1a1c WHIRLPOOL 16b12ade124e62b57d8401c73975a4a0861166f080b0f735e7ad363dca1a7387d807e5c8bf4ae9b90b70f41a03e9811109bcb917e78b833578e891b78c9da55f
diff --git a/net-misc/omniORB/files/ldflags.patch b/net-misc/omniORB/files/ldflags.patch
new file mode 100644
index 00000000000..471df27ae7f
--- /dev/null
+++ b/net-misc/omniORB/files/ldflags.patch
@@ -0,0 +1,11 @@
+--- mk/beforeauto.mk.in.orig 2010-04-24 21:13:17.000000000 +0200
++++ mk/beforeauto.mk.in 2010-04-24 21:14:24.000000000 +0200
+@@ -541,7 +541,7 @@
+ SharedLibraryLibNameTemplate = lib$$1$$2.$(SHAREDLIB_SUFFIX)
+ SharedLibraryImplibNameTemplate = lib$$1$$2.a
+
+-SharedLibraryPlatformLinkFlagsTemplate = -shared -Wl,-soname,$$soname
++SharedLibraryPlatformLinkFlagsTemplate = -shared -Wl,-soname,$$soname @LDFLAGS@
+
+ define SharedLibraryFullName
+ fn() { \
diff --git a/net-misc/omniORB/files/omniNames b/net-misc/omniORB/files/omniNames
new file mode 100644
index 00000000000..4f480d15b1c
--- /dev/null
+++ b/net-misc/omniORB/files/omniNames
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting omniNames"
+ start-stop-daemon --start --background --make-pidfile --pidfile /var/run/omniNames.pid \
+ --exec /usr/bin/omniNames -- -start -always -logdir /var/log/omniORB \
+ -errlog /var/log/omniORB/omniORB.errors
+ eend $? "Error starting omniNames."
+}
+
+stop() {
+ ebegin "Stopping omniNames"
+ start-stop-daemon --stop --pidfile /var/run/omniNames.pid
+ eend $? "Error stopping omniNames."
+}
diff --git a/net-misc/omniORB/files/omniORB-4.1.4-format-security.patch b/net-misc/omniORB/files/omniORB-4.1.4-format-security.patch
new file mode 100644
index 00000000000..2af8d21d308
--- /dev/null
+++ b/net-misc/omniORB/files/omniORB-4.1.4-format-security.patch
@@ -0,0 +1,16 @@
+ src/tool/omniidl/cxx/cccp/cccp.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/tool/omniidl/cxx/cccp/cccp.c b/src/tool/omniidl/cxx/cccp/cccp.c
+index 0198b1a..64d80ae 100644
+--- a/src/tool/omniidl/cxx/cccp/cccp.c
++++ b/src/tool/omniidl/cxx/cccp/cccp.c
+@@ -8034,7 +8034,7 @@ macroexpand (hp, op)
+ else
+ parse_error = macarg (NULL_PTR, 0);
+ if (parse_error) {
+- error_with_line (line_for_error (start_line), parse_error);
++ error_with_line (line_for_error (start_line), "%s", parse_error);
+ break;
+ }
+ i++;
diff --git a/net-misc/omniORB/files/omniORB-4.1.4-openssl-1.patch b/net-misc/omniORB/files/omniORB-4.1.4-openssl-1.patch
new file mode 100644
index 00000000000..968013a2578
--- /dev/null
+++ b/net-misc/omniORB/files/omniORB-4.1.4-openssl-1.patch
@@ -0,0 +1,31 @@
+http://bugs.gentoo.org/326791
+
+--- include/omniORB4/sslContext.h
++++ include/omniORB4/sslContext.h
+@@ -111,7 +111,11 @@
+ virtual ~sslContext();
+
+ protected:
+- virtual SSL_METHOD* set_method();
++ #if OPENSSL_VERSION_NUMBER >= 0x10000000L
++ virtual const SSL_METHOD* set_method();
++ #else
++ virtual SSL_METHOD* set_method();
++ #endif
+ // Default to return SSLv23_method().
+
+ virtual void set_supported_versions();
+--- src/lib/omniORB/orbcore/ssl/sslContext.cc
++++ src/lib/omniORB/orbcore/ssl/sslContext.cc
+@@ -197,7 +197,11 @@
+ }
+
+ /////////////////////////////////////////////////////////////////////////
++#if OPENSSL_VERSION_NUMBER >= 0x10000000L
++const SSL_METHOD*
++#else
+ SSL_METHOD*
++#endif
+ sslContext::set_method() {
+ return SSLv23_method();
+ }
diff --git a/net-misc/omniORB/metadata.xml b/net-misc/omniORB/metadata.xml
new file mode 100644
index 00000000000..47c52c1154d
--- /dev/null
+++ b/net-misc/omniORB/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>caster@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">omniorb</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/omniORB/omniORB-4.1.4-r2.ebuild b/net-misc/omniORB/omniORB-4.1.4-r2.ebuild
new file mode 100644
index 00000000000..929449b4714
--- /dev/null
+++ b/net-misc/omniORB/omniORB-4.1.4-r2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils multilib python-single-r1
+
+DESCRIPTION="A robust, high-performance CORBA 2 ORB"
+HOMEPAGE="http://omniorb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/omniorb/${P}.tar.gz"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 ~sparc x86"
+IUSE="doc ssl static-libs"
+
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6b:0= )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # respect ldflags, bug #284191
+ epatch \
+ "${FILESDIR}"/ldflags.patch \
+ "${FILESDIR}"/${P}-openssl-1.patch \
+ "${FILESDIR}"/${P}-format-security.patch
+
+ sed \
+ -e 's/^CXXDEBUGFLAGS.*/CXXDEBUGFLAGS = $(OPTCXXFLAGS)/' \
+ -e 's/^CDEBUGFLAGS.*/CDEBUGFLAGS = $(OPTCFLAGS)/' \
+ -i mk/beforeauto.mk.in mk/platforms/i586_linux_2.0*.mk || \
+ die "sed failed"
+}
+
+src_configure() {
+ mkdir build && cd build || die
+
+ local MY_CONF="--prefix=/usr --with-omniORB-config=/etc/omniorb/omniORB.cfg \
+ --with-omniNames-logdir=/var/log/omniORB --libdir=/usr/$(get_libdir)"
+
+ use ssl && MY_CONF="${MY_CONF} --with-openssl=/usr"
+
+ ECONF_SOURCE=".." econf ${MY_CONF} $(use_enable static-libs static)
+}
+
+src_compile() {
+ cd build || die
+ emake OPTCFLAGS="${CFLAGS}" OPTCXXFLAGS="${CXXFLAGS}"
+}
+
+src_install() {
+ cd build || die
+ default
+ # this looks redundant
+ rm "${ED}/usr/bin/omniidlrun.py" || die
+
+ cd "${S}" || die
+
+ if use doc; then
+ dohtml doc/*.html
+ dohtml -r doc/omniORB
+ docinto print
+ dodoc doc/*.pdf
+ fi
+
+ cat <<- EOF > "${T}/90omniORB"
+ PATH="/usr/share/omniORB/bin/scripts"
+ OMNIORB_CONFIG="/etc/omniorb/omniORB.cfg"
+ EOF
+ doenvd "${T}/90omniORB"
+ doinitd "${FILESDIR}"/omniNames
+
+ cp "sample.cfg" "${T}/omniORB.cfg" || die
+ cat <<- EOF >> "${T}/omniORB.cfg"
+ # resolve the omniNames running on localhost
+ InitRef = NameService=corbaname::localhost
+ EOF
+ insinto /etc/omniorb
+ doins "${T}"/omniORB.cfg
+
+ keepdir /var/log/omniORB
+
+ python_optimize
+ python_fix_shebang "${ED}"/usr/bin/omniidl
+}
+
+pkg_postinst() {
+ elog "Since 4.1.2, the omniORB init script has been renamed to omniNames for clarity."
+}