summaryrefslogtreecommitdiff
path: root/net-misc/pipes
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/pipes
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/pipes')
-rw-r--r--net-misc/pipes/Manifest2
-rw-r--r--net-misc/pipes/metadata.xml23
-rw-r--r--net-misc/pipes/pipes-1.16.1.ebuild30
-rw-r--r--net-misc/pipes/pipes-1.16.ebuild37
4 files changed, 92 insertions, 0 deletions
diff --git a/net-misc/pipes/Manifest b/net-misc/pipes/Manifest
new file mode 100644
index 00000000000..15c3f96fc40
--- /dev/null
+++ b/net-misc/pipes/Manifest
@@ -0,0 +1,2 @@
+DIST pipes-1.16.1.tar.bz2 21642 SHA256 d7bb02f7e10ee91174a4d0d74ce61e1328d08be68d1ab3c235e63d2f34ada62c SHA512 ff8f6cf7934149c3d8a6e0443a06840863313acccd31791913fa25b086173e834d8f357212811e5e1ddb62148d3e687858e8956065734f11d7fc729f2a64b0a3 WHIRLPOOL 6ab87a0228451ad98746e5f9346922fcf6246c87b57e09a709781af478a546e49c521bd4b2bc0a7824776cf1dfd230bc7e61b3f1f12c41e19c87f09e2059a831
+DIST pipes-1.16.tar.bz2 21441 SHA256 cd5366d8e1ee9a9135e61b976eafc4b2e36938cda81aaed6c281b0b438335150
diff --git a/net-misc/pipes/metadata.xml b/net-misc/pipes/metadata.xml
new file mode 100644
index 00000000000..bd1cbeb8e1f
--- /dev/null
+++ b/net-misc/pipes/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+<longdescription>
+I just noticed that netpipes doesn't support bidirectional pipes.
+So I made my own version.
+Now I can say in computer A that "plis 12345 -io ohjelma" and in computer B that "pcon A 12345 -io ohjelma2",
+and they communicate together then.
+My example utilization was that I can send the picture of SNES-emulator to another
+computer via network, and grab the keyboard input there, so get two consoles to
+the same game.
+My friend wanted to watch when I play FF6, but didn't want to sit next to my monitor,
+and asked if he could get the picture to his monitor.
+And he got it.
+Then he asked if he could play it from his computer at the same time as me...
+And now it works too.
+Other ways of use can everybody invent theirselves.
+It's really easy to make simple server software with this.
+For example, do "plis 79 -io finger" and then you have a finger-service.
+Or "plis 5555 -o 'cat signature'" and then port 5555 gives your signature.
+</longdescription>
+</pkgmetadata>
diff --git a/net-misc/pipes/pipes-1.16.1.ebuild b/net-misc/pipes/pipes-1.16.1.ebuild
new file mode 100644
index 00000000000..b812b80db09
--- /dev/null
+++ b/net-misc/pipes/pipes-1.16.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Very versatile TCP pipes"
+HOMEPAGE="http://bisqwit.iki.fi/source/pipes.html"
+SRC_URI="http://bisqwit.iki.fi/src/arch/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc ~s390 ~x86"
+
+src_prepare() {
+ # Prevent the build system from looking for dependencies
+ touch .depend || die
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) OPTIM="${CFLAGS}" LDFLAGS="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ dobin plis
+ dosym /usr/bin/plis /usr/bin/pcon
+ dodoc Examples ChangeLog
+ dohtml README.html
+}
diff --git a/net-misc/pipes/pipes-1.16.ebuild b/net-misc/pipes/pipes-1.16.ebuild
new file mode 100644
index 00000000000..16d245bf5b1
--- /dev/null
+++ b/net-misc/pipes/pipes-1.16.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Very versatile TCP pipes"
+HOMEPAGE="http://bisqwit.iki.fi/source/pipes.html"
+SRC_URI="http://bisqwit.iki.fi/src/arch/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 s390 ~ppc"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s:-O2:${CFLAGS}:" Makefile || \
+ die "sed Makefile failed"
+ touch .depend
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin plis || die "dobin failed"
+ dohard /usr/bin/plis /usr/bin/pcon || die "dohard failed"
+ dodoc Examples ChangeLog
+ dohtml README.html
+}