summaryrefslogtreecommitdiff
path: root/net-misc/pps-tools
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/pps-tools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/pps-tools')
-rw-r--r--net-misc/pps-tools/Manifest2
-rw-r--r--net-misc/pps-tools/files/pps-tools-0.0.20120407-build.patch53
-rw-r--r--net-misc/pps-tools/files/pps-tools-0.0.20120407-install.patch28
-rw-r--r--net-misc/pps-tools/metadata.xml8
-rw-r--r--net-misc/pps-tools/pps-tools-0.0.20110710.ebuild42
-rw-r--r--net-misc/pps-tools/pps-tools-0.0.20120407.ebuild27
6 files changed, 160 insertions, 0 deletions
diff --git a/net-misc/pps-tools/Manifest b/net-misc/pps-tools/Manifest
new file mode 100644
index 00000000000..361c374bc76
--- /dev/null
+++ b/net-misc/pps-tools/Manifest
@@ -0,0 +1,2 @@
+DIST pps-tools-git-0.0.20110710.tgz 6590 SHA256 1557da95e77684997bb46f3a30eafd665b409c507b3df1c3aa5e1200c2db7215
+DIST pps-tools-git-0.0.20120407.tar.gz 13619 SHA256 eb020d40a3938546620889bb6ecdeead2c188e87ffd43c3ae04a41e5998e7997 SHA512 d2014262b0594959f337c25df859591d0737994decec663389392d3c7e53376ded2485713f6364c4833d8d7c40b4b0c3b88865ab85e481bcc2e81e35931d84de WHIRLPOOL 03ff250da63ff2ca2f9111b8207608e0e989c376a5af51b919d4fb8889936e00db2b15d14309dda68e92e13c7478f81e5a2d72544eefa73eb93287dd0396fc14
diff --git a/net-misc/pps-tools/files/pps-tools-0.0.20120407-build.patch b/net-misc/pps-tools/files/pps-tools-0.0.20120407-build.patch
new file mode 100644
index 00000000000..5a27bb65184
--- /dev/null
+++ b/net-misc/pps-tools/files/pps-tools-0.0.20120407-build.patch
@@ -0,0 +1,53 @@
+From f4133df52856adfe9ffa2152f0e449f2f8adb49d Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sat, 18 Aug 2012 17:04:43 -0400
+Subject: [PATCH] fix up makefile
+
+Make sure we respect CFLAGS/CPPFLAGS properly.
+
+Also fix up the depend include so we get reproducible behavior --
+the depend file is generated & included first, and we don't get
+weird behavior when we run:
+ git clean -x -d
+ make
+ make
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ Makefile | 13 +++++--------
+ 1 file changed, 5 insertions(+), 8 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 0fb84b4..a07156f 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,9 +1,8 @@
+ TARGETS = ppstest ppsctl ppswatch
+
+-CFLAGS += -Wall -O2 -D_GNU_SOURCE
+-CFLAGS += -I .
+-CFLAGS += -ggdb
+-CFLAGS += -D__N_PPS=18
++CFLAGS ?= -O2 -ggdb
++CFLAGS += -Wall
++CPPFLAGS += -D_GNU_SOURCE -I. -D__N_PPS=18
+
+ # -- Actions section --
+
+@@ -12,11 +11,9 @@ CFLAGS += -D__N_PPS=18
+ all : .depend $(TARGETS)
+
+ .depend depend dep :
+- $(CC) $(CFLAGS) -M $(TARGETS:=.c) > .depend
++ $(CC) $(CPPFLAGS) $(CFLAGS) -M $(TARGETS:=.c) > .depend
+
+-ifeq (.depend,$(wildcard .depend))
+-include .depend
+-endif
++-include .depend
+
+ install : all
+ install -m 755 -t $(DESTDIR)/usr/bin ppsfind $(TARGETS)
+--
+1.7.9.7
+
diff --git a/net-misc/pps-tools/files/pps-tools-0.0.20120407-install.patch b/net-misc/pps-tools/files/pps-tools-0.0.20120407-install.patch
new file mode 100644
index 00000000000..e268d6622a9
--- /dev/null
+++ b/net-misc/pps-tools/files/pps-tools-0.0.20120407-install.patch
@@ -0,0 +1,28 @@
+From 0b3a849153ffb42fb22fe42dc2b9e59ca23cec8c Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sat, 18 Aug 2012 17:15:19 -0400
+Subject: [PATCH] fix DESTDIR installs
+
+Make sure the dirs we install into exist first:
+ make install DESTDIR=$PWD/foo
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ Makefile | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile b/Makefile
+index a07156f..bebcce7 100644
+--- a/Makefile
++++ b/Makefile
+@@ -16,6 +16,7 @@ all : .depend $(TARGETS)
+ -include .depend
+
+ install : all
++ mkdir -p -m 755 $(DESTDIR)/usr/bin $(DESTDIR)/usr/include/sys
+ install -m 755 -t $(DESTDIR)/usr/bin ppsfind $(TARGETS)
+ install -m 644 -t $(DESTDIR)/usr/include/sys timepps.h
+
+--
+1.7.9.7
+
diff --git a/net-misc/pps-tools/metadata.xml b/net-misc/pps-tools/metadata.xml
new file mode 100644
index 00000000000..f493acd5865
--- /dev/null
+++ b/net-misc/pps-tools/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>base-system</herd>
+ <upstream>
+ <remote-id type="github">ago/pps-tools</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/pps-tools/pps-tools-0.0.20110710.ebuild b/net-misc/pps-tools/pps-tools-0.0.20110710.ebuild
new file mode 100644
index 00000000000..384b01ded27
--- /dev/null
+++ b/net-misc/pps-tools/pps-tools-0.0.20110710.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit eutils
+
+GITHUB_USER="ago"
+PV_COMMIT="74c32c318f63bca5b5db"
+
+DESCRIPTION="User-space tools for LinuxPPS"
+HOMEPAGE="http://wiki.enneenne.com/index.php/LinuxPPS_installation"
+SRC_URI="http://github.com/${GITHUB_USER}/${PN}/tarball/${PV_COMMIT} -> ${PN}-git-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${GITHUB_USER}-${PN}-${PV_COMMIT:0:7}"
+
+src_prepare() {
+ sed -i \
+ -e '/^CFLAGS.*ggdb/d' \
+ -e '/^CFLAGS.*O2/s,-O2,,g' \
+ -e '/^\.PHONY:/s,all,,g' \
+ Makefile
+}
+
+src_compile() {
+ emake depend
+ emake all
+}
+
+src_install() {
+ dodir /usr/bin /usr/include
+ emake install DESTDIR="${D}"
+}
diff --git a/net-misc/pps-tools/pps-tools-0.0.20120407.ebuild b/net-misc/pps-tools/pps-tools-0.0.20120407.ebuild
new file mode 100644
index 00000000000..3e89eec50a9
--- /dev/null
+++ b/net-misc/pps-tools/pps-tools-0.0.20120407.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils
+
+GITHUB_USER="ago"
+PV_COMMIT='0deb9c7e135e9380a6d09e9d2e938a146bb698c8'
+
+DESCRIPTION="User-space tools for LinuxPPS"
+HOMEPAGE="http://wiki.enneenne.com/index.php/LinuxPPS_installation"
+SRC_URI="http://github.com/${GITHUB_USER}/${PN}/tarball/${PV_COMMIT} -> ${PN}-git-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+S="${WORKDIR}/${GITHUB_USER}-${PN}-${PV_COMMIT:0:7}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+ epatch "${FILESDIR}"/${P}-install.patch
+ tc-export CC
+}