summaryrefslogtreecommitdiff
path: root/net-misc/pump
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/pump
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/pump')
-rw-r--r--net-misc/pump/Manifest2
-rw-r--r--net-misc/pump/metadata.xml10
-rw-r--r--net-misc/pump/pump-0.8.24-r4.ebuild57
3 files changed, 69 insertions, 0 deletions
diff --git a/net-misc/pump/Manifest b/net-misc/pump/Manifest
new file mode 100644
index 00000000000..0bc78e0ecf7
--- /dev/null
+++ b/net-misc/pump/Manifest
@@ -0,0 +1,2 @@
+DIST pump_0.8.24-7.diff.gz 29280 SHA256 2bc790e57a6476693395075ae2e64791afb269a3a5b79029a3915d2ecae6cc64 SHA512 8d70bb31f9d56d79b4cb74def6d3df2a3115b62672190d8c38b7fa628ad35481ad637dd4854e8331a4c5a649fa573c58c9b867b014bbaad7fe6c8c870a02eae2 WHIRLPOOL cda44ce5c5e8f7404aaf23fcc0525930bd5bc5d4963c7d7f383c15c1f2771467351c6f2a3234edcd0bd0bfbaac09b3f9ebbf1fd44ee9c942e301807fa89e5908
+DIST pump_0.8.24.orig.tar.gz 79790 SHA256 cbb423942a4295a07a23b76a02d645b76b4ac0b58c3a30076ad42c2ab80c2dba SHA512 b6956f0ab2a5fbcda2320efd454d21aee651816a13a55622e21dc3a29919aef7db7c9a8d71c3b37b1969f29cff37c67d313f763a17404652fb962bc54eabcb34 WHIRLPOOL e007ca89139f16afcd42585299e97c960c7136b192499c3b042083f832fd2f3347b814c94a40ea65515db243f26e7ad81deee923d2eb632af7e428f9e6a013d2
diff --git a/net-misc/pump/metadata.xml b/net-misc/pump/metadata.xml
new file mode 100644
index 00000000000..b1f88f3afd8
--- /dev/null
+++ b/net-misc/pump/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ A DHCP/BOOTP client
+ </longdescription>
+</pkgmetadata>
diff --git a/net-misc/pump/pump-0.8.24-r4.ebuild b/net-misc/pump/pump-0.8.24-r4.ebuild
new file mode 100644
index 00000000000..339780cf2bf
--- /dev/null
+++ b/net-misc/pump/pump-0.8.24-r4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+PATCHLEVEL="7"
+
+DESCRIPTION="This is the DHCP/BOOTP client written by RedHat"
+HOMEPAGE="http://ftp.debian.org/debian/pool/main/p/pump/"
+SRC_URI="mirror://debian/pool/main/p/${PN}/${PN}_${PV}.orig.tar.gz
+ mirror://debian/pool/main/p/${PN}/${PN}_${PV}-${PATCHLEVEL}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm hppa ia64 ppc sparc x86"
+IUSE=""
+
+DEPEND=">=dev-libs/popt-1.5"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Fix Debian patch to fit epatch logic
+ sed -i \
+ -e 's:/debian::g' \
+ -e '/^---/s:pump-0.8.24.orig/::' \
+ -e '/^+++/s:pump-0.8.24/::' \
+ "${WORKDIR}/${PN}_${PV}-${PATCHLEVEL}.diff" || die "sed on ${PN}_${PV}-${PATCHLEVEL}.diff failed"
+
+ # Apply Debians pump patchset - they fix things good :)
+ # Debian patchset 7 include gentoo patchset too
+ epatch "${WORKDIR}/${PN}_${PV}-${PATCHLEVEL}.diff"
+ # Add LC_ALL workaround to make sure that patches are applied in right order(bug 471666)
+ LC_ALL=C EPATCH_FORCE="yes" EPATCH_SOURCE="patches" EPATCH_SUFFIX="patch" epatch
+
+ # respect AR, wrt bug #458482
+ tc-export AR
+
+ epatch_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" DEB_CFLAGS="-fPIC ${CFLAGS}" pump
+}
+
+src_install() {
+ exeinto /sbin
+ doexe pump
+
+ doman pump.8
+ dodoc changelog CREDITS
+
+ dolib.a libpump.a
+ doheader pump.h
+}