summaryrefslogtreecommitdiff
path: root/net-misc/redir
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/redir
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/redir')
-rw-r--r--net-misc/redir/Manifest1
-rw-r--r--net-misc/redir/files/redir-2.2.1-include.patch10
-rw-r--r--net-misc/redir/metadata.xml8
-rw-r--r--net-misc/redir/redir-2.2.1.ebuild37
4 files changed, 56 insertions, 0 deletions
diff --git a/net-misc/redir/Manifest b/net-misc/redir/Manifest
new file mode 100644
index 00000000000..c54b65c648f
--- /dev/null
+++ b/net-misc/redir/Manifest
@@ -0,0 +1 @@
+DIST redir-2.2.1.tar.gz 42247 SHA256 7ea504f835338e448f674ca8637512f511bf74538418ad43ab39039017090e6c
diff --git a/net-misc/redir/files/redir-2.2.1-include.patch b/net-misc/redir/files/redir-2.2.1-include.patch
new file mode 100644
index 00000000000..5fea475d31a
--- /dev/null
+++ b/net-misc/redir/files/redir-2.2.1-include.patch
@@ -0,0 +1,10 @@
+--- redir-2.2.1/redir.c.orig 1999-12-26 21:50:06.000000000 +0100
++++ redir-2.2.1/redir.c 2009-10-23 15:01:26.000000000 +0200
+@@ -78,6 +78,7 @@
+ #include <arpa/inet.h>
+ #include <netdb.h>
+ #include <errno.h>
++#include <time.h>
+
+ #ifdef USE_TCP_WRAPPERS
+ #include <tcpd.h>
diff --git a/net-misc/redir/metadata.xml b/net-misc/redir/metadata.xml
new file mode 100644
index 00000000000..59e2b8f78cb
--- /dev/null
+++ b/net-misc/redir/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <name>Default assignee for orphaned packages</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-misc/redir/redir-2.2.1.ebuild b/net-misc/redir/redir-2.2.1.ebuild
new file mode 100644
index 00000000000..da395778fd1
--- /dev/null
+++ b/net-misc/redir/redir-2.2.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Redir is a port redirector"
+HOMEPAGE="http://sammy.net/~sammy/hacks/"
+SRC_URI="http://sammy.net/~sammy/hacks/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha ~amd64 ~hppa ~mips sparc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_configure() {
+ epatch "${FILESDIR}/${P}-include.patch"
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" || \
+ die "emake failed"
+}
+
+src_install() {
+ dobin redir || die "dobin failed"
+ newman redir.man redir.1 || die "doman failed"
+ dodoc CHANGES README transproxy.txt || die "dodoc failed"
+}