summaryrefslogtreecommitdiff
path: root/net-misc/rwbs
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/rwbs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/rwbs')
-rw-r--r--net-misc/rwbs/Manifest1
-rw-r--r--net-misc/rwbs/files/rwbs.conf21
-rw-r--r--net-misc/rwbs/files/rwbs.rc21
-rw-r--r--net-misc/rwbs/metadata.xml7
-rw-r--r--net-misc/rwbs/rwbs-0.27-r1.ebuild36
5 files changed, 86 insertions, 0 deletions
diff --git a/net-misc/rwbs/Manifest b/net-misc/rwbs/Manifest
new file mode 100644
index 00000000000..5889710aa4a
--- /dev/null
+++ b/net-misc/rwbs/Manifest
@@ -0,0 +1 @@
+DIST rwbs_Linux_0_27.tar.gz 365489 SHA256 dcf1568c6d5ce3f49f3b1f92fc67f0f9a4abb3905a3b13fb0a818b2c091d3ab0 SHA512 131aa275015fe032462d2848fbefc9b1949fccb605663203c2d7b4cf32ed0351f10368e5458af7d54e8b251ae8539febd3bd57c7b5df146770161aba3ba90959 WHIRLPOOL 61b9489547498d3c8c862120d76fc37c300b502a834c192ca9677d6b89a709bafb3cf76a5959320402d6fc60c9171304015fe85074074fda014d3eca687d50d5
diff --git a/net-misc/rwbs/files/rwbs.conf b/net-misc/rwbs/files/rwbs.conf
new file mode 100644
index 00000000000..09541e48f14
--- /dev/null
+++ b/net-misc/rwbs/files/rwbs.conf
@@ -0,0 +1,21 @@
+# Roger Wilco base station configuration
+#
+# $ rwbs --help reads:
+# usage: ./rwbs [-b(ackwardcompat)] [-t(est)] [-s(tatic)] [-p <passwd>] [-u <udpport>] [-x <connectspeed>] [$
+# connectspeed is an integer measuring the allocated broadcast
+# capacity for the channel host. The recommended value is 1.
+# Higher values will cause the RWBS to use its additional broadcast capacity
+# to help relay transmissions, at the expense of scalability.
+# the b(ackwardcompat) option tells RWBS to appear as a "user" on the
+# channel. Mark I users will prefer this, but not Mark Ia users.
+# The s(tatic) option indicates that a client asking to join a
+# non-existent named channel should be turned away with an error.
+# rather than being hosted on a dynamically-created channel.
+# hostname is what your station's name will be in the Roger Wilco Channel Tab.
+# For instance, if you used -n "Clan Hurt", Roger Wilco users will see
+# an entry in the Channel window named "Clan Hurt Base"
+# If the -t(est) flag is used, the base station echoes transmissions
+# when there is just one other party on the channel.
+
+# Specify whatever options you want on this line
+RWBS_OPTS='-n "Gentoo Linux"'
diff --git a/net-misc/rwbs/files/rwbs.rc b/net-misc/rwbs/files/rwbs.rc
new file mode 100644
index 00000000000..88528a7fa7c
--- /dev/null
+++ b/net-misc/rwbs/files/rwbs.rc
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting Roger Wilco base station"
+ start-stop-daemon --start --quiet --exec /opt/bin/rwbs -b \
+ -- \${RWBS_OPTS} >>/var/log/rwbs 2>&1
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Roger Wilco base station"
+ start-stop-daemon --stop --quiet --exec /opt/bin/rwbs > /dev/null 2>&1
+ eend $?
+}
diff --git a/net-misc/rwbs/metadata.xml b/net-misc/rwbs/metadata.xml
new file mode 100644
index 00000000000..91f4e72fb54
--- /dev/null
+++ b/net-misc/rwbs/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-misc/rwbs/rwbs-0.27-r1.ebuild b/net-misc/rwbs/rwbs-0.27-r1.ebuild
new file mode 100644
index 00000000000..94b40927c68
--- /dev/null
+++ b/net-misc/rwbs/rwbs-0.27-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="Roger Wilco base station"
+HOMEPAGE="http://rogerwilco.gamespy.com/"
+SRC_URI="http://games.gci.net/pub/VoiceOverIP/RogerWilco/rwbs_Linux_0_27.tar.gz"
+
+SLOT="0"
+LICENSE="Resounding GPL-2"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+# Everything is statically linked
+DEPEND=""
+
+S="${WORKDIR}"
+
+QA_PREBUILT="opt/bin/rwbs"
+
+src_install() {
+ dodoc README.TXT CHANGES.TXT
+ exeinto /opt/bin
+ doexe rwbs run_rwbs
+
+ # Put distribution into /usr/share/rwbs
+ insinto /usr/share/rwbs/
+ doins "${S}"/anotherpersonjoined "${S}"/helloandwelcome \
+ "${S}"/ifucanhearthis "${S}"/invitetestxmit "${S}"/join?.rwc \
+ "${S}"/plsstartagame "${S}"/thisisatestmsg
+
+ newconfd "${FILESDIR}"/rwbs.conf rwbs
+ newinitd "${FILESDIR}"/rwbs.rc rwbs
+}