summaryrefslogtreecommitdiff
path: root/net-misc/rwhoisd/files
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/rwhoisd/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/rwhoisd/files')
-rw-r--r--net-misc/rwhoisd/files/rwhoisd17
-rw-r--r--net-misc/rwhoisd/files/rwhoisd-destdir-1.5.9.5.patch39
-rw-r--r--net-misc/rwhoisd/files/rwhoisd.conf7
3 files changed, 63 insertions, 0 deletions
diff --git a/net-misc/rwhoisd/files/rwhoisd b/net-misc/rwhoisd/files/rwhoisd
new file mode 100644
index 00000000000..8e02214c8d0
--- /dev/null
+++ b/net-misc/rwhoisd/files/rwhoisd
@@ -0,0 +1,17 @@
+#!/sbin/runscript
+
+depend() {
+ use logger
+}
+
+start() {
+ ebegin "Starting rwhoisd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/rwhoisd -- ${RWHOISD_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping rwhoisd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/rwhoisd
+ eend $?
+}
diff --git a/net-misc/rwhoisd/files/rwhoisd-destdir-1.5.9.5.patch b/net-misc/rwhoisd/files/rwhoisd-destdir-1.5.9.5.patch
new file mode 100644
index 00000000000..6cd6b28f2e5
--- /dev/null
+++ b/net-misc/rwhoisd/files/rwhoisd-destdir-1.5.9.5.patch
@@ -0,0 +1,39 @@
+--- a/tools/rwhois_repack/Makefile.in
++++ b/tools/rwhois_repack/Makefile.in
+@@ -52,9 +52,9 @@
+ # procedural
+
+ install:
+- if [ ! -d $(exec_prefix) ]; then mkdir $(exec_prefix); fi
+- if [ ! -d $(bindir) ]; then mkdir $(bindir); fi
+- $(INSTALL) rwhois_repack $(bindir)
++ if [ ! -d $(DESTDIR)$(exec_prefix) ]; then mkdir $(DESTDIR)$(exec_prefix); fi
++ if [ ! -d $(DESTDIR)$(bindir) ]; then mkdir $(DESTDIR)$(bindir); fi
++ $(INSTALL) rwhois_repack $(DESTDIR)$(bindir)
+
+ uninstall:
+ $(RM) $(bindir)/rwhois_repack
+
+--- a/sample.data/Makefile.in
++++ b/sample.data/Makefile.in
+@@ -10,7 +10,7 @@
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+ bindir = $(exec_prefix)/bin
+-etcdir = $(exec_prefix)/etc
++etcdir = /etc
+
+ srcdir = @srcdir@
+ VPATH = @srcdir@
+
+--- a/sample.data/Makefile.in
++++ b/sample.data/Makefile.in
+@@ -17,7 +17,7 @@
+
+ DESTDIR =
+
+-RWHOIS_ROOT_DIR = $(DESTDIR)$(etcdir)/rwhoisd/samples
++RWHOIS_ROOT_DIR = $(DESTDIR)/var/rwhoisd/samples
+
+ FILES = \
+ a.com \
diff --git a/net-misc/rwhoisd/files/rwhoisd.conf b/net-misc/rwhoisd/files/rwhoisd.conf
new file mode 100644
index 00000000000..eb32d26d55e
--- /dev/null
+++ b/net-misc/rwhoisd/files/rwhoisd.conf
@@ -0,0 +1,7 @@
+# configuration file for /etc/init.d/rwhoisd
+
+OPTS="-c /etc/rwhoisd/rwhoisd.conf"
+
+# Pass any additional options to rwhoisd here.
+
+RWHOISD_OPTS="${OPTS}"