summaryrefslogtreecommitdiff
path: root/net-misc/selfdhcp
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/selfdhcp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/selfdhcp')
-rw-r--r--net-misc/selfdhcp/Manifest1
-rw-r--r--net-misc/selfdhcp/files/selfdhcp-0.2a-buffer-overflow.patch11
-rw-r--r--net-misc/selfdhcp/metadata.xml11
-rw-r--r--net-misc/selfdhcp/selfdhcp-0.2a-r1.ebuild33
4 files changed, 56 insertions, 0 deletions
diff --git a/net-misc/selfdhcp/Manifest b/net-misc/selfdhcp/Manifest
new file mode 100644
index 00000000000..9ee2079eec0
--- /dev/null
+++ b/net-misc/selfdhcp/Manifest
@@ -0,0 +1 @@
+DIST selfdhcp-0.2a.tar.bz2 162803 SHA256 b60d37b288eee05dcaf6b14b1bba184726ec2e3af6dddfdad78f0627878ec8b6 SHA512 3ffb8a6115502c201b37a6c4179f498d4847d469f5d271dd9408d7fe5714d1ebe10428c890d8ab943a6753f3fbc650730139a78b1f71c9972739ea4b886a53bf WHIRLPOOL 830e040d3fb7c0650ed1052cb768e243b7568489f312941fb28fb743f0fbac134b003e83c10358d88202e48deb4b8a318f3efa2442575c8951640491b1164bb6
diff --git a/net-misc/selfdhcp/files/selfdhcp-0.2a-buffer-overflow.patch b/net-misc/selfdhcp/files/selfdhcp-0.2a-buffer-overflow.patch
new file mode 100644
index 00000000000..6f99f7dea89
--- /dev/null
+++ b/net-misc/selfdhcp/files/selfdhcp-0.2a-buffer-overflow.patch
@@ -0,0 +1,11 @@
+--- selfdhcp-0.2a.orig/src/selfdhcp_profiles.c 2004-08-02 18:10:36.000000000 -0400
++++ selfdhcp-0.2a/src/selfdhcp_profiles.c 2011-01-29 11:54:29.132199679 -0500
+@@ -345,7 +345,7 @@
+ {
+ key = xmlNodeListGetString (doc, cur->xmlChildrenNode, 1);
+ err_msg (DBG_PROG, "xml element \"%s\"", (char *) key);
+- strncpy (netconf_buff.domainname, (char *) key, 49);
++ strncpy (netconf_buff.domainname, (char *) key, sizeof(netconf_buff.domainname)-1);
+ netconf_buff.what_is_set &= NETADDR;
+ err_msg (DBG_INFO, "read domain name \"%s\"",
+ netconf_buff.domainname);
diff --git a/net-misc/selfdhcp/metadata.xml b/net-misc/selfdhcp/metadata.xml
new file mode 100644
index 00000000000..e36ea64d115
--- /dev/null
+++ b/net-misc/selfdhcp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <description>This package lacks a primary herd or maintainer.</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">selfdhcp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/selfdhcp/selfdhcp-0.2a-r1.ebuild b/net-misc/selfdhcp/selfdhcp-0.2a-r1.ebuild
new file mode 100644
index 00000000000..f0f6bf0b8ec
--- /dev/null
+++ b/net-misc/selfdhcp/selfdhcp-0.2a-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="a small stealth network autoconfigure software"
+HOMEPAGE="http://selfdhcp.sourceforge.net"
+SRC_URI="mirror://sourceforge/selfdhcp/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-libs/popt
+ dev-libs/libxml2
+ >=net-libs/libnet-1.0.2
+ net-libs/libpcap"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-buffer-overflow.patch"
+}
+
+src_configure() {
+ econf --sysconfdir=/etc --sbindir=/sbin
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog README TODO
+}