summaryrefslogtreecommitdiff
path: root/net-misc/socat
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/socat
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/socat')
-rw-r--r--net-misc/socat/Manifest2
-rw-r--r--net-misc/socat/files/socat-1.7.2.1-long-long.patch64
-rw-r--r--net-misc/socat/files/socat-1.7.2.4-linux-3.17.patch14
-rw-r--r--net-misc/socat/files/socat-1.7.3.0-filan-build.patch30
-rw-r--r--net-misc/socat/metadata.xml5
-rw-r--r--net-misc/socat/socat-1.7.3.0.ebuild50
-rw-r--r--net-misc/socat/socat-2.0.0_beta8.ebuild52
-rw-r--r--net-misc/socat/socat-9999.ebuild53
8 files changed, 270 insertions, 0 deletions
diff --git a/net-misc/socat/Manifest b/net-misc/socat/Manifest
new file mode 100644
index 00000000000..ea769eeaa7f
--- /dev/null
+++ b/net-misc/socat/Manifest
@@ -0,0 +1,2 @@
+DIST socat-1.7.3.0.tar.bz2 474633 SHA256 0767e850c0329b9fdf711c6cd468565cbbb28786ba1a8a1cbd5531d4016b3e04 SHA512 e567efd6cd31a517ffb1622983640396c6c1db93e8cc4be01b6047ac00b2fbd8474ffb9f96d2af33d24939cddb36ee4b71deb87a5a0101b1f1fb959fa436baad WHIRLPOOL 0ea897879e4d21d678e87c03d11c084a418b5ce179021f0f175db2f5877f250b6d56e42e38f6b9dbcdff7ce0d81970573d41b30a77b1768e659785792e5ae03f
+DIST socat-2.0.0-b8.tar.bz2 502766 SHA256 c804579db998fb697431c82829ae03e6a50f342bd41b8810332a5d0661d893ea SHA512 f996e39d20363b307ab5d85116553e3face1911ed4ec33c28c204abcf1b5fe7083487e4d4d742da5b3ac9996ae7745f047eb2e7f430cd56938864cce43b3cf97 WHIRLPOOL 1fa968eff762af8d443a8bcd2986c8189618dc3d059285b736627b59aa5e78f8328d9482ff26e7aacad6c547a28532d217040170093fa9707cbdaf4906ca3282
diff --git a/net-misc/socat/files/socat-1.7.2.1-long-long.patch b/net-misc/socat/files/socat-1.7.2.1-long-long.patch
new file mode 100644
index 00000000000..45a73dccb2c
--- /dev/null
+++ b/net-misc/socat/files/socat-1.7.2.1-long-long.patch
@@ -0,0 +1,64 @@
+https://bugs.gentoo.org/436164
+
+From cbb59d88e2d83ded78bd4b85a0c1a4f37be60589 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Thu, 25 Oct 2012 22:34:12 -0400
+Subject: [PATCH] support long long sizes with more basic types
+
+Some newer ABIs (like x32) use 64bit sizes with basic types.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ compat.h | 16 ++++++++++++++++
+ 1 file changed, 16 insertions(+)
+
+diff --git a/compat.h b/compat.h
+index d581fad..ecff2ee 100644
+--- a/compat.h
++++ b/compat.h
+@@ -232,6 +232,10 @@
+ #define F_time "%ld"
+ # elif HAVE_BASIC_TIME_T==6
+ #define F_time "%lu"
++# elif HAVE_BASIC_TIME_T==7
++#define F_time "%Ld"
++# elif HAVE_BASIC_TIME_T==8
++#define F_time "%Lu"
+ # else
+ #error "HAVE_BASIC_TIME_T is out of range:" HAVE_BASIC_TIME_T
+ # endif
+@@ -256,6 +260,10 @@
+ #define F_socklen "%ld"
+ # elif HAVE_BASIC_SOCKLEN_T==6
+ #define F_socklen "%lu"
++# elif HAVE_BASIC_SOCKLEN_T==7
++#define F_socklen "%Ld"
++# elif HAVE_BASIC_SOCKLEN_T==8
++#define F_socklen "%Lu"
+ # else
+ #error "HAVE_BASIC_SOCKLEN_T is out of range:" HAVE_BASIC_SOCKLEN_T
+ # endif
+@@ -404,6 +412,10 @@
+ #define F_st_nlink "%ld"
+ # elif HAVE_TYPEOF_ST_NLINK==6
+ #define F_st_nlink "%lu"
++# elif HAVE_TYPEOF_ST_NLINK==7
++#define F_st_nlink "%Ld"
++# elif HAVE_TYPEOF_ST_NLINK==8
++#define F_st_nlink "%Lu"
+ # else
+ #error "HAVE_TYPEOF_ST_NLINK is out of range:" HAVE_TYPEOF_ST_NLINK
+ # endif
+@@ -481,6 +493,10 @@
+ #define F_st_blksize "%ld"
+ # elif HAVE_TYPEOF_ST_BLKSIZE==6
+ #define F_st_blksize "%lu"
++# elif HAVE_TYPEOF_ST_BLKSIZE==7
++#define F_st_blksize "%Ld"
++# elif HAVE_TYPEOF_ST_BLKSIZE==8
++#define F_st_blksize "%Lu"
+ # else
+ #error "HAVE_TYPEOF_ST_BLKSIZE is out of range:" HAVE_TYPEOF_ST_BLKSIZE
+ # endif
+--
+1.7.12
diff --git a/net-misc/socat/files/socat-1.7.2.4-linux-3.17.patch b/net-misc/socat/files/socat-1.7.2.4-linux-3.17.patch
new file mode 100644
index 00000000000..6bf990a9b61
--- /dev/null
+++ b/net-misc/socat/files/socat-1.7.2.4-linux-3.17.patch
@@ -0,0 +1,14 @@
+--- a/configure.in
++++ b/configure.in
+@@ -80,7 +80,10 @@
+ AC_CHECK_HEADERS(termios.h linux/if_tun.h)
+ AC_CHECK_HEADERS(net/if_dl.h)
+ AC_CHECK_HEADERS(linux/types.h)
+-AC_CHECK_HEADER(linux/errqueue.h, AC_DEFINE(HAVE_LINUX_ERRQUEUE_H), [], [#include <linux/types.h>])
++AC_CHECK_HEADER(linux/errqueue.h, AC_DEFINE(HAVE_LINUX_ERRQUEUE_H), [], [AC_INCLUDES_DEFAULT
++ #if HAVE_LINUX_TYPES_H
++ #include <linux/types.h>
++ #endif])
+ AC_CHECK_HEADERS(sys/utsname.h sys/select.h sys/file.h)
+ AC_CHECK_HEADERS(util.h bsd/libutil.h libutil.h sys/stropts.h regex.h)
+ AC_CHECK_HEADERS(linux/fs.h linux/ext2_fs.h)
diff --git a/net-misc/socat/files/socat-1.7.3.0-filan-build.patch b/net-misc/socat/files/socat-1.7.3.0-filan-build.patch
new file mode 100644
index 00000000000..861c673ad91
--- /dev/null
+++ b/net-misc/socat/files/socat-1.7.3.0-filan-build.patch
@@ -0,0 +1,30 @@
+From aae2ea107b543fa908956f2fdcdf6db684e4a2e6 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@chromium.org>
+Date: Fri, 24 Apr 2015 23:06:37 -0400
+Subject: [PATCH] filan: fix depend list
+
+The link line contains more objects than the depend line; sync them like
+procan does. Otherwise, parallel builds randomly fail.
+---
+ Makefile.in | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index f2a6edb..0c00459 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -118,8 +118,9 @@ PROCAN_OBJS=procan_main.o procan.o procan-cdefs.o hostan.o error.o sycls.o sysut
+ procan: $(PROCAN_OBJS)
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(PROCAN_OBJS) $(CLIBS)
+
+-filan: filan_main.o filan.o fdname.o error.o sycls.o sysutils.o utils.o
+- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ filan_main.o filan.o fdname.o error.o sycls.o sysutils.o utils.o vsnprintf_r.o snprinterr.o $(CLIBS)
++FILAN_OBJS=filan_main.o filan.o fdname.o error.o sycls.o sysutils.o utils.o vsnprintf_r.o snprinterr.o
++filan: $(FILAN_OBJS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(FILAN_OBJS) $(CLIBS)
+
+ libxio.a: $(XIOOBJS) $(UTLOBJS)
+ $(AR) r $@ $(XIOOBJS) $(UTLOBJS)
+--
+2.3.5
+
diff --git a/net-misc/socat/metadata.xml b/net-misc/socat/metadata.xml
new file mode 100644
index 00000000000..78692635ad2
--- /dev/null
+++ b/net-misc/socat/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+</pkgmetadata>
diff --git a/net-misc/socat/socat-1.7.3.0.ebuild b/net-misc/socat/socat-1.7.3.0.ebuild
new file mode 100644
index 00000000000..9ae11f6b0a6
--- /dev/null
+++ b/net-misc/socat/socat-1.7.3.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Multipurpose relay (SOcket CAT)"
+HOMEPAGE="http://www.dest-unreach.org/socat/"
+MY_P=${P/_beta/-b}
+S="${WORKDIR}/${MY_P}"
+SRC_URI="http://www.dest-unreach.org/socat/download/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="ssl readline ipv6 tcpd"
+
+DEPEND="
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ readline? ( >=sys-libs/readline-4.1 )
+ tcpd? ( sys-apps/tcp-wrappers )
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+DOCS=(
+ BUGREPORTS CHANGES DEVELOPMENT EXAMPLES FAQ FILES PORTING README SECURITY
+)
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-filan-build.patch
+}
+
+src_configure() {
+ filter-flags '-Wno-error*' #293324
+ tc-export AR
+ econf \
+ $(use_enable ssl openssl) \
+ $(use_enable readline) \
+ $(use_enable ipv6 ip6) \
+ $(use_enable tcpd libwrap)
+}
+
+src_install() {
+ default
+
+ dohtml doc/*.html doc/*.css
+}
diff --git a/net-misc/socat/socat-2.0.0_beta8.ebuild b/net-misc/socat/socat-2.0.0_beta8.ebuild
new file mode 100644
index 00000000000..eb6735580dc
--- /dev/null
+++ b/net-misc/socat/socat-2.0.0_beta8.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Multipurpose relay (SOcket CAT)"
+HOMEPAGE="http://www.dest-unreach.org/socat/"
+MY_P=${P/_beta/-b}
+S="${WORKDIR}/${MY_P}"
+SRC_URI="http://www.dest-unreach.org/socat/download/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="ssl readline ipv6 tcpd"
+
+DEPEND="
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ readline? ( >=sys-libs/readline-4.1 )
+ tcpd? ( sys-apps/tcp-wrappers )
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+DOCS=(
+ BUGREPORTS CHANGES DEVELOPMENT EXAMPLES FAQ FILES PORTING README SECURITY
+)
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.7.3.0-filan-build.patch
+ touch doc/${PN}.1 || die
+}
+
+src_configure() {
+ filter-flags -Wall '-Wno-error*' #293324
+ tc-export AR
+ econf \
+ $(use_enable ssl openssl) \
+ $(use_enable readline) \
+ $(use_enable ipv6 ip6) \
+ $(use_enable tcpd libwrap)
+}
+
+src_install() {
+ default
+
+ dohtml doc/*.html doc/*.css
+}
diff --git a/net-misc/socat/socat-9999.ebuild b/net-misc/socat/socat-9999.ebuild
new file mode 100644
index 00000000000..e931a19da14
--- /dev/null
+++ b/net-misc/socat/socat-9999.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils flag-o-matic git-r3 toolchain-funcs
+
+DESCRIPTION="Multipurpose relay (SOcket CAT)"
+HOMEPAGE="http://www.dest-unreach.org/socat/"
+MY_P=${P/_beta/-b}
+S="${WORKDIR}/${MY_P}"
+EGIT_REPO_URI="git://repo.or.cz/${PN}.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="ssl readline ipv6 tcpd"
+
+RDEPEND="
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ readline? ( >=sys-libs/readline-4.1 )
+ tcpd? ( sys-apps/tcp-wrappers )
+"
+DEPEND="
+ ${RDEPEND}
+ app-text/yodl
+"
+
+RESTRICT="test"
+
+DOCS=(
+ BUGREPORTS CHANGES DEVELOPMENT EXAMPLES FAQ FILES PORTING README SECURITY
+)
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ filter-flags '-Wno-error*' #293324
+ tc-export AR
+ econf \
+ $(use_enable ssl openssl) \
+ $(use_enable readline) \
+ $(use_enable ipv6 ip6) \
+ $(use_enable tcpd libwrap)
+}
+
+src_install() {
+ default
+
+ dohtml doc/*.html doc/*.css
+}