summaryrefslogtreecommitdiff
path: root/net-misc/spread
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-05-03 19:51:44 -0500
committerAustin English <wizardedit@gentoo.org>2016-05-03 19:51:44 -0500
commitb372beb51de84f4f5268c717c52e6aea6722bf37 (patch)
treeda8759eb337c4c8489a99b2dc22f97797c2a4591 /net-misc/spread
parent002d11e0f28a1b6b55d5ed71e6b07da43d9901aa (diff)
downloadgentoo-b372beb51de84f4f5268c717c52e6aea6722bf37.tar.gz
gentoo-b372beb51de84f4f5268c717c52e6aea6722bf37.tar.xz
net-misc/spread: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/573846 Package-Manager: portage-2.2.26
Diffstat (limited to 'net-misc/spread')
-rw-r--r--net-misc/spread/files/spread.init.d5
-rw-r--r--net-misc/spread/spread-4.1.0-r1.ebuild40
-rw-r--r--net-misc/spread/spread-4.3.0-r1.ebuild39
3 files changed, 81 insertions, 3 deletions
diff --git a/net-misc/spread/files/spread.init.d b/net-misc/spread/files/spread.init.d
index b62ec6e33a7..9d551840a34 100644
--- a/net-misc/spread/files/spread.init.d
+++ b/net-misc/spread/files/spread.init.d
@@ -1,8 +1,7 @@
-#!/sbin/runscript
-# Copyright 1999-2014 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-# $Id$
depend() {
need net
diff --git a/net-misc/spread/spread-4.1.0-r1.ebuild b/net-misc/spread/spread-4.1.0-r1.ebuild
new file mode 100644
index 00000000000..67438ab76df
--- /dev/null
+++ b/net-misc/spread/spread-4.1.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+inherit user
+
+MY_PN="spread-src"
+
+DESCRIPTION="Distributed network messaging system"
+HOMEPAGE="http://www.spread.org"
+SRC_URI="mirror://gentoo/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="Spread-1.0 GPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+pkg_setup() {
+ enewuser spread
+ enewgroup spread
+}
+
+src_prepare() {
+ default
+
+ # don't strip binaries
+ sed -i -e 's/0755 -s/0755/g' daemon/Makefile.in examples/Makefile.in
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}" install
+ newinitd "${FILESDIR}"/spread.init.d spread
+ dodir /var/run/spread
+}
diff --git a/net-misc/spread/spread-4.3.0-r1.ebuild b/net-misc/spread/spread-4.3.0-r1.ebuild
new file mode 100644
index 00000000000..57978f74da8
--- /dev/null
+++ b/net-misc/spread/spread-4.3.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+inherit user
+
+MY_PN="spread-src"
+
+DESCRIPTION="Distributed network messaging system"
+HOMEPAGE="http://www.spread.org"
+SRC_URI="mirror://gentoo/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="Spread-1.0 GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+pkg_setup() {
+ enewuser spread
+ enewgroup spread
+}
+
+src_prepare() {
+ default
+
+ # don't strip binaries
+ sed -i -e 's/0755 -s/0755/g' daemon/Makefile.in examples/Makefile.in
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}" install
+ newinitd "${FILESDIR}"/spread.init.d spread
+}