summaryrefslogtreecommitdiff
path: root/net-misc/sstp-client/sstp-client-1.0.9-r1.ebuild
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/sstp-client/sstp-client-1.0.9-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/sstp-client/sstp-client-1.0.9-r1.ebuild')
-rw-r--r--net-misc/sstp-client/sstp-client-1.0.9-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/net-misc/sstp-client/sstp-client-1.0.9-r1.ebuild b/net-misc/sstp-client/sstp-client-1.0.9-r1.ebuild
new file mode 100644
index 00000000000..2bcb0622237
--- /dev/null
+++ b/net-misc/sstp-client/sstp-client-1.0.9-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils linux-info multilib user
+
+DESCRIPTION="A client implementation of Secure Socket Tunneling Protocol (SSTP)"
+HOMEPAGE="http://sstp-client.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sstp-client/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static"
+
+RDEPEND=">=dev-libs/libevent-2.0.10
+ dev-libs/openssl:0
+ net-dialup/ppp:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+CONFIG_CHECK="~NETFILTER_NETLINK"
+DOCS=( AUTHORS ChangeLog DEVELOPERS INSTALL NEWS README TODO USING )
+
+pkg_setup() {
+ enewgroup sstpc
+ enewuser sstpc -1 -1 -1 sstpc
+}
+
+src_prepare() {
+ # set proper examples dir, --docdir overriding is src_configure does not work
+ sed -i -e "/^docdir/s:@PACKAGE@:${PF}/examples:" Makefile.in || die 'sed on Makefile.in failed'
+
+ epatch_user
+}
+
+src_configure() {
+ local PPPD_VER="$(best_version net-dialup/ppp)"
+ PPPD_VER=${PPPD_VER#*/*-} #reduce it to ${PV}-${PR}
+ PPPD_VER=${PPPD_VER%%[_-]*} # main version without beta/pre/patch/revision
+ econf \
+ --enable-ppp-plugin \
+ --enable-group=sstpc \
+ --enable-user=sstpc \
+ --with-pppd-plugin-dir="/usr/$(get_libdir)/pppd/${PPPD_VER}" \
+ $(use_enable static)
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+}