summaryrefslogtreecommitdiff
path: root/net-misc/switzerland
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/switzerland
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/switzerland')
-rw-r--r--net-misc/switzerland/Manifest1
-rw-r--r--net-misc/switzerland/files/Makefile12
-rw-r--r--net-misc/switzerland/metadata.xml14
-rw-r--r--net-misc/switzerland/switzerland-0.1.0.ebuild45
4 files changed, 72 insertions, 0 deletions
diff --git a/net-misc/switzerland/Manifest b/net-misc/switzerland/Manifest
new file mode 100644
index 00000000000..0108f71c1e8
--- /dev/null
+++ b/net-misc/switzerland/Manifest
@@ -0,0 +1 @@
+DIST switzerland-0.1.0.tgz 592922 SHA256 759d7a3dfda9e71ee309410c741342393585e9a0328d8f0d7ebf2049f319bd60 SHA512 3a5474c005bf45cddf8eede7c1e2faa5855bf9017f5c732555cfe2c8b7b82381ea25c2ada000a9945a330ff3af19f1e861a11508ff057c81a78eab53de1d0cdb WHIRLPOOL 8ac597d03a7ab39af9aad817ea850a5376e5fdacc4879df97a46fccfd97e7cc418dfc70f964873e618d8e9eee967b37fa1de80b5c75def0eb768219103455e0c
diff --git a/net-misc/switzerland/files/Makefile b/net-misc/switzerland/files/Makefile
new file mode 100644
index 00000000000..c1e582d56dc
--- /dev/null
+++ b/net-misc/switzerland/files/Makefile
@@ -0,0 +1,12 @@
+SRC = FastCollector.c
+OBJ = ${SRC:.c=.o}
+
+LIBS = -lpcap
+
+all: FastCollector
+
+.c.o:
+ $(CC) -c $(CFLAGS) $<
+
+FastCollector: $(OBJ)
+ $(CC) -o $@ $(CFLAGS) $(LDFLAGS) $(OBJ) $(LIBS)
diff --git a/net-misc/switzerland/metadata.xml b/net-misc/switzerland/metadata.xml
new file mode 100644
index 00000000000..f1752c72738
--- /dev/null
+++ b/net-misc/switzerland/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <longdescription lang="en">
+ Switzerland is an open source software tool for testing the integrity of
+ data communications over networks, ISPs and firewalls. It will spot IP
+ packets which are forged or modified between clients, inform you, and
+ give you copies of the modified packets.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">switzerland</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/switzerland/switzerland-0.1.0.ebuild b/net-misc/switzerland/switzerland-0.1.0.ebuild
new file mode 100644
index 00000000000..592ded40069
--- /dev/null
+++ b/net-misc/switzerland/switzerland-0.1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Network Testing Tool"
+HOMEPAGE="http://www.eff.org/testyourisp/switzerland/"
+SRC_URI="mirror://sourceforge/switzerland/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="net-libs/libpcap"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ cp "${FILESDIR}"/Makefile switzerland/client
+
+ sed -i \
+ -e "s/= find_binary()/= dest/" \
+ setup.py
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ cd switzerland/client
+ emake CC=$(tc-getCC)
+
+ cd "${S}"
+ distutils-r1_src_compile
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ dodoc BUGS.txt CREDITS
+
+ keepdir /var/log/switzerland-pcaps
+ keepdir /var/log/switzerland
+}