summaryrefslogtreecommitdiff
path: root/net-misc/termpkg
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/termpkg
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/termpkg')
-rw-r--r--net-misc/termpkg/Manifest2
-rw-r--r--net-misc/termpkg/files/termnetd.confd14
-rw-r--r--net-misc/termpkg/files/termnetd.initd52
-rw-r--r--net-misc/termpkg/files/termpkg-3.3-ttydforfax.diff28
-rw-r--r--net-misc/termpkg/files/termpkg-3.3.9.1-gcc43.diff11
-rw-r--r--net-misc/termpkg/files/ttyd.confd63
-rw-r--r--net-misc/termpkg/files/ttyd.initd96
-rw-r--r--net-misc/termpkg/metadata.xml17
-rw-r--r--net-misc/termpkg/termpkg-3.3.9.1-r1.ebuild65
-rw-r--r--net-misc/termpkg/termpkg-3.3.9.1.ebuild58
10 files changed, 406 insertions, 0 deletions
diff --git a/net-misc/termpkg/Manifest b/net-misc/termpkg/Manifest
new file mode 100644
index 00000000000..f0b29750900
--- /dev/null
+++ b/net-misc/termpkg/Manifest
@@ -0,0 +1,2 @@
+DIST termpkg_3.3-9.1.diff.gz 6759 SHA256 3ece3bc9ae469c45a8eba24ccd46c9460e2f03a215e4ec5f7c8fb0d41598b211 SHA512 dbcba1bc020ead0ef5e4f2fb2e7ee50937dbd6d614e53547bf2473dc3cbf0f4f3100a15bcd200b815a4fcbfd454a08a3185cdb305c4f3bde389070b5545293d4 WHIRLPOOL 87cb0182b4ff5124e43d3fcc16557a7d0dbd888a3d89b466f8b89b785073eb383b29d78ad28bdcdf4f0fa36c1a4353a1dc5a5b82c970d4bc2f3fc53e2c734a4b
+DIST termpkg_3.3.orig.tar.gz 65807 SHA256 0497f30d3fdac114080b65476d2757211a21276ae32c269d91314e3d54b9eff0 SHA512 4dc1152af27af5edda66622435f5c5d46e9bbba9dc3e9e0d6349792efef9488993d9ea02eb8780bc05a0a29756a0ba3cf45bf8d1799906b55d166c287432c22c WHIRLPOOL 0a5f789d2521e3b460fd174bc647efef00d89ea2e53668002ac210ee859e810cb04d8ab7bd0b41e653d2d4a105566fa045ced92231ca6e0b8567c4efa049ca0b
diff --git a/net-misc/termpkg/files/termnetd.confd b/net-misc/termpkg/files/termnetd.confd
new file mode 100644
index 00000000000..4eb95a989d4
--- /dev/null
+++ b/net-misc/termpkg/files/termnetd.confd
@@ -0,0 +1,14 @@
+# Config file for /etc/init.d/termnetd
+
+# Set the configuration file to one other than the default of /etc/termnetd.conf
+#
+#CONFIG_FILE="/etc/termnetd.conf"
+
+# Sets the IP port to listen to for the control port (default = none).
+#
+#CONTROL_PORT=""
+
+# see the termnetd(1) manual page for additional options you can configure here
+#
+#EXTRA_OPTS=""
+
diff --git a/net-misc/termpkg/files/termnetd.initd b/net-misc/termpkg/files/termnetd.initd
new file mode 100644
index 00000000000..90e2462f4fd
--- /dev/null
+++ b/net-misc/termpkg/files/termnetd.initd
@@ -0,0 +1,52 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+description="Terminal Server daemon (${RC_SVCNAME#*.})"
+command="/usr/sbin/termnetd"
+name="${RC_SVCNAME}"
+
+extra_started_commands="reload"
+description_reload="Reread configuration file and make the appropriate changes"
+start_stop_daemon_args="--quiet --exec ${command} --name ${name}"
+
+depend() {
+ use logger
+ need net
+}
+
+config_check() {
+ command_args="${EXTRA_OPTS}"
+ CONFIG_FILE_DEFAULT="/etc/termnetd.conf"
+
+ [ -z "${CONFIG_FILE}" ] && CONFIG_FILE="${CONFIG_FILE_DEFAULT}"
+ [ -n "${CONTROL_PORT}" ] && command_args="${command_args} -s ${CONTROL_PORT}"
+ [ "${CONFIG_FILE}" != "${CONFIG_FILE_DEFAULT}" ] && command_args="${command_args} -c ${CONFIG_FILE}"
+
+ if [ ! -f "${CONFIG_FILE}" ]; then
+ eerror "Please create ${CONFIG_FILE}"
+ eerror "Sample conf: ${CONFIG_FILE_DEFAULT}.dist"
+ return 1
+ fi
+ return 0
+}
+
+start() {
+ config_check || return ${?}
+ ebegin "Starting ${description}"
+ start-stop-daemon --start ${start_stop_daemon_args} -- ${command_args}
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping ${description}"
+ start-stop-daemon --stop ${start_stop_daemon_args}
+ eend ${?}
+}
+
+reload() {
+ ebegin "Reloading ${description}"
+ start-stop-daemon --signal HUP ${start_stop_daemon_args}
+ eend ${?}
+}
diff --git a/net-misc/termpkg/files/termpkg-3.3-ttydforfax.diff b/net-misc/termpkg/files/termpkg-3.3-ttydforfax.diff
new file mode 100644
index 00000000000..0471fde1315
--- /dev/null
+++ b/net-misc/termpkg/files/termpkg-3.3-ttydforfax.diff
@@ -0,0 +1,28 @@
+--- termpkg-3.3/termnet/ttyd.c.orig 2005-09-29 08:59:05.000000000 -1000
++++ termpkg-3.3/termnet/ttyd.c 2005-09-29 08:51:33.000000000 -1000
+@@ -340,7 +340,10 @@
+ char *cp;
+ int x;
+ for (cp = commbuf, x = 0; x < cnt; x++, cp++)
++if (isprint(*cp))
+ syslog(LOG_DEBUG, "ttyd: Have net char 0x%x, |%c|", *cp, *cp);
++else
++syslog(LOG_DEBUG, "ttyd: Have net char 0x%x", *cp);
+ }
+ write(fd, commbuf, cnt);
+ }
+@@ -366,9 +369,13 @@
+ char *cp;
+ int x;
+ for (cp = commbuf, x = 0; x < cnt; x++, cp++)
++if (isprint(*cp))
+ syslog(LOG_DEBUG, "ttyd: Have key char 0x%x, |%c|", *cp, *cp);
++else
++syslog(LOG_DEBUG, "ttyd: Have key char 0x%x", *cp);
+ }
+- inputTerminal(commbuf, cnt);
++// inputTerminal(commbuf, cnt);
++write(fileno(tnlout), commbuf, cnt);
+ }
+ else
+ break;
diff --git a/net-misc/termpkg/files/termpkg-3.3.9.1-gcc43.diff b/net-misc/termpkg/files/termpkg-3.3.9.1-gcc43.diff
new file mode 100644
index 00000000000..8d17fc5dd8b
--- /dev/null
+++ b/net-misc/termpkg/files/termpkg-3.3.9.1-gcc43.diff
@@ -0,0 +1,11 @@
+diff -Naur termpkg-3.3.orig/libtn/SocketIO.c termpkg-3.3/libtn/SocketIO.c
+--- termpkg-3.3.orig/libtn/SocketIO.c 2008-09-03 18:21:28.881220673 +0200
++++ termpkg-3.3/libtn/SocketIO.c 2008-09-03 18:23:29.106343243 +0200
+@@ -25,6 +25,7 @@
+ #endif
+ #include <sys/socket.h>
+ #include <netinet/in.h>
++#include <arpa/inet.h>
+ #include <fcntl.h>
+ #include <string.h>
+ #include <stdlib.h>
diff --git a/net-misc/termpkg/files/ttyd.confd b/net-misc/termpkg/files/ttyd.confd
new file mode 100644
index 00000000000..5b0e2b8c000
--- /dev/null
+++ b/net-misc/termpkg/files/ttyd.confd
@@ -0,0 +1,63 @@
+# Configfile for /etc/init.d/ttyd
+
+# HINT: if you only need one virtual TTY, then you can use this config.
+# Otherwise you should use it as a template for specific configurations.
+# Just copy /etc/conf.d/ttyd to /etc/conf.d/ttyd.<foo> and symlink
+# /etc/init.d/ttyd to /etc/init.d/ttyd.<foo>
+
+
+# Master pseudo tty device to open and wait for a connection on.
+# For reference, in Linux the master pseudo tty devices are the
+# devices /dev/pty[a-ep-z][0-9a-f] and the slave devices are
+# /dev/tty[a-ep-z][0-9a-f].
+#
+PTY="/dev/ptyp0"
+
+# The host and port parameters specify the host and IP port to
+# connect to when the slave pseudo device is opened.
+#
+HOST="host.example.com"
+PORT=3000
+
+# The optional mode and user options specify the filesystem
+# permissions of the slave pseudo device. We set them right
+# after the ttyd daemon has started. After stopping, we reset
+# them to the permissions of the master pseudo device.
+#
+#MODE=660
+#USER="root:uucp"
+
+# Sets the initial baud-rate of the device (optional).
+#
+#BAUDRATE=115200
+
+# Optional port settings. Specified by a string of one of
+# more of the following concatenated together with no
+# intervening spaces:
+#
+# 8: 8 bits/character
+# 7: 7 bits/character
+# 6: 6 bits/character
+# 5: 5 bits/character
+# N: No parity
+# E: Even parity
+# O: Odd parity
+# C0: No hardware flow control
+# C1: Hardware flow control
+# S0: No software flow control
+# S1: Software flow control
+#
+#PORT_SETTINGS="8NC0"
+
+# You can create symlinks to the slave pseudo device, so you
+# have an easy to remember name for your virtual device. You
+# can add as many links as you want, if you blank-seperate the
+# names. All links *must* be relative and beneath to /dev.
+#
+#SYMLINK="ttyd/modem ttyNET0"
+
+# Some odd programs just don't work with symlinks, so you
+# can also create hardlinks (even in addition to symlinks).
+# Same rules apply as for symlinks.
+#
+#HARDLINK="ttyS5"
diff --git a/net-misc/termpkg/files/ttyd.initd b/net-misc/termpkg/files/ttyd.initd
new file mode 100644
index 00000000000..abcb691f360
--- /dev/null
+++ b/net-misc/termpkg/files/ttyd.initd
@@ -0,0 +1,96 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+description="Remote Modem Utility (${RC_SVCNAME#*.})"
+command="/usr/sbin/ttyd"
+name="${RC_SVCNAME}"
+
+start_stop_daemon_args="--quiet --exec ${command} --name ${name}"
+
+depend() {
+ use logger
+ need net
+}
+
+config_check() {
+ # sanitize PTY/TTY names
+ DEV_PTY="/dev/${PTY/\/dev\/}"
+ DEV_TTY="${DEV_PTY/\/pty//tty}"
+
+ # create command args
+ command_args="-d ${DEV_PTY}"
+ [ -n "${BAUDRATE}" ] && command_args="${command_args} -b ${BAUDRATE}"
+ [ -n "${PORT_SETTINGS}" ] && command_args="${command_args} -p ${PORT_SETTINGS}"
+ command_args="${command_args} ${HOST} ${PORT}"
+}
+
+device_check() {
+ if [ ! -e "${DEV_PTY}" ]; then
+ eerror "PTY doesn't exist: ${DEV_PTY}"
+ return 1
+ fi
+ if [ ! -e "${DEV_TTY}" ]; then
+ eerror "TTY doesn't exist: ${DEV_TTY}"
+ return 1
+ fi
+ return 0
+}
+
+linkrel() { # <from> <to>
+ local LINK="${1%/*}/${2/\/dev\/}"
+ echo "${LINK/\/dev\/}" | sed "s:[^/]\+/:../:g"
+}
+
+setup_links() {
+ local LINK NODE
+ for LINK in ${SYMLINK}; do
+ NODE="/dev/${LINK/\/dev\/}"
+ mkdir -p -- "${NODE%/*}" && ln -snf -- $(linkrel "${NODE}" "${DEV_TTY}") "${NODE}"
+ done
+ for LINK in ${HARDLINK}; do
+ NODE="/dev/${LINK/\/dev\/}"
+ mkdir -p -- "${NODE%/*}" && ln -nf -- "${DEV_TTY}" "${NODE}"
+ done
+}
+
+unset_links() {
+ local LINK LIST=""
+ for LINK in ${SYMLINK} ${HARDLINK}; do
+ LIST="${LIST} /dev/${LINK/\/dev\/}"
+ done
+ [ -n "${LIST}" ] && rm -f -- ${LIST}
+}
+
+setup_perms() {
+ [ -n "${MODE}" ] && chmod "${MODE}" -- "${DEV_TTY}"
+ [ -n "${USER}" ] && chown "${USER}" -- "${DEV_TTY}"
+}
+
+unset_perms() {
+ [ -n "${USER}" ] && chown --reference "${DEV_PTY}" -- "${DEV_TTY}"
+ [ -n "${MODE}" ] && chmod --reference "${DEV_PTY}" -- "${DEV_TTY}"
+}
+
+start() {
+ config_check || return ${?}
+ device_check || return ${?}
+ ebegin "Starting ${description}"
+ start-stop-daemon --start ${start_stop_daemon_args} -- ${command_args}
+ if eend ${?}; then
+ setup_perms
+ setup_links
+ return 0 # from here we never fail
+ fi
+}
+
+stop() {
+ config_check || return ${?}
+ ebegin "Stopping ${description}"
+ start-stop-daemon --stop ${start_stop_daemon_args}
+ eend ${?}
+ unset_links
+ unset_perms
+ return 0 # never fail
+}
diff --git a/net-misc/termpkg/metadata.xml b/net-misc/termpkg/metadata.xml
new file mode 100644
index 00000000000..7bbee5227ce
--- /dev/null
+++ b/net-misc/termpkg/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-dialup</herd>
+ <longdescription lang="en">
+ Termpkg is a terminal server daemon and simple telnet like client.
+ Allows access to one or more serial ports through the telnet protocol.
+ Can be configured to connect in a one to one relation of telnet ports
+ to serial ports or in a round-robin fashion where one telnet port
+ serves many serial ports.
+ </longdescription>
+ <use>
+ <flag name='uucp'>
+ Adds support for uucp style device locking
+ </flag>
+ </use>
+</pkgmetadata>
diff --git a/net-misc/termpkg/termpkg-3.3.9.1-r1.ebuild b/net-misc/termpkg/termpkg-3.3.9.1-r1.ebuild
new file mode 100644
index 00000000000..a92fbf0b147
--- /dev/null
+++ b/net-misc/termpkg/termpkg-3.3.9.1-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit base versionator
+
+MY_PV=$(get_version_component_range 1-2)
+MY_PF=$(replace_version_separator 2 '-')
+
+DESCRIPTION="Termpkg, the Poor Man's Terminal Server"
+HOMEPAGE="http://www.linuxlots.com/~termpkg/"
+SRC_URI="mirror://debian/pool/main/t/termpkg/${PN}_${MY_PV}.orig.tar.gz
+ mirror://debian/pool/main/t/termpkg/${PN}_${MY_PF}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+uucp"
+
+DEPEND="sys-devel/flex"
+RDEPEND=""
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+DOCS=(
+ "README"
+ "CHANGES"
+ "termpkg.lsm"
+)
+
+PATCHES=(
+ # debian patches
+ "${WORKDIR}/${PN}_${MY_PF}.diff"
+
+ # gentoo patches
+ "${FILESDIR}/${P}-gcc43.diff"
+
+ # iaxmodem patches
+ "${FILESDIR}/${PN}-${MY_PV}-ttydforfax.diff"
+)
+
+src_configure() {
+ ./configure LINUX $(use uucp && echo UUCP_LOCKING)
+}
+
+src_compile() {
+ emake -C linux CC=$(tc-getCC) LIBS="${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ local X
+ base_src_install_docs
+ dobin linux/bin/termnet
+ dosbin linux/bin/{termnetd,ttyd}
+ newdoc debian/changelog ChangeLog.debian
+ doman doc/*.1
+ insinto /etc
+ newins debian/termnetd.conf termnetd.conf.dist
+ for X in termnetd ttyd; do
+ newinitd "${FILESDIR}/${X}.initd" "${X}"
+ newconfd "${FILESDIR}/${X}.confd" "${X}"
+ done
+}
diff --git a/net-misc/termpkg/termpkg-3.3.9.1.ebuild b/net-misc/termpkg/termpkg-3.3.9.1.ebuild
new file mode 100644
index 00000000000..b571c2cbf00
--- /dev/null
+++ b/net-misc/termpkg/termpkg-3.3.9.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils versionator
+
+MY_PV=$(get_version_component_range 1-2)
+MY_PF=$(replace_version_separator 2 '-')
+
+DESCRIPTION="Termpkg, the Poor Man's Terminal Server"
+HOMEPAGE="http://www.linuxlots.com/~termpkg/"
+SRC_URI="mirror://debian/pool/main/t/termpkg/${PN}_${MY_PV}.orig.tar.gz
+ mirror://debian/pool/main/t/termpkg/${PN}_${MY_PF}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="uucp"
+
+DEPEND="sys-devel/flex"
+RDEPEND="sys-process/procps"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ # apply debian patches
+ epatch "${WORKDIR}/${PN}_${MY_PF}.diff"
+
+ # apply gentoo patches
+ epatch "${FILESDIR}/${P}-gcc43.diff"
+
+ # apply iaxmodem patches
+ epatch "${FILESDIR}/${PN}-${MY_PV}-ttydforfax.diff"
+}
+
+src_configure() {
+ ./configure LINUX $(use uucp && echo UUCP_LOCKING)
+}
+
+src_compile() {
+ emake -C linux CC=$(tc-getCC) LIBS="${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin linux/bin/termnet
+ dosbin linux/bin/{termnetd,ttyd}
+ dodoc CHANGES README termpkg.lsm
+ newdoc debian/changelog ChangeLog.debian
+ doman doc/*.1
+ insinto /etc
+ newins debian/termnetd.conf termnetd.conf.dist
+ for X in termnetd ttyd; do
+ newinitd "${FILESDIR}/${X}.initd" "${X}"
+ newconfd "${FILESDIR}/${X}.confd" "${X}"
+ done
+}