summaryrefslogtreecommitdiff
path: root/net-misc/tn5250
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-08-17 15:42:48 +0200
committerPacho Ramos <pacho@gentoo.org>2016-08-17 15:50:15 +0200
commitc05665502e8ff0b0b4f7ffdff1f040a28a96489a (patch)
tree0b861c2cabaf676d81049107cf7ed2026f09b6b0 /net-misc/tn5250
parentdc4342af59006609d49cdf88aa2505ce42107d47 (diff)
downloadgentoo-c05665502e8ff0b0b4f7ffdff1f040a28a96489a.tar.gz
gentoo-c05665502e8ff0b0b4f7ffdff1f040a28a96489a.tar.xz
net-misc/tn5250: Bump eapi, stop using deprecated python eclass (python doesn't seem really needed as I see in Fedora package), drop .la files, fix deps.
Package-Manager: portage-2.3.0
Diffstat (limited to 'net-misc/tn5250')
-rw-r--r--net-misc/tn5250/tn5250-0.17.4-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/net-misc/tn5250/tn5250-0.17.4-r1.ebuild b/net-misc/tn5250/tn5250-0.17.4-r1.ebuild
new file mode 100644
index 00000000000..c8457dee242
--- /dev/null
+++ b/net-misc/tn5250/tn5250-0.17.4-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Telnet client for the IBM AS/400 that emulates 5250 terminals and printers"
+HOMEPAGE="http://tn5250.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="X libressl ssl"
+
+RDEPEND="
+ sys-libs/ncurses:=
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+"
+
+DEPEND="${RDEPEND}
+ X? ( x11-libs/libXt )
+"
+
+src_prepare() {
+ default
+ # Next, the Makefile for the terminfo settings tries to remove
+ # some files it doesn't have access to. We can just remove those
+ # lines.
+ cd "${S}/linux"
+ sed -i \
+ -e "/rm -f \/usr\/.*\/terminfo.*5250/d" Makefile.in \
+ || die "sed Makefile.in failed"
+ cd "${S}"
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ --without-python \
+ $(use_with X x) \
+ $(use_with ssl)
+}
+
+src_install() {
+ # The TERMINFO variable needs to be defined for the install
+ # to work, because the install calls "tic." man tic for
+ # details.
+ dodir /usr/share/terminfo
+ emake DESTDIR="${D}" \
+ TERMINFO="${D}/usr/share/terminfo" install
+
+ einstalldocs
+ prune_libtool_files
+}