summaryrefslogtreecommitdiff
path: root/net-misc/vncsnapshot
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/vncsnapshot
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/vncsnapshot')
-rw-r--r--net-misc/vncsnapshot/Manifest1
-rw-r--r--net-misc/vncsnapshot/files/vncsnapshot-1.2a-amd64grey.patch12
-rw-r--r--net-misc/vncsnapshot/metadata.xml11
-rw-r--r--net-misc/vncsnapshot/vncsnapshot-1.2a.ebuild44
4 files changed, 68 insertions, 0 deletions
diff --git a/net-misc/vncsnapshot/Manifest b/net-misc/vncsnapshot/Manifest
new file mode 100644
index 00000000000..fa5f20f37de
--- /dev/null
+++ b/net-misc/vncsnapshot/Manifest
@@ -0,0 +1 @@
+DIST vncsnapshot-1.2a-src.tar.bz2 70121 SHA256 ac490c4b3810d419c65cdfb48d742ca382218c3c0f04e7868520ff9a06149ca6
diff --git a/net-misc/vncsnapshot/files/vncsnapshot-1.2a-amd64grey.patch b/net-misc/vncsnapshot/files/vncsnapshot-1.2a-amd64grey.patch
new file mode 100644
index 00000000000..ee5807b58af
--- /dev/null
+++ b/net-misc/vncsnapshot/files/vncsnapshot-1.2a-amd64grey.patch
@@ -0,0 +1,12 @@
+diff -aur vncsnapshot-1.2a-orig/rfb.h vncsnapshot-1.2a/rfb.h
+--- vncsnapshot-1.2a-orig/rfb.h 2002-02-09 16:00:42.000000000 -0500
++++ vncsnapshot-1.2a/rfb.h 2008-09-24 16:57:13.000000000 -0400
+@@ -34,7 +34,7 @@
+
+ // Define the CARD* types as used in X11/Xmd.h
+
+-typedef unsigned long CARD32;
++typedef unsigned int CARD32;
+ typedef unsigned short CARD16;
+ typedef short INT16;
+ typedef unsigned char CARD8;
diff --git a/net-misc/vncsnapshot/metadata.xml b/net-misc/vncsnapshot/metadata.xml
new file mode 100644
index 00000000000..09b86bb5a8c
--- /dev/null
+++ b/net-misc/vncsnapshot/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <name>Default assignee for orphaned packages</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">vncsnapshot</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/vncsnapshot/vncsnapshot-1.2a.ebuild b/net-misc/vncsnapshot/vncsnapshot-1.2a.ebuild
new file mode 100644
index 00000000000..0826735eba0
--- /dev/null
+++ b/net-misc/vncsnapshot/vncsnapshot-1.2a.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="A command-line tool for taking JPEG snapshots of VNC servers"
+HOMEPAGE="http://vncsnapshot.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+
+DEPEND="
+ virtual/jpeg
+ >=sys-libs/zlib-1.1.4"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-amd64grey.patch"
+ sed \
+ -e 's:-I/usr/local/include::g' \
+ -e 's:-L/usr/local/lib::g' \
+ -e '/^all:/s|$(SUBDIRS:.dir=.all)||g' \
+ -e '/^vnc/s|$| $(SUBDIRS:.dir=.all)|g' \
+ -i Makefile || die
+}
+
+src_compile() {
+ #note: We override CDEBUGFLAGS instead of CFLAGS because otherwise
+ # we lost the INCLUDES in the makefile.
+ # bug #295741
+ emake CDEBUGFLAGS="${CXXFLAGS}" CC="$(tc-getCC)" CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ dobin vncsnapshot
+ cp vncsnapshot.man1 vncsnapshot.1
+ doman vncsnapshot.1
+}