summaryrefslogtreecommitdiff
path: root/net-misc/yajhfc
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/yajhfc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/yajhfc')
-rw-r--r--net-misc/yajhfc/Manifest2
-rw-r--r--net-misc/yajhfc/metadata.xml11
-rw-r--r--net-misc/yajhfc/yajhfc-0.5.2.ebuild33
-rw-r--r--net-misc/yajhfc/yajhfc-0.5.7.ebuild53
4 files changed, 99 insertions, 0 deletions
diff --git a/net-misc/yajhfc/Manifest b/net-misc/yajhfc/Manifest
new file mode 100644
index 00000000000..94a3011756f
--- /dev/null
+++ b/net-misc/yajhfc/Manifest
@@ -0,0 +1,2 @@
+DIST yajhfc-0_5_2.jar 1902262 SHA256 7182a694b1ee6310b94ca7e5ca913cc381c463101dd2d004a92f4c86fb3a4d7e SHA512 0c0ba609a15dd8e79743d4afea75350ba5626676e3fa2dd24835d8d661c894e910ab1df7c69b05f9db4519ffcd3491b774cad89a2b48597e78e23720414c4e73 WHIRLPOOL 971454666b46beb2fc4aebdf8b69e9a47f32eb87e0ed9eefb1c822f2c6791bc38346645acc611aca37797d49389c5965809cb5e10bd1ec4bd01241f0167f48dd
+DIST yajhfc-0_5_7-src.zip 3577450 SHA256 896f394dabe60238114b2e91f40a595e052185b14105b00f073994cb1b454dcc SHA512 9177e959810df9ab005f2ed380275f6683aa22e0b6209d50a96d8f60018c0dc1d624dc400ad6ac2625688d57ecb84401f26dd66b145da518c0c5287c0af4e9f1 WHIRLPOOL 7e75333ea99eab1aa42937a97b0584a8f71a8b126d55e15111a0a460afa5e999d0510fb0d57f245c2b9cd38a92cc4bb1b26850617b15bb29dfd23d05960e7bdb
diff --git a/net-misc/yajhfc/metadata.xml b/net-misc/yajhfc/metadata.xml
new file mode 100644
index 00000000000..75de67d8673
--- /dev/null
+++ b/net-misc/yajhfc/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mattm@gentoo.org</email>
+ <name>Matthew Marlowe</name>
+ </maintainer>
+ <longdescription>
+Client for Hylafax+ Server.
+</longdescription>
+</pkgmetadata>
diff --git a/net-misc/yajhfc/yajhfc-0.5.2.ebuild b/net-misc/yajhfc/yajhfc-0.5.2.ebuild
new file mode 100644
index 00000000000..2e126b29b84
--- /dev/null
+++ b/net-misc/yajhfc/yajhfc-0.5.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils java-pkg-opt-2 versionator
+
+MY_P="${PN}-${PV}.jar"
+MY_P="${MY_P/_/}"
+MY_P="${MY_P/./_}"
+MY_P="${MY_P/./_}"
+
+DESCRIPTION="Yet another Java HylaFAX Plus Client"
+HOMEPAGE="http://www.yajhfc.de/"
+SRC_URI="http://download.yajhfc.de/releases/${MY_P}"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS=""
+IUSE=""
+
+COMMON_DEPEND=">=virtual/jdk-1.4"
+RDEPEND="${COMMON_DEPEND} >=virtual/jre-1.4"
+DEPEND="${COMMON_DEPEND} virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ echo "java -jar /usr/bin/${MY_P}" > "${WORKDIR}"/h.h
+ newbin "${WORKDIR}/h.h" "yajhfc"
+ newbin "${DISTDIR}/${MY_P}" "${MY_P}"
+}
diff --git a/net-misc/yajhfc/yajhfc-0.5.7.ebuild b/net-misc/yajhfc/yajhfc-0.5.7.ebuild
new file mode 100644
index 00000000000..d49aa58ec85
--- /dev/null
+++ b/net-misc/yajhfc/yajhfc-0.5.7.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_P="${PN}-${PV}"
+MY_P="${MY_P/_/}"
+MY_P="${MY_P/./_}"
+MY_P="${MY_P/./_}"
+
+DESCRIPTION="Yet another Java HylaFAX Plus Client"
+HOMEPAGE="http://www.yajhfc.de/"
+SRC_URI="http://download.yajhfc.de/releases/${MY_P}-src.zip"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="dev-java/gnu-hylafax:0
+ dev-java/tablelayout:0"
+RDEPEND="${COMMON_DEPEND} >=virtual/jre-1.6"
+DEPEND="${COMMON_DEPEND} >=virtual/jdk-1.6 virtual/pkgconfig app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+JAVA_GENTOO_CLASSPATH="gnu-hylafax,tablelayout"
+JAVA_SRC_DIR="src"
+
+src_prepare() {
+ rm build.xml || die
+ rm -rv "${S}"/jna-src "${S}"/mac-src || die # contains win32/mac only code
+
+ cp -r java1-src/* src || die
+ cp -r java6-src/* src || die
+
+ # this method is missing in the gnu-hylafax api despite they use the same upstream version
+ sed -i -e 's/client.setCharacterEncoding.*//g' src/yajhfc/HylaClientManager.java || die
+}
+
+src_compile() {
+ java-pkg-simple_src_compile
+ pushd src || die
+ find -type f -not -name "*.java" -not -name "*.class" | xargs jar uf "${S}"/${PN}.jar || die
+}
+
+src_install() {
+ java-pkg-simple_src_install
+ java-pkg_dolauncher ${PN} --jar ${PN}.jar --main yajhfc.Launcher
+}