summaryrefslogtreecommitdiff
path: root/net-misc
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-10-21 21:25:23 -0400
committerAnthony G. Basile <blueness@gentoo.org>2015-10-21 21:26:19 -0400
commit1c8fbe151cdb982fa006bfc9f1b88c75f9ae40b7 (patch)
tree89b2506a41149a7858db11d065ea2e70954f8f05 /net-misc
parent69eb9a4db6fc82aab0650b8f826f83f997dc985d (diff)
downloadgentoo-1c8fbe151cdb982fa006bfc9f1b88c75f9ae40b7.tar.gz
gentoo-1c8fbe151cdb982fa006bfc9f1b88c75f9ae40b7.tar.xz
net-misc/tor: version bump to 0.2.7.4_rc
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/tor/Manifest1
-rw-r--r--net-misc/tor/files/tor-0.2.7.4-torrc.sample.patch31
-rw-r--r--net-misc/tor/tor-0.2.7.4_rc.ebuild99
3 files changed, 131 insertions, 0 deletions
diff --git a/net-misc/tor/Manifest b/net-misc/tor/Manifest
index 4370c29baa2..9fd0dd2b32c 100644
--- a/net-misc/tor/Manifest
+++ b/net-misc/tor/Manifest
@@ -1,2 +1,3 @@
DIST tor-0.2.6.10.tar.gz 3587211 SHA256 0542c0efe43b86619337862fa7eb02c7a74cb23a79d587090628a5f0f1224b8d SHA512 4d1fd794d48ada725af829e1c1f3f3b7d8d04f2d1dd22e4f175ddc49401834f2001f04d78b011cdc7e953fe44972f2859d87078489a08ae126b44f93f6b9a438 WHIRLPOOL ba2685454ecb0dd94c568e05fb14526cd06beea6e9c6f7b27328f85c555392b6f42f35dc7860ae25299a830c7f6643963a9b9719a2557c28a7216019c96caf21
DIST tor-0.2.7.3-rc.tar.gz 4810396 SHA256 aeb84ab84475edef5a0545b5e19f154cc1c28bd6730197ffe0013790157470b8 SHA512 c3a61cffc1a3faaa46918566ef7b7f8718ee655358aa86b6121bf8fc706419af2ead7432c21e7a3e8280cc104fedc2a65a30fdd88d2fc44192b1b2c04917b8d1 WHIRLPOOL a1c13481eaf496d2afcd8c5c12ca07ba8ebabc10342819125b7ccccd96c2f2905f2195339ca195dcfe2492df898a9ca65e8a7b3d5e93a4f1a43781decac7ba3f
+DIST tor-0.2.7.4-rc.tar.gz 4830972 SHA256 6741c3e6abfedb76be781b767b77f794ee1a0f554cc4ccf083e44d4d9dc8af67 SHA512 e637cad37d26f7ceec52e2f78ff53ff2d9e362cefe0796b91fc91c7e2b01652d0333be44e48497cb54650ece3f606b20a7201b806775e9349eef99a288420e59 WHIRLPOOL 85dc797558391dc5e577fcdcb802ea027ff4ac787acfadd90b363bd6c60c7654fa16b15de74a84152ec081dda008a122029198cee5b12bf92730c5d160f7407b
diff --git a/net-misc/tor/files/tor-0.2.7.4-torrc.sample.patch b/net-misc/tor/files/tor-0.2.7.4-torrc.sample.patch
new file mode 100644
index 00000000000..92eb03bb18e
--- /dev/null
+++ b/net-misc/tor/files/tor-0.2.7.4-torrc.sample.patch
@@ -0,0 +1,31 @@
+diff -Nuar tor-0.2.7.4-rc.orig/src/config/torrc.sample.in tor-0.2.7.4-rc/src/config/torrc.sample.in
+--- tor-0.2.7.4-rc.orig/src/config/torrc.sample.in 2015-10-19 11:12:53.000000000 -0400
++++ tor-0.2.7.4-rc/src/config/torrc.sample.in 2015-10-21 21:18:49.151973113 -0400
+@@ -12,6 +12,11 @@
+ ## Tor will look for this file in various places based on your platform:
+ ## https://www.torproject.org/docs/faq#torrc
+
++## Default username and group the server will run as
++User tor
++
++PIDFile /var/run/tor/tor.pid
++
+ ## Tor opens a SOCKS proxy on port 9050 by default -- even if you don't
+ ## configure one below. Set "SOCKSPort 0" if you plan to run Tor only
+ ## as a relay, and not make any local application connections yourself.
+@@ -42,6 +47,7 @@
+ #Log notice syslog
+ ## To send all messages to stderr:
+ #Log debug stderr
++Log warn syslog
+
+ ## Uncomment this to start the process in the background... or use
+ ## --runasdaemon 1 on the command line. This is ignored on Windows;
+@@ -51,6 +57,7 @@
+ ## The directory for keeping all the keys/etc. By default, we store
+ ## things in $HOME/.tor on Unix, and in Application Data\tor on Windows.
+ #DataDirectory @LOCALSTATEDIR@/lib/tor
++DataDirectory /var/lib/tor/data
+
+ ## The port on which Tor will listen for local connections from Tor
+ ## controller applications, as documented in control-spec.txt.
diff --git a/net-misc/tor/tor-0.2.7.4_rc.ebuild b/net-misc/tor/tor-0.2.7.4_rc.ebuild
new file mode 100644
index 00000000000..082da4f40d1
--- /dev/null
+++ b/net-misc/tor/tor-0.2.7.4_rc.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils flag-o-matic readme.gentoo systemd toolchain-funcs versionator user
+
+MY_PV="$(replace_version_separator 4 -)"
+MY_PF="${PN}-${MY_PV}"
+DESCRIPTION="Anonymizing overlay network for TCP"
+HOMEPAGE="http://www.torproject.org/"
+SRC_URI="https://www.torproject.org/dist/${MY_PF}.tar.gz
+ https://archive.torproject.org/tor-package-archive/${MY_PF}.tar.gz"
+S="${WORKDIR}/${MY_PF}"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="-bufferevents libressl scrypt seccomp selinux stats systemd tor-hardening transparent-proxy test web"
+
+DEPEND="
+ !libressl? ( dev-libs/openssl:0=[-bindist] )
+ libressl? ( dev-libs/libressl:= )
+ sys-libs/zlib
+ dev-libs/libevent
+ bufferevents? ( dev-libs/libevent[ssl] )
+ scrypt? ( app-crypt/libscrypt )
+ seccomp? ( sys-libs/libseccomp )
+ systemd? ( sys-apps/systemd )"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-tor )"
+
+pkg_setup() {
+ enewgroup tor
+ enewuser tor -1 -1 /var/lib/tor tor
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.2.7.4-torrc.sample.patch
+ epatch_user
+}
+
+src_configure() {
+ # Upstream isn't sure of all the user provided CFLAGS that
+ # will break tor, but does recommend against -fstrict-aliasing.
+ # We'll filter-flags them here as we encounter them.
+ filter-flags -fstrict-aliasing
+
+ econf \
+ --enable-system-torrc \
+ --enable-asciidoc \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable stats instrument-downloads) \
+ $(use_enable bufferevents) \
+ $(use_enable scrypt libscrypt) \
+ $(use_enable seccomp) \
+ $(use_enable systemd) \
+ $(use_enable tor-hardening gcc-hardening) \
+ $(use_enable tor-hardening linker-hardening) \
+ $(use_enable transparent-proxy transparent) \
+ $(use_enable web tor2web-mode) \
+ $(use_enable test unittests) \
+ $(use_enable test coverage)
+}
+
+src_install() {
+ readme.gentoo_create_doc
+
+ newconfd "${FILESDIR}"/tor.confd tor
+ newinitd "${FILESDIR}"/tor.initd-r7 tor
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ systemd_dotmpfilesd "${FILESDIR}/${PN}.conf"
+
+ emake DESTDIR="${D}" install
+
+ keepdir /var/lib/tor
+
+ dodoc README ChangeLog ReleaseNotes doc/HACKING
+
+ fperms 750 /var/lib/tor
+ fowners tor:tor /var/lib/tor
+
+ insinto /etc/tor/
+ newins "${FILESDIR}"/torrc-r1 torrc
+}
+
+pkg_postinst() {
+ readme.gentoo_pkg_postinst
+
+ if [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -eq 8 && $(gcc-micro-version) -ge 1 ]] ; then
+ ewarn "Due to a bug in >=gcc-4.8.1, compiling ${P} with -Os leads to an infinite"
+ ewarn "loop. See:"
+ ewarn
+ ewarn " https://trac.torproject.org/projects/tor/ticket/10259"
+ ewarn " https://gcc.gnu.org/bugzilla/show_bug.cgi?id=59358"
+ ewarn
+ fi
+}