summaryrefslogtreecommitdiff
path: root/net-misc
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-10-27 01:11:03 +0200
committerDavid Seifert <soap@gentoo.org>2016-11-06 19:11:30 +0100
commitb1a32afbbc081e9a09f6929a7f44f5e8220dc14d (patch)
tree33d433f1a7208913d4951d301ab32d24ef8069fd /net-misc
parent13a86f47f58eb7d2fac9f7738a37bc7aa97d83ad (diff)
downloadgentoo-b1a32afbbc081e9a09f6929a7f44f5e8220dc14d.tar.gz
gentoo-b1a32afbbc081e9a09f6929a7f44f5e8220dc14d.tar.xz
net-misc/x2goclient: Eliminate qt4 vs. qt5 REQUIRED_USE conflict
Instead, nsplugin does not work with USE=qt5 Gentoo-bug: 597420 Fix translations along the way. Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2672 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/x2goclient/files/x2goclient-4.0.5.2-r1-rcc_to_qrc.patch23
-rw-r--r--net-misc/x2goclient/x2goclient-4.0.5.2-r1.ebuild106
2 files changed, 129 insertions, 0 deletions
diff --git a/net-misc/x2goclient/files/x2goclient-4.0.5.2-r1-rcc_to_qrc.patch b/net-misc/x2goclient/files/x2goclient-4.0.5.2-r1-rcc_to_qrc.patch
new file mode 100644
index 00000000000..724c176eebb
--- /dev/null
+++ b/net-misc/x2goclient/files/x2goclient-4.0.5.2-r1-rcc_to_qrc.patch
@@ -0,0 +1,23 @@
+diff -Naur x2goclient-4.0.5.2.orig/x2goclient.pro x2goclient-4.0.5.2/x2goclient.pro
+--- x2goclient-4.0.5.2.orig/x2goclient.pro 2016-09-19 06:17:44.000000000 +0200
++++ x2goclient-4.0.5.2/x2goclient.pro 2016-09-28 22:03:41.830790244 +0200
+@@ -167,16 +167,16 @@
+ TEMPLATE = app
+ DEPENDPATH += .
+ INCLUDEPATH += src
+-RESOURCES += res/resources.rcc
++RESOURCES += res/resources.qrc
+
+ exists(res/txt/git-info) {
+ message("Configuring with --git-info")
+- RESOURCES += res/git.rcc
++ RESOURCES += res/git.qrc
+ }
+
+ exists(res/txt/changelog) {
+ message("Configuring with --changelog")
+- RESOURCES += res/changelog.rcc
++ RESOURCES += res/changelog.qrc
+ }
+
+ linux-g++ {
diff --git a/net-misc/x2goclient/x2goclient-4.0.5.2-r1.ebuild b/net-misc/x2goclient/x2goclient-4.0.5.2-r1.ebuild
new file mode 100644
index 00000000000..e948f9b9548
--- /dev/null
+++ b/net-misc/x2goclient/x2goclient-4.0.5.2-r1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit nsplugins qmake-utils
+
+DESCRIPTION="The X2Go Qt client"
+HOMEPAGE="http://www.x2go.org"
+SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap nsplugin qt5"
+
+REQUIRED_USE="nsplugin? ( !qt5 )"
+
+DEPEND=">=net-libs/libssh-0.6.0_rc1
+ net-print/cups
+ x11-libs/libXpm
+ ldap? ( net-nds/openldap )
+ !qt5? (
+ dev-qt/qtcore:4[ssl]
+ dev-qt/qtgui:4
+ dev-qt/qtsvg:4
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ )
+"
+RDEPEND="${DEPEND}
+ net-misc/nx"
+
+CLIENT_BUILD="${WORKDIR}"/${P}.client_build
+PLUGIN_BUILD="${WORKDIR}"/${P}.plugin_build
+
+PATCHES=( "${FILESDIR}"/${P}-r1-rcc_to_qrc.patch )
+
+src_prepare() {
+ default
+
+ local f
+ for f in res/*rcc; do
+ mv ${f} ${f/rcc/qrc} || die
+ done
+
+ if ! use ldap; then
+ sed -e "s/-lldap//" -i x2goclient.pro || die
+ sed -e "s/#define USELDAP//" -i src/x2goclientconfig.h || die
+ fi
+
+ mkdir -p "${CLIENT_BUILD}" || die
+ if use nsplugin; then
+ mkdir -p "${PLUGIN_BUILD}" || die
+ fi
+}
+
+src_configure() {
+ cd "${CLIENT_BUILD}" || die
+
+ if use qt5; then
+ eqmake5 "${S}"/x2goclient.pro
+ else
+ eqmake4 "${S}"/x2goclient.pro
+ fi
+
+ if use nsplugin; then
+ cd "${PLUGIN_BUILD}" || die
+ X2GO_CLIENT_TARGET=plugin eqmake4 "${S}"/x2goclient.pro
+ fi
+}
+
+src_compile() {
+ cd "${CLIENT_BUILD}" || die
+ emake
+
+ if use nsplugin; then
+ cd "${PLUGIN_BUILD}" || die
+ emake
+ fi
+}
+
+src_install() {
+ dobin "${CLIENT_BUILD}"/${PN}
+
+ insinto /usr/share/pixmaps/x2goclient
+ doins res/img/icons/${PN}.xpm
+
+ domenu desktop/${PN}.desktop
+ doman man/man?/*
+
+ if use nsplugin; then
+ # PLUGINS_DIR comes from nsplugins.eclass
+ exeinto /usr/$(get_libdir)/${PLUGINS_DIR}
+ doexe "${PLUGIN_BUILD}"/libx2goplugin.so
+ fi
+
+ emake DESTDIR="${D}" PREFIX=/usr install_pluginprovider
+}