summaryrefslogtreecommitdiff
path: root/net-misc
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-05-13 23:45:55 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-05-13 23:46:06 +0200
commitb98c423ff1a1db16491be784451ae56827e19324 (patch)
treee45b01567ed9d5aa307e683f92551277d75ceb5f /net-misc
parente8abb56bafd52b5fc749f04b75f41e80d99c413f (diff)
downloadgentoo-b98c423ff1a1db16491be784451ae56827e19324.tar.gz
gentoo-b98c423ff1a1db16491be784451ae56827e19324.tar.xz
net-misc/openvpn: Sync live ebuild
Package-Manager: portage-2.2.28
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/openvpn/openvpn-9999.ebuild23
1 files changed, 17 insertions, 6 deletions
diff --git a/net-misc/openvpn/openvpn-9999.ebuild b/net-misc/openvpn/openvpn-9999.ebuild
index bcfcb96158c..bbaf8aa1312 100644
--- a/net-misc/openvpn/openvpn-9999.ebuild
+++ b/net-misc/openvpn/openvpn-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=5
-inherit multilib autotools flag-o-matic user git-2
+inherit multilib autotools flag-o-matic user linux-info git-2
DESCRIPTION="Robust and highly flexible tunneling application compatible with many OSes"
EGIT_REPO_URI="https://github.com/OpenVPN/${PN}.git"
@@ -13,10 +13,11 @@ HOMEPAGE="http://openvpn.net/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="examples down-root iproute2 +lzo pam passwordsave pkcs11 +plugins polarssl selinux socks +ssl static systemd userland_BSD"
+IUSE="examples down-root iproute2 libressl +lzo pam passwordsave pkcs11 +plugins polarssl selinux socks +ssl static systemd userland_BSD"
REQUIRED_USE="static? ( !plugins !pkcs11 )
- polarssl? ( ssl )
+ polarssl? ( ssl !libressl )
+ pkcs11? ( ssl )
!plugins? ( !pam !down-root )"
DEPEND="
@@ -25,7 +26,11 @@ DEPEND="
)
pam? ( virtual/pam )
ssl? (
- !polarssl? ( >=dev-libs/openssl-0.9.7 ) polarssl? ( >=net-libs/polarssl-1.2.10 )
+ !polarssl? (
+ !libressl? ( >=dev-libs/openssl-0.9.7:* )
+ libressl? ( dev-libs/libressl )
+ )
+ polarssl? ( >=net-libs/polarssl-1.3.8 )
)
lzo? ( >=dev-libs/lzo-1.07 )
pkcs11? ( >=dev-libs/pkcs11-helper-1.11 )
@@ -34,6 +39,12 @@ RDEPEND="${DEPEND}
selinux? ( sec-policy/selinux-openvpn )
"
+CONFIG_CHECK="~TUN"
+
+pkg_setup() {
+ linux-info_pkg_setup
+}
+
src_prepare() {
eautoreconf
}