summaryrefslogtreecommitdiff
path: root/net-nds
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2018-03-03 23:35:56 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2018-03-03 23:36:21 +0100
commit2d3f3423b5a8c8c808209abafd62e8fab2523401 (patch)
tree5f52a61377039389a8d86d2a21866c97b68a1edf /net-nds
parent06b305d8184e3471c4642e5034192c12b6fe8d65 (diff)
downloadgentoo-2d3f3423b5a8c8c808209abafd62e8fab2523401.tar.gz
gentoo-2d3f3423b5a8c8c808209abafd62e8fab2523401.tar.xz
net-nds/yp-tools: Always use libtirpc, should fix bug 630246
Closes: https://bugs.gentoo.org/630246 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/yp-tools/yp-tools-4.2.2-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-nds/yp-tools/yp-tools-4.2.2-r2.ebuild b/net-nds/yp-tools/yp-tools-4.2.2-r2.ebuild
new file mode 100644
index 00000000000..314678603f5
--- /dev/null
+++ b/net-nds/yp-tools/yp-tools-4.2.2-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit systemd
+
+DESCRIPTION="Network Information Service tools"
+HOMEPAGE="http://www.linux-nis.org/nis/"
+SRC_URI="http://www.linux-nis.org/download/yp-tools/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls"
+
+DEPEND="
+ net-libs/libtirpc
+ net-libs/libnsl:0=
+"
+RDEPEND=${DEPEND}
+# uses always libtirpc if present
+
+RESTRICT=test # do not compile
+
+src_configure () {
+ econf \
+ --disable-static \
+ --sysconfdir=/etc/yp \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+
+ insinto /etc/yp
+ doins etc/nicknames
+
+ systemd_dounit "${FILESDIR}/domainname.service"
+ systemd_install_serviced "${FILESDIR}"/domainname.service.conf
+}