summaryrefslogtreecommitdiff
path: root/net-news/rssguard
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-news/rssguard
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-news/rssguard')
-rw-r--r--net-news/rssguard/Manifest1
-rw-r--r--net-news/rssguard/metadata.xml10
-rw-r--r--net-news/rssguard/rssguard-2.4.0.ebuild47
3 files changed, 58 insertions, 0 deletions
diff --git a/net-news/rssguard/Manifest b/net-news/rssguard/Manifest
new file mode 100644
index 00000000000..dd3a58c6b71
--- /dev/null
+++ b/net-news/rssguard/Manifest
@@ -0,0 +1 @@
+DIST rssguard-2.4.0.tar.gz 44439456 SHA256 5b9f87185a1d5b4ebbbd6aa8ff49fe0b470f323e7465c1a7c364198f62ed877e SHA512 ab789af3119fea8a974b0d0c4c15c256b61ea8d143963fcba6c8dfa792191fa7e21a83e8c867bdeec4cf5dec479300016163f529e5337bc22ef533e9b7631f92 WHIRLPOOL 15f3243b077ccab89188b95b0b5450c06b07910555296d483dea283125e09a11f4e0c1327c2e8740fb6cd1aebccc2a874e52558e28a9a5c2fac64de7fd6a0d87
diff --git a/net-news/rssguard/metadata.xml b/net-news/rssguard/metadata.xml
new file mode 100644
index 00000000000..350da705d81
--- /dev/null
+++ b/net-news/rssguard/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>yngwin@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="bitbucket">skunkos/rssguard</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-news/rssguard/rssguard-2.4.0.ebuild b/net-news/rssguard/rssguard-2.4.0.ebuild
new file mode 100644
index 00000000000..893c982f583
--- /dev/null
+++ b/net-news/rssguard/rssguard-2.4.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="A tiny RSS and Atom feed reader"
+HOMEPAGE="https://bitbucket.org/skunkos/rssguard"
+SRC_URI="https://bitbucket.org/skunkos/rssguard/downloads/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="qt4 +qt5"
+REQUIRED_USE="^^ ( qt4 qt5 )"
+
+DEPEND="
+ qt4? ( dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtwebkit:4
+ dev-qt/qtxmlpatterns:4 )
+ qt5? ( dev-qt/linguist-tools:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsql:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ dev-qt/qtxmlpatterns:5 )"
+RDEPEND="${DEPEND}"
+
+DOCS=( README.md resources/text/CHANGELOG )
+
+src_prepare() {
+ sed -e '/Encoding/d' -i resources/desktop/${PN}.desktop.in || die 'sed failed'
+ epatch_user
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_use qt5 QT_5)
+ )
+ cmake-utils_src_configure
+}