summaryrefslogtreecommitdiff
path: root/net-p2p/classified-ads/classified-ads-0.12.ebuild
diff options
context:
space:
mode:
authorAntti Jarvinen <antti.jarvinen@katiska.org>2017-12-02 13:21:11 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-01-26 22:43:37 +0100
commitd2beaf0948c16eb8026d846e9c981df26646131d (patch)
tree3d5d4d32e95799a2b68b4379d50ced5a829a1452 /net-p2p/classified-ads/classified-ads-0.12.ebuild
parentd845a553872141451cf906797b919f0ebb35a371 (diff)
downloadgentoo-d2beaf0948c16eb8026d846e9c981df26646131d.tar.gz
gentoo-d2beaf0948c16eb8026d846e9c981df26646131d.tar.xz
net-p2p/classified-ads: version bump to upstream version 0.12.
Package-Manager: Portage-2.3.13, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/6398
Diffstat (limited to 'net-p2p/classified-ads/classified-ads-0.12.ebuild')
-rw-r--r--net-p2p/classified-ads/classified-ads-0.12.ebuild88
1 files changed, 88 insertions, 0 deletions
diff --git a/net-p2p/classified-ads/classified-ads-0.12.ebuild b/net-p2p/classified-ads/classified-ads-0.12.ebuild
new file mode 100644
index 00000000000..083c75d23ab
--- /dev/null
+++ b/net-p2p/classified-ads/classified-ads-0.12.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PLOCALES="en fi sv da uk es"
+PLOCALE_BACKUP="en"
+inherit qmake-utils virtualx l10n
+
+DESCRIPTION="Program for displaying classified advertisement items"
+HOMEPAGE="http://katiska.org/classified-ads/"
+SRC_URI="https://github.com/operatornormal/classified-ads/archive/${PV}.tar.gz \
+ -> classified-ads-${PV}.tar.gz \
+ https://github.com/operatornormal/classified-ads/blob/graphics/preprocessed.tar.gz?raw=true \
+ -> classified-ads-graphics-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc test"
+
+RDEPEND="dev-libs/openssl:0
+ >=net-libs/libnatpmp-20130911
+ <=net-libs/libnatpmp-20140401-r1
+ >=net-libs/miniupnpc-1.8
+ sys-apps/file
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtwidgets:5
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtmultimedia:5[widgets]
+ dev-qt/qtprintsupport:5
+ media-libs/opus
+ virtual/libintl
+ dev-lang/tcl:=
+ dev-lang/tk:=
+ sys-libs/zlib"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ doc? ( app-doc/doxygen[dot] )
+ test? ( dev-libs/libgcrypt:0
+ dev-qt/qttest:5
+ sys-devel/gdb:0 )"
+
+src_prepare() {
+ # preprocessed graphics are unpacked into wrong directory
+ # so lets move them into correct location:
+ mv ../ui/* ui/ || die
+ # unit-test patch
+ eapply "${FILESDIR}/${P}-unit-tests.patch"
+ # possible patches
+ eapply_user
+}
+
+src_configure() {
+ eqmake5
+ if use test; then
+ cd test || die
+ eqmake5
+ fi
+}
+
+src_compile() {
+ emake
+ if use doc; then
+ pushd doc > /dev/null || die
+ doxygen || die
+ popd > /dev/null || die
+ fi
+ if use test; then
+ pushd test > /dev/null || die
+ emake
+ popd > /dev/null || die
+ fi
+}
+
+src_test() {
+ # testca will return 0 if all unit tests pass
+ virtx ./test/testca
+}
+
+src_install() {
+ docompress -x /usr/share/doc/
+ emake install INSTALL_ROOT="${D}" DESTDIR="${D}"
+ use doc && dodoc -r doc/doxygen.generated/html/
+}