summaryrefslogtreecommitdiff
path: root/net-p2p/dclib
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-p2p/dclib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-p2p/dclib')
-rw-r--r--net-p2p/dclib/Manifest1
-rw-r--r--net-p2p/dclib/dclib-0.3.23.ebuild39
-rw-r--r--net-p2p/dclib/files/dclib-0.3.23-asneeded.patch16
-rw-r--r--net-p2p/dclib/files/dclib-0.3.23-openssl-1.patch52
-rw-r--r--net-p2p/dclib/metadata.xml8
5 files changed, 116 insertions, 0 deletions
diff --git a/net-p2p/dclib/Manifest b/net-p2p/dclib/Manifest
new file mode 100644
index 00000000000..cf90b79247f
--- /dev/null
+++ b/net-p2p/dclib/Manifest
@@ -0,0 +1 @@
+DIST dclib-0.3.23.tar.bz2 517251 SHA256 757b67cb1158a93fd826ef358ec094f59ba9dca0dde94a1d7325833f222e4dd0
diff --git a/net-p2p/dclib/dclib-0.3.23.ebuild b/net-p2p/dclib/dclib-0.3.23.ebuild
new file mode 100644
index 00000000000..3945a73501a
--- /dev/null
+++ b/net-p2p/dclib/dclib-0.3.23.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="DirectConnect client library"
+HOMEPAGE="http://sourceforge.net/projects/wxdcgui"
+SRC_URI="mirror://sourceforge/wxdcgui/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ppc64 x86"
+IUSE="socks5 ssl"
+
+DEPEND="app-arch/bzip2
+ sys-libs/zlib
+ dev-libs/libxml2
+ socks5? ( net-proxy/dante )
+ ssl? ( dev-libs/openssl )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch \
+ "${FILESDIR}"/${P}-openssl-1.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable socks5 socks) \
+ $(use_enable ssl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
diff --git a/net-p2p/dclib/files/dclib-0.3.23-asneeded.patch b/net-p2p/dclib/files/dclib-0.3.23-asneeded.patch
new file mode 100644
index 00000000000..d3634c424c2
--- /dev/null
+++ b/net-p2p/dclib/files/dclib-0.3.23-asneeded.patch
@@ -0,0 +1,16 @@
+Changing order allows ACX_PHTREAD to find -lthread
+before trying to use -pthread
+
+http://bugs.gentoo.org/show_bug.cgi?id=282426
+
+--- m4/acx_pthread.m4
++++ m4/acx_pthread.m4
+@@ -123,7 +123,7 @@
+ # which indicates that we try without any flags at all, and "pthread-config"
+ # which is a program returning the flags for the Pth emulation library.
+
+-acx_pthread_flags="pthreads none -Kthread -kthread lthread -pthread -pthreads -mthreads pthread --thread-safe -mt pthread-config"
++acx_pthread_flags="pthreads none -Kthread -kthread lthread pthread -pthread -pthreads -mthreads --thread-safe -mt pthread-config"
+
+ # The ordering *is* (sometimes) important. Some notes on the
+ # individual items follow:
diff --git a/net-p2p/dclib/files/dclib-0.3.23-openssl-1.patch b/net-p2p/dclib/files/dclib-0.3.23-openssl-1.patch
new file mode 100644
index 00000000000..f8b4a4bc2af
--- /dev/null
+++ b/net-p2p/dclib/files/dclib-0.3.23-openssl-1.patch
@@ -0,0 +1,52 @@
+http://bugs.gentoo.org/330291
+
+--- dclib/core/cssl.cpp
++++ dclib/core/cssl.cpp
+@@ -86,7 +86,11 @@
+ /** */
+ SSL_CTX * CSSL::InitClientCTX()
+ {
++ #if OPENSSL_VERSION_NUMBER >= 0x10000000L
++ const SSL_METHOD *method;
++ #else
+ SSL_METHOD *method;
++ #endif
+ SSL_CTX *ctx = NULL;
+
+ method = SSLv23_client_method(); /* Create new client-method instance */
+@@ -109,7 +113,11 @@
+ /** */
+ SSL_CTX * CSSL::InitServerCTX()
+ {
++ #if OPENSSL_VERSION_NUMBER >= 0x10000000L
++ const SSL_METHOD *method;
++ #else
+ SSL_METHOD *method;
++ #endif
+ SSL_CTX *ctx = NULL;
+
+ method = SSLv23_server_method(); /* Create new client-method instance */
+@@ -130,7 +138,11 @@
+ /** */
+ SSL_CTX * CSSL::NewTLSv1ClientCTX()
+ {
++ #if OPENSSL_VERSION_NUMBER >= 0x10000000L
++ const SSL_METHOD * method = TLSv1_client_method();
++ #else
+ SSL_METHOD * method = TLSv1_client_method();
++ #endif
+ SSL_CTX * ctx = NULL;
+
+ if ( method != NULL )
+@@ -149,7 +161,11 @@
+ /** */
+ SSL_CTX * CSSL::NewTLSv1ServerCTX()
+ {
++ #if OPENSSL_VERSION_NUMBER >= 0x10000000L
++ const SSL_METHOD * method = TLSv1_server_method();
++ #else
+ SSL_METHOD * method = TLSv1_server_method();
++ #endif
+ SSL_CTX * ctx = NULL;
+
+ if ( method != NULL )
diff --git a/net-p2p/dclib/metadata.xml b/net-p2p/dclib/metadata.xml
new file mode 100644
index 00000000000..b6e0d287755
--- /dev/null
+++ b/net-p2p/dclib/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-p2p</herd>
+ <upstream>
+ <remote-id type="sourceforge">wxdcgui</remote-id>
+ </upstream>
+</pkgmetadata>