summaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2017-05-09 23:22:31 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-11 20:20:04 +0200
commit70f8a1d5bd0a26f2834dbc83e90efc2d29bf781e (patch)
tree698506209ea5fb1d3f11a218318c32c2751436bd /net-p2p
parent2769787ce24e40630c4400d87a1727cb5c35118e (diff)
downloadgentoo-70f8a1d5bd0a26f2834dbc83e90efc2d29bf781e.tar.gz
gentoo-70f8a1d5bd0a26f2834dbc83e90efc2d29bf781e.tar.xz
net-p2p/airdcpp-webclient: bump to 2.0.1
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/airdcpp-webclient/Manifest1
-rw-r--r--net-p2p/airdcpp-webclient/airdcpp-webclient-2.0.1.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/net-p2p/airdcpp-webclient/Manifest b/net-p2p/airdcpp-webclient/Manifest
index 0bfa33ca5d4..bd8b3e318e7 100644
--- a/net-p2p/airdcpp-webclient/Manifest
+++ b/net-p2p/airdcpp-webclient/Manifest
@@ -1,2 +1,3 @@
DIST airdcpp-webclient-1.3.1.tar.gz 736889 SHA256 3ec4e2aca343a7d715008482b8197c09b00677d8cb2798470274d944e6e4f5bf SHA512 0a2b4e7a6d639167d51d7ddd4a40e577df7a8babd76df7af7a3a7eb246f73b9840a1f0d96e2a3b494cd05a881881167cc7932b676e9e7d64a28a100c4e0b7467 WHIRLPOOL ea11b7ed94cf4c1fd5ffed0b7e64781bee2b1f4a8255204d662b63bef46bf9808c006ca2b9d6bde572abbfc3e98e25e6300e5ddb99ce90d3717bf2a811433d19
DIST airdcpp-webclient-1.4.1.tar.gz 743631 SHA256 9acb61366c91a7aaa03cae58e9aee28ccac05ffe9dff0ec947836fa81967f27f SHA512 7b973251574cb5b49942efa868cef9f689fcf8d804be632ad17c445be98ab55ca9973c5fe9dce052d542006d47a7850af7d236953010c2c0e3158c54e448afe1 WHIRLPOOL e43ccfddc50dbdd0ce8a3cd5b00fc4c844ed69051967d67cca9c9c72b073227d1d20ac510d34b07161c231c7c7d69b945d60872d8756a0ef2c91dfe4a843fe06
+DIST airdcpp-webclient-2.0.1.tar.gz 843348 SHA256 312466c20b6c3125b6bf88b26f23618f67546722bb0372089537c5a88cc3460b SHA512 2c31712816a59560f248f42b3ad3ffe5d2f76a64860bf515a537b79dda5a579bac17d5d8ba46d9d57554a0b93b9384696a299b2f2096e05c62ea4b97e42d06bc WHIRLPOOL e78d998d8398eb705599ed0f249242d460586288c5649b810606321334a7ea66bd2cb9f119789eec19038e1e3d9ce376a93e96bd18fe15bba10d7a80c97ee580
diff --git a/net-p2p/airdcpp-webclient/airdcpp-webclient-2.0.1.ebuild b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.0.1.ebuild
new file mode 100644
index 00000000000..48eaa65f1fe
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.0.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy{,3} )
+
+inherit cmake-utils user python-any-r1
+
+DESCRIPTION="Cross-platform Direct Connect client"
+HOMEPAGE="https://airdcpp-web.github.io/"
+SRC_URI="https://github.com/airdcpp-web/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="nat-pmp +tbb +webui"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-cpp/websocketpp
+ dev-libs/boost:=
+ dev-libs/geoip
+ dev-libs/leveldb
+ dev-libs/openssl:0=[-bindist]
+ net-libs/miniupnpc:=
+ sys-libs/zlib
+ virtual/libiconv
+ nat-pmp? ( net-libs/libnatpmp )
+ tbb? ( dev-cpp/tbb )
+"
+DEPEND="
+ virtual/pkgconfig
+ ${PYTHON_DEPS}
+ ${RDEPEND}
+"
+PDEPEND="webui? ( www-apps/airdcpp-webui )"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ enewgroup airdcppd
+ enewuser airdcppd -1 -1 /var/lib/airdcppd airdcppd
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_WEB_UI=OFF
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ newconfd "${FILESDIR}/airdcppd.confd" airdcppd
+ newinitd "${FILESDIR}/airdcppd.initd" airdcppd
+ keepdir /var/lib/airdcppd
+ fowners airdcppd:airdcppd /var/lib/airdcppd
+ cmake-utils_src_install
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Run 'airdcppd --configure' to set up ports and authentication"
+ fi
+}