summaryrefslogtreecommitdiff
path: root/net-print/epson-inkjet-printer-escpr
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-print/epson-inkjet-printer-escpr
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-print/epson-inkjet-printer-escpr')
-rw-r--r--net-print/epson-inkjet-printer-escpr/Manifest1
-rw-r--r--net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.4.4.ebuild32
-rw-r--r--net-print/epson-inkjet-printer-escpr/files/1.4.4-warnings.patch43
-rw-r--r--net-print/epson-inkjet-printer-escpr/metadata.xml8
4 files changed, 84 insertions, 0 deletions
diff --git a/net-print/epson-inkjet-printer-escpr/Manifest b/net-print/epson-inkjet-printer-escpr/Manifest
new file mode 100644
index 00000000000..e4128a1bd4c
--- /dev/null
+++ b/net-print/epson-inkjet-printer-escpr/Manifest
@@ -0,0 +1 @@
+DIST epson-inkjet-printer-escpr-1.4.4-1lsb3.2.tar.gz 2432872 SHA256 bec7c51d11d96b6448bd96b5e9ac622786e3fc5024e13cae2fc248f8858db2f6 SHA512 7a3f1f880dba9048773d051cfe54ea2ee929d82a85efb496d4df4b84b33ed2f48bb6020892615d5d22da6b5671501b82df55cea6e11b35fea392392f115a6330 WHIRLPOOL 856bcffc4fe45c6bb15c7ecbe1c41e315ee68bf2c3c93697ac4f314324e2b3a0a8796ba741c04e962f1ca9148dbf38d529649ffd5d7ddaaa757666ea066e32a0
diff --git a/net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.4.4.ebuild b/net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.4.4.ebuild
new file mode 100644
index 00000000000..3e76ec4b741
--- /dev/null
+++ b/net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.4.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib
+
+DESCRIPTION="Epson Inkjet Printer Driver (ESC/P-R)"
+HOMEPAGE="http://www.epson.com/"
+SRC_URI="https://download3.ebz.epson.net/dsc/f/03/00/03/29/49/36201e41f124a1f4f7b793533b1ade1202032276/epson-inkjet-printer-escpr-1.4.4-1lsb3.2.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="net-print/cups"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/1.4.4-warnings.patch"
+}
+
+src_configure() {
+ econf --disable-shared
+}
+
+src_install() {
+ default
+ rm -r "${ED%/}/usr/$(get_libdir)" || die
+}
diff --git a/net-print/epson-inkjet-printer-escpr/files/1.4.4-warnings.patch b/net-print/epson-inkjet-printer-escpr/files/1.4.4-warnings.patch
new file mode 100644
index 00000000000..34ec1737d53
--- /dev/null
+++ b/net-print/epson-inkjet-printer-escpr/files/1.4.4-warnings.patch
@@ -0,0 +1,43 @@
+--- a/lib/epson-escpage-mono.c
++++ b/lib/epson-escpage-mono.c
+@@ -885,7 +885,7 @@
+
+ EPS_LOG_FUNCIN;
+
+- memset(pBand, 0, sizeof(pBand));
++ memset(pBand, 0, sizeof(EPS_PAGE_BAND_M));
+
+ pBand->WidthInPixels = widthInPixels;
+ pBand->WidthInBytes = (pBand->WidthInPixels+7)/8;
+--- a/lib/epson-escpr-api.h
++++ b/lib/epson-escpr-api.h
+@@ -98,6 +98,9 @@
+ /*** -------------------------------------------------------------------------------*/
+ extern EPS_ERR_CODE epsMakeMainteCmd (EPS_INT32, EPS_UINT8*, EPS_UINT32* );
+
++extern EPS_ERR_CODE SetupJobAttrib (const EPS_JOB_ATTRIB* );
++extern EPS_ERR_CODE SendStartJob (EPS_BOOL );
++extern EPS_ERR_CODE PrintBand (const EPS_UINT8*, EPS_UINT32, EPS_UINT32* );
+ #ifdef __cplusplus
+ }
+ #endif
+--- a/src/filter.c
++++ b/src/filter.c
+@@ -38,6 +38,7 @@
+ #include "epson-escpr-api.h"
+ #include "epson-escpr-services.h"
+ #include "epson-escpr-mem.h"
++#include "epson-escpage.h"
+
+ #include "err.h"
+ #include "mem.h"
+--- a/src/mem.c
++++ b/src/mem.c
+@@ -23,6 +23,7 @@
+ #endif
+
+ #include <stdlib.h>
++#include "err.h"
+ #include "mem.h"
+
+ void *
diff --git a/net-print/epson-inkjet-printer-escpr/metadata.xml b/net-print/epson-inkjet-printer-escpr/metadata.xml
new file mode 100644
index 00000000000..09ddbff14db
--- /dev/null
+++ b/net-print/epson-inkjet-printer-escpr/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>floppym@gentoo.org</email>
+ <name>Mike Gilbert</name>
+ </maintainer>
+</pkgmetadata>