summaryrefslogtreecommitdiff
path: root/net-print/foomatic-db
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-print/foomatic-db
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-print/foomatic-db')
-rw-r--r--net-print/foomatic-db/Manifest2
-rw-r--r--net-print/foomatic-db/foomatic-db-4.0.20140105.ebuild42
-rw-r--r--net-print/foomatic-db/foomatic-db-4.0.20141025.ebuild41
-rw-r--r--net-print/foomatic-db/metadata.xml5
4 files changed, 90 insertions, 0 deletions
diff --git a/net-print/foomatic-db/Manifest b/net-print/foomatic-db/Manifest
new file mode 100644
index 00000000000..84c59fd637a
--- /dev/null
+++ b/net-print/foomatic-db/Manifest
@@ -0,0 +1,2 @@
+DIST foomatic-db-4.0-20140105.tar.gz 38845034 SHA256 8c94ca9316f0e7ebc9cd69818349d49058411120b5f5ab45d4246a30bf832292 SHA512 4d06d63fe79bcfb912875b8209d658e018f4486821e7bf9433cb181d68df58602a58e755202d8ce53e0a9b9d8b0f1b31a7847c4d1346164e88105b06a4003ee4 WHIRLPOOL 77ac1ee1b13857aa07e82da540cd5d11973d9a75437c12b5fba7c115ea27cfea3fe1c3500c3fc09a74333255e824aa9e2199653e5f873bebe9c1c7c7b85800bc
+DIST foomatic-db-4.0-20141025.tar.gz 39889820 SHA256 6167c45fe3c59f45a41fe9e66514be335b0cfa554bded3155937debfa0d7b6b2 SHA512 bd430f41ae3bd76c4d9f521ee0ba03366aff88ced499dcdbd994f594129343739eda54c345525338ffc254bca1cb62863415504ccd29e3871acab7272759d40e WHIRLPOOL 5a8cf6d99941c61e92e5fe209ee1bce4c4ec7e211b05ef23ad42e13e9482fa621519e1562272d0e5337806ce79fa9b5206a658ed14e5ac429e8caaab5cfbb429
diff --git a/net-print/foomatic-db/foomatic-db-4.0.20140105.ebuild b/net-print/foomatic-db/foomatic-db-4.0.20140105.ebuild
new file mode 100644
index 00000000000..c85664ebc59
--- /dev/null
+++ b/net-print/foomatic-db/foomatic-db-4.0.20140105.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit versionator
+
+DESCRIPTION="Printer information files for foomatic-db-engine to generate ppds"
+HOMEPAGE="http://www.linuxprinting.org/foomatic.html"
+#SRC_URI="http://www.openprinting.org/download/foomatic/${PN}-$(replace_version_separator 2 -).tar.gz"
+SRC_URI="http://dev.gentoo.org/~dilfridge/distfiles/${PN}-$(replace_version_separator 2 -).tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ net-print/foomatic-db-engine
+ !net-print/foo2zjs[hp2600n]"
+
+S="${WORKDIR}/${PN}-$(get_version_component_range 3 ${PV})"
+
+src_prepare() {
+ # ppd files do not belong to this package
+ rm -r db/source/PPD || die
+}
+
+src_configure() {
+ econf \
+ --disable-gzip-ppds \
+ --disable-ppds-to-cups
+}
+
+src_install() {
+ default
+ rmdir "${ED}"/usr/share/foomatic/db/source/PPD || die
+ # Avoid collision with foo2zjs, bug 185486
+ rm "${ED}"/usr/share/foomatic/db/source/{driver/foo2{hp,lava,xqx,zjs}.xml,printer/{Generic-ZjStream_Printer,HP-{Color_LaserJet_{1500,1600,2600n},LaserJet_{10{00,05,18,20,22},M1005_MFP}},Minolta-{Color_PageWorks_Pro_L,magicolor_2{20,30,43}0_DL},Samsung-CLP-{3,6}00}.xml} || die
+}
diff --git a/net-print/foomatic-db/foomatic-db-4.0.20141025.ebuild b/net-print/foomatic-db/foomatic-db-4.0.20141025.ebuild
new file mode 100644
index 00000000000..b88d2cd7aae
--- /dev/null
+++ b/net-print/foomatic-db/foomatic-db-4.0.20141025.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit versionator
+
+DESCRIPTION="Printer information files for foomatic-db-engine to generate ppds"
+HOMEPAGE="http://www.linuxprinting.org/foomatic.html"
+SRC_URI="http://www.openprinting.org/download/foomatic/${PN}-$(replace_version_separator 2 -).tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ net-print/foomatic-db-engine
+ !net-print/foo2zjs[hp2600n]"
+
+S="${WORKDIR}/${PN}-$(get_version_component_range 3 ${PV})"
+
+src_prepare() {
+ # ppd files do not belong to this package
+ rm -r db/source/PPD || die
+}
+
+src_configure() {
+ econf \
+ --disable-gzip-ppds \
+ --disable-ppds-to-cups
+}
+
+src_install() {
+ default
+ rmdir "${ED}"/usr/share/foomatic/db/source/PPD || die
+ # Avoid collision with foo2zjs, bug 185486
+ rm "${ED}"/usr/share/foomatic/db/source/{driver/foo2{hp,lava,xqx,zjs}.xml,printer/{Generic-ZjStream_Printer,HP-{Color_LaserJet_{1500,1600,2600n},LaserJet_{10{00,05,18,20,22},M1005_MFP}},Minolta-{Color_PageWorks_Pro_L,magicolor_2{20,30,43}0_DL},Samsung-CLP-{3,6}00}.xml} || die
+}
diff --git a/net-print/foomatic-db/metadata.xml b/net-print/foomatic-db/metadata.xml
new file mode 100644
index 00000000000..e450ba260ec
--- /dev/null
+++ b/net-print/foomatic-db/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>printing</herd>
+</pkgmetadata>