summaryrefslogtreecommitdiff
path: root/net-print/magicfilter
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-print/magicfilter
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-print/magicfilter')
-rw-r--r--net-print/magicfilter/Manifest1
-rw-r--r--net-print/magicfilter/files/magicfilter-2.3d-glibc-2.10.patch100
-rw-r--r--net-print/magicfilter/files/magicfilter-2.3h-configure.patch59
-rw-r--r--net-print/magicfilter/files/magicfilter-2.3h-makefile.patch75
-rw-r--r--net-print/magicfilter/magicfilter-2.3h.ebuild44
-rw-r--r--net-print/magicfilter/metadata.xml8
6 files changed, 287 insertions, 0 deletions
diff --git a/net-print/magicfilter/Manifest b/net-print/magicfilter/Manifest
new file mode 100644
index 00000000000..637f31191ca
--- /dev/null
+++ b/net-print/magicfilter/Manifest
@@ -0,0 +1 @@
+DIST magicfilter-2.3.h.tar.gz 161929 RMD160 af36ec7731d1431ed4ac1ff1b048b62a7e31a459 SHA1 94e2f5abbfa208f994b729d8cebc2a2a91c71186 SHA256 8d6a3e3e68a16aa43682cdd77e8a9d28635eef4ea5e8dcf558e9a6fb88f8642c
diff --git a/net-print/magicfilter/files/magicfilter-2.3d-glibc-2.10.patch b/net-print/magicfilter/files/magicfilter-2.3d-glibc-2.10.patch
new file mode 100644
index 00000000000..eea064501ca
--- /dev/null
+++ b/net-print/magicfilter/files/magicfilter-2.3d-glibc-2.10.patch
@@ -0,0 +1,100 @@
+--- fe.c
++++ fe.c
+@@ -128,7 +128,7 @@
+
+ /* read rules
+ */
+- while ( (r = getline(f)) != 0) {
++ while ( (r = get_line(f)) != 0) {
+ rulecount++;
+ if (tail) {
+ tail->next = r;
+--- getline.c
++++ getline.c
+@@ -27,7 +27,7 @@
+ * THE POSSIBILITY OF SUCH DAMAGE.
+ */
+ /*
+- * getline() picks up a magicfilter rule line and passes it back to magicfilter
++ * get_line() picks up a magicfilter rule line and passes it back to magicfilter
+ *
+ * rules are:
+ *
+@@ -172,10 +172,10 @@
+
+
+ /*
+- * getline() gets a rule off the input stream
++ * get_line() gets a rule off the input stream
+ */
+ struct rule *
+-getline(FILE *input)
++get_line(FILE *input)
+ {
+ static char *bfr = 0; /* a buffer for reading lines into */
+ static int buflen = 0; /* size of that buffer */
+@@ -189,13 +189,13 @@
+ /* initialize the line buffer the first time in
+ */
+ if ( (bfr = malloc(buflen=80)) == 0) {
+- perror("getline::malloc");
++ perror("get_line::malloc");
+ exit(1);
+ }
+ }
+
+ if ( (r = calloc(1, sizeof *r)) == 0) {
+- perror("getline::calloc");
++ perror("get_line::calloc");
+ exit(1);
+ }
+
+@@ -240,7 +240,7 @@
+ }
+
+ if ( (r->pattern = strdup(q)) == 0) {
+- perror("getline::strdup");
++ perror("get_line::strdup");
+ exit(1);
+ }
+
+@@ -289,7 +289,7 @@
+
+ if (hint)
+ if ( (r->hint = strdup(hint)) == 0) {
+- perror("getline::strdup");
++ perror("get_line::strdup");
+ exit(1);
+ }
+
+@@ -302,11 +302,11 @@
+ while ( (q = getarg(&p)) != 0) {
+ r->argv = realloc(r->argv, (3 + r->argc) * sizeof r->argv[0]);
+ if (r->argv == 0) {
+- perror("getline::realloc");
++ perror("get_line::realloc");
+ exit(1);
+ }
+ if ( (r->argv[r->argc++] = strdup(q)) == 0) {
+- perror("getline::strdup");
++ perror("get_line::strdup");
+ exit(1);
+ }
+ }
+@@ -330,4 +330,4 @@
+ }
+ ++ruleno;
+ return r;
+-} /* getline */
++} /* get_line */
+--- rule.h
++++ rule.h
+@@ -55,7 +55,7 @@
+ struct rule *next; /* next rule in the chain */
+ } ;
+
+-extern struct rule *getline(FILE *);
++extern struct rule *get_line(FILE *);
+ extern struct rule *rules;
+ char * action_p(enum rule_action);
+
diff --git a/net-print/magicfilter/files/magicfilter-2.3h-configure.patch b/net-print/magicfilter/files/magicfilter-2.3h-configure.patch
new file mode 100644
index 00000000000..0d89b4d04eb
--- /dev/null
+++ b/net-print/magicfilter/files/magicfilter-2.3h-configure.patch
@@ -0,0 +1,59 @@
+--- configure.sh
++++ configure.sh
+@@ -423,44 +423,12 @@ EOF
+ TLOGN " ($AC_CC)"
+ if [ $status -eq 0 ]; then
+ TLOG " ok"
+-
+- # check that the CFLAGS and LDFLAGS aren't bogus
+-
+- unset AC_CFLAGS AC_LDFLAGS
+-
+- if [ "$CFLAGS" ]; then
+- test "$CFLAGS" && echo "validating CFLAGS=${CFLAGS}"
+- if $AC_CC $CFLAGS -o /tmp/ngc$$.o /tmp/ngc$$.c ; then
+- AC_CFLAGS=${CFLAGS:-"-g"}
+- test "$CFLAGS" && echo "CFLAGS=\"${CFLAGS}\" are okay"
+- elif [ "$CFLAGS" ]; then
+- echo "ignoring bogus CFLAGS=\"${CFLAGS}\""
+- fi
+- else
+- AC_CFLAGS=-g
+- fi
+- if [ "$LDFLAGS" ]; then
+- test "$LDFLAGS" && echo "validating LDFLAGS=${LDFLAGS}"
+- if $AC_CC $LDFLAGS -o /tmp/ngc$$ /tmp/ngc$$.o; then
+- AC_LDFLAGS=${LDFLAGS:-"-g"}
+- test "$LDFLAGS" && TLOG "LDFLAGS=\"${LDFLAGS}\" are okay"
+- elif [ "$LDFLAGS" ]; then
+- TLOG "ignoring bogus LDFLAGS=\"${LDFLAGS}\""
+- fi
+- else
+- AC_LDFLAGS=${CFLAGS:-"-g"}
+- fi
+- AC_SUB 'CFLAGS' "$AC_CFLAGS"
+- AC_SUB 'LDFLAGS' "$AC_LDFLAGS"
+- else
+- AC_SUB 'CFLAGS' ''
+- AC_SUB 'LDFLAGS' ''
+- AC_FAIL " does not compile code properly"
+ fi
+
+- AC_SUB 'CC' "$AC_CC"
++ AC_SUB 'CFLAGS' "$CFLAGS"
++ AC_SUB 'LDFLAGS' "$LDFLAGS"
+
+- rm -f /tmp/ngc$$ /tmp/ngc$$.c /tmp/ngc$$.o
++ AC_SUB 'CC' "$AC_CC"
+
+ return $status
+ }
+@@ -896,7 +864,7 @@ AC_PROG_INSTALL () {
+ fi
+
+ AC_SUB 'INSTALL' "$PROG_INSTALL"
+- AC_SUB 'INSTALL_PROGRAM' "$PROG_INSTALL -s -m 755"
++ AC_SUB 'INSTALL_PROGRAM' "$PROG_INSTALL -m 755"
+ AC_SUB 'INSTALL_DATA' "$PROG_INSTALL -m 444"
+
+ # finally build a little directory installer
diff --git a/net-print/magicfilter/files/magicfilter-2.3h-makefile.patch b/net-print/magicfilter/files/magicfilter-2.3h-makefile.patch
new file mode 100644
index 00000000000..59c2cc15af9
--- /dev/null
+++ b/net-print/magicfilter/files/magicfilter-2.3h-makefile.patch
@@ -0,0 +1,75 @@
+--- Makefile.in
++++ Makefile.in
+@@ -17,7 +17,7 @@ libmagic @LIBMAGIC@:
+ @MAKE_MAGIC@ all
+
+ textonly: contrib/textonly.c
+- $(CC) $(CFLAGS) -o textonly $<
++ $(CC) $(CFLAGS) $(LDFLAGS) -o textonly $<
+
+ mpp: magic.m4 mkmpp
+ @srcdir@/mkmpp magic.m4
+@@ -43,47 +43,46 @@ magic.c: magic.m4 mkmagic config.h
+ cfmagic: file/magic
+ @MAKE_MAGIC@ magic
+
+-commoninstall: textonly @CFMAGIC@
+- @INSTALL_DIR@ $(prefix)/@exedir@
+- @INSTALL_DIR@ $(prefix)/@mandir@/man8
+- @INSTALL_DIR@ $(prefix)/@mandir@/man5
+- @INSTALL_DIR@ $(prefix)/@filterdir@
+- @INSTALL_MAGIC@ -m 444 file/magic $(prefix)/@MAGIC@
+- @INSTALL_PROGRAM@ -m 511 textonly $(prefix)/@filterdir@
++commoninstall: textonly
++ @INSTALL_DIR@ $(DESTDIR)$(prefix)/@exedir@
++ @INSTALL_DIR@ $(DESTDIR)$(prefix)/@mandir@/man8
++ @INSTALL_DIR@ $(DESTDIR)$(prefix)/@mandir@/man5
++ @INSTALL_DIR@ $(DESTDIR)$(prefix)/@filterdir@
++ @INSTALL_PROGRAM@ textonly $(DESTDIR)$(prefix)/@filterdir@
+
+ install: @DO_WHAT@
+
+ install-bin-t: traditional commoninstall
+- @INSTALL_PROGRAM@ -m 511 traditional $(prefix)/@exedir@/magicfilter-t
++ @INSTALL_PROGRAM@ traditional $(DESTDIR)$(prefix)/@exedir@/magicfilter-t
+
+ install-bin: magicfilter commoninstall
+- @INSTALL_PROGRAM@ -m 511 magicfilter $(prefix)/@exedir@
++ @INSTALL_PROGRAM@ magicfilter $(DESTDIR)$(prefix)/@exedir@
+
+ install-data-t: traditional commoninstall
+ @srcdir@/mkmpp
+ for x in @srcdir@/filters/*.def;do \
+- ./mpp @exedir@/magicfilter-t $$x > $(prefix)/@filterdir@/`basename $$x .def`-filter; \
+- chmod +x $(prefix)/@filterdir@/`basename $$x .def`-filter; \
++ ./mpp @exedir@/magicfilter-t $$x > $(DESTDIR)$(prefix)/@filterdir@/`basename $$x .def`-filter; \
++ chmod +x $(DESTDIR)$(prefix)/@filterdir@/`basename $$x .def`-filter; \
+ done
+ @rm -f mpp
+
+ install-data: magicfilter commoninstall
+ for x in @srcdir@/filters/*.def;do \
+- sed -e 's,@MAGIC''FILTER@,@exedir@/magicfilter,' < $$x > $(prefix)/@filterdir@/`basename $$x .def`; \
+- chmod +x $(prefix)/@filterdir@/`basename $$x .def`; \
++ sed -e 's,@MAGIC''FILTER@,@exedir@/magicfilter,' < $$x > $(DESTDIR)$(prefix)/@filterdir@/`basename $$x .def`; \
++ chmod +x $(DESTDIR)$(prefix)/@filterdir@/`basename $$x .def`; \
+ done
+
+ install-man: VERSION commoninstall
+ @SED@ -n -e 's/&PROGRAM&/magicfilter/g' -e 's/^MAN //p' -e @LPD_OPTS@ < magicfilter.8templ > $$$$; \
+- @INSTALL_DATA@ -m 444 $$$$ $(prefix)/@mandir@/man8/magicfilter.8; \
++ @INSTALL_DATA@ $$$$ $(DESTDIR)$(prefix)/@mandir@/man8/magicfilter.8; \
+ rm -f $$$$
+- @INSTALL_DATA@ -m 444 magicfilter.5 $(prefix)/@mandir@/man5
++ @INSTALL_DATA@ magicfilter.5 $(DESTDIR)$(prefix)/@mandir@/man5
+
+ install-man-t: VERSION commoninstall
+ @SED@ -n -e 's/&PROGRAM&/magicfilter-t/g' -e 's/^MAN //p' -e 's/^TRAD//p' -e @LPD_OPTS@ < magicfilter.8templ > $$$$; \
+- @INSTALL_DATA@ -m 444 $$$$ $(prefix)/@mandir@/man8/magicfilter-t.8; \
++ @INSTALL_DATA@ $$$$ $(DESTDIR)$(prefix)/@mandir@/man8/magicfilter-t.8; \
+ rm -f $$$$
+- @INSTALL_DATA@ -m 444 magicfilter-t.5 $(prefix)/@mandir@/man5
++ @INSTALL_DATA@ magicfilter-t.5 $(DESTDIR)$(prefix)/@mandir@/man5
+
+ install-traditional: install-man-t install-bin-t install-data-t
+
diff --git a/net-print/magicfilter/magicfilter-2.3h.ebuild b/net-print/magicfilter/magicfilter-2.3h.ebuild
new file mode 100644
index 00000000000..a3a4874cdaf
--- /dev/null
+++ b/net-print/magicfilter/magicfilter-2.3h.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+MY_P=${PN}-2.3.h
+
+DESCRIPTION="Customizable, extensible automatic printer filter"
+HOMEPAGE="http://www.pell.portland.or.us/~orc/Code/magicfilter/"
+SRC_URI="http://www.pell.portland.or.us/~orc/Code/magicfilter/${MY_P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="lprng-failsafe"
+
+DEPEND="app-text/ghostscript-gpl"
+RDEPEND="${DEPEND}
+ lprng-failsafe? ( net-print/lprng )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-2.3d-glibc-2.10.patch \
+ "${FILESDIR}"/${PN}-2.3h-configure.patch \
+ "${FILESDIR}"/${PN}-2.3h-makefile.patch
+}
+
+src_configure() {
+ local myconf
+ use lprng-failsafe && myconf="--with-lprng"
+
+ tc-export CC
+ export AC_CPP_PROG="$(tc-getCPP)"
+
+ ./configure.sh \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --filterdir=/usr/share/magicfilter/filters \
+ ${myconf} || die
+}
diff --git a/net-print/magicfilter/metadata.xml b/net-print/magicfilter/metadata.xml
new file mode 100644
index 00000000000..865a3c330b0
--- /dev/null
+++ b/net-print/magicfilter/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>printing</herd>
+ <use>
+ <flag name="lprng-failsafe">Refuse options for compability with certain LPRng versions.</flag>
+ </use>
+</pkgmetadata>