summaryrefslogtreecommitdiff
path: root/net-proxy/ntlmaps/ntlmaps-0.9.9-r2.ebuild
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-proxy/ntlmaps/ntlmaps-0.9.9-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-proxy/ntlmaps/ntlmaps-0.9.9-r2.ebuild')
-rw-r--r--net-proxy/ntlmaps/ntlmaps-0.9.9-r2.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/net-proxy/ntlmaps/ntlmaps-0.9.9-r2.ebuild b/net-proxy/ntlmaps/ntlmaps-0.9.9-r2.ebuild
new file mode 100644
index 00000000000..c23b818c53c
--- /dev/null
+++ b/net-proxy/ntlmaps/ntlmaps-0.9.9-r2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils user
+
+DESCRIPTION="NTLM proxy Authentication against MS proxy/web server"
+HOMEPAGE="http://ntlmaps.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 x86"
+IUSE=""
+
+DEPEND="dev-lang/python"
+
+pkg_setup() {
+ enewgroup ntlmaps
+ enewuser ntlmaps -1 -1 -1 ntlmaps
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+
+ sed -i -e 's/\r//' lib/*.py server.cfg *.txt doc/*.{txt,htm} || die 'Failed to convert line endings.'
+}
+
+src_install() {
+ exeinto /usr/bin
+ newexe main.py ntlmaps
+ insinto /usr/lib/ntlmaps
+ doins lib/*
+
+ dodoc *.txt doc/*.txt
+ dohtml doc/*
+
+ insopts -m0640 -g ntlmaps
+ insinto /etc/ntlmaps
+ doins server.cfg
+ newinitd "${FILESDIR}/ntlmaps.init" ntlmaps
+
+ diropts -m 0770 -g ntlmaps
+ keepdir /var/log/ntlmaps
+}
+
+pkg_preinst() {
+ #Remove the following lines sometime in December 2005
+ #Their purpose is to fix security bug #107766
+ if [ -f "${ROOT}/etc/ntlmaps/server.cfg" ]; then
+ chmod 0640 "${ROOT}/etc/ntlmaps/server.cfg"
+ chgrp ntlmaps "${ROOT}/etc/ntlmaps/server.cfg"
+ fi
+}
+
+pkg_prerm() {
+ einfo "Removing python compiled bytecode"
+ rm -f "${ROOT}"/usr/lib/ntlmaps/*.py?
+}