summaryrefslogtreecommitdiff
path: root/net-vpn
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2018-03-18 17:27:39 +0100
committerJohannes Huber <johu@gentoo.org>2018-03-18 17:28:47 +0100
commit3f933e6eb7801b648e5f4e61f8c7a66d26332970 (patch)
tree1505789d9c4ab2802e9ef45e431884e564ff27ce /net-vpn
parent68a4197d1232cf025d423c549dba31677ac55556 (diff)
downloadgentoo-3f933e6eb7801b648e5f4e61f8c7a66d26332970.tar.gz
gentoo-3f933e6eb7801b648e5f4e61f8c7a66d26332970.tar.xz
net-vpn/openfortivpn: Version bump 1.6.0
Closes: https://bugs.gentoo.org/650548 Reported-by: Arne Babenhauserheide <arne_bab@web.de> Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/openfortivpn/Manifest1
-rw-r--r--net-vpn/openfortivpn/openfortivpn-1.6.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/net-vpn/openfortivpn/Manifest b/net-vpn/openfortivpn/Manifest
index fd81b050c26..cfbb82a8b28 100644
--- a/net-vpn/openfortivpn/Manifest
+++ b/net-vpn/openfortivpn/Manifest
@@ -1 +1,2 @@
DIST openfortivpn-1.5.0.tar.gz 52302 BLAKE2B 8e776d089eee5a33a80b36684f006b3a4bda56405f50b134edfb371f174341299362f2d7e79f8c0b86bd9c255f253cdd195c2598f462d4f3ee262727ab31d135 SHA512 2ee56baf83b4ca604512dfb0f518c03731be18c08399a4482190ea9c8cf0c14a570e31ae3b1bcd32067203a008d02a7d4414000f817b178b4cdbd171035be76c
+DIST openfortivpn-1.6.0.tar.gz 55606 BLAKE2B 649ca2a8112313fc7b63d89867efe33c4cf8e75cb4c2f7f19839e1f569ac04e3ace841b17ac0e7aa9b51a7e6d9b1f7910925761d5052cac6ef5aec1e257b93bc SHA512 547dca62022f56271717191a10a645b8a1c554568536f0695ef73d8c2883926e957dc070570648ed672786374a01b110de34b4ea19c4ae8cb2e3657c27716c69
diff --git a/net-vpn/openfortivpn/openfortivpn-1.6.0.ebuild b/net-vpn/openfortivpn/openfortivpn-1.6.0.ebuild
new file mode 100644
index 00000000000..c8484fbeaef
--- /dev/null
+++ b/net-vpn/openfortivpn/openfortivpn-1.6.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools linux-info
+
+DESCRIPTION="A Fortinet compatible VPN client"
+HOMEPAGE="https://github.com/adrienverge/openfortivpn"
+SRC_URI="https://github.com/adrienverge/openfortivpn/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3-with-openssl-exception openssl"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libressl"
+
+DEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ net-dialup/ppp
+"
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~PPP ~PPP_ASYNC"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' Makefile.am || die "Failed to remove -Werror from Makefile.am"
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ keepdir /etc/openfortivpn
+}