summaryrefslogtreecommitdiff
path: root/net-wireless/chirp
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-wireless/chirp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-wireless/chirp')
-rw-r--r--net-wireless/chirp/Manifest1
-rw-r--r--net-wireless/chirp/chirp-0.4.1.ebuild43
-rw-r--r--net-wireless/chirp/chirp-9999.ebuild43
-rw-r--r--net-wireless/chirp/metadata.xml12
4 files changed, 99 insertions, 0 deletions
diff --git a/net-wireless/chirp/Manifest b/net-wireless/chirp/Manifest
new file mode 100644
index 00000000000..4fefe4dde90
--- /dev/null
+++ b/net-wireless/chirp/Manifest
@@ -0,0 +1 @@
+DIST chirp-0.4.1.tar.gz 416851 SHA256 8c9d652dc89dbab9e2a1a75c07aa7179ce403de078a4d02814365f89e183319e SHA512 13f36e96bb1608a41605cedd2fa3dfb46efc37e97437d09b75a0dd9ff10bb85c32ef3190d8db3fdb0360de8b85470588492df3ca5b3e2ecbdb813f3f11a9cc57 WHIRLPOOL 995c370a48b63fe4eb4d879b11f85385474a2ebcb5ea23f09db89661f42bdb0ad6867a172d4a15821eaf84d83469b55790b02d2fe4c4ce276e1a713022a5f49e
diff --git a/net-wireless/chirp/chirp-0.4.1.ebuild b/net-wireless/chirp/chirp-0.4.1.ebuild
new file mode 100644
index 00000000000..3ec9e14c9d5
--- /dev/null
+++ b/net-wireless/chirp/chirp-0.4.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+if [[ ${PV} == "9999" ]] ; then
+ SCM=mercurial
+ EHG_REPO_URI="http://d-rats.com/hg/chirp.hg"
+fi
+
+inherit distutils-r1 ${SCM}
+
+DESCRIPTION="Free open-source tool for programming your amateur radio"
+HOMEPAGE="http://chirp.danplanet.com"
+
+if [[ ${PV} == "9999" ]] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="http://chirp.danplanet.com/download/${PV}/${P}.tar.gz"
+ RESTRICT="test"
+fi
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/pyserial
+ dev-libs/libxml2[python]"
+RDEPEND="${DEPEND}
+ dev-python/pygtk"
+
+src_prepare() {
+ sed -i -e "/share\/doc\/chirp/d" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ pushd tests > /dev/null
+ "${PYTHON}" run_tests || die
+ popd > /dev/null
+}
diff --git a/net-wireless/chirp/chirp-9999.ebuild b/net-wireless/chirp/chirp-9999.ebuild
new file mode 100644
index 00000000000..3ec9e14c9d5
--- /dev/null
+++ b/net-wireless/chirp/chirp-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+if [[ ${PV} == "9999" ]] ; then
+ SCM=mercurial
+ EHG_REPO_URI="http://d-rats.com/hg/chirp.hg"
+fi
+
+inherit distutils-r1 ${SCM}
+
+DESCRIPTION="Free open-source tool for programming your amateur radio"
+HOMEPAGE="http://chirp.danplanet.com"
+
+if [[ ${PV} == "9999" ]] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="http://chirp.danplanet.com/download/${PV}/${P}.tar.gz"
+ RESTRICT="test"
+fi
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/pyserial
+ dev-libs/libxml2[python]"
+RDEPEND="${DEPEND}
+ dev-python/pygtk"
+
+src_prepare() {
+ sed -i -e "/share\/doc\/chirp/d" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ pushd tests > /dev/null
+ "${PYTHON}" run_tests || die
+ popd > /dev/null
+}
diff --git a/net-wireless/chirp/metadata.xml b/net-wireless/chirp/metadata.xml
new file mode 100644
index 00000000000..50b2373a3fe
--- /dev/null
+++ b/net-wireless/chirp/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>radio</herd>
+<maintainer>
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+