summaryrefslogtreecommitdiff
path: root/perl-core/ExtUtils-MakeMaker
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /perl-core/ExtUtils-MakeMaker
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'perl-core/ExtUtils-MakeMaker')
-rw-r--r--perl-core/ExtUtils-MakeMaker/ExtUtils-MakeMaker-7.40.0-r1.ebuild40
-rw-r--r--perl-core/ExtUtils-MakeMaker/Manifest1
-rw-r--r--perl-core/ExtUtils-MakeMaker/files/6.56-delete_packlist_podlocal.patch79
-rw-r--r--perl-core/ExtUtils-MakeMaker/files/6.58-RUNPATH.patch16
-rw-r--r--perl-core/ExtUtils-MakeMaker/files/6.58-delete_packlist_podlocal.patch76
-rw-r--r--perl-core/ExtUtils-MakeMaker/files/6.62-delete_packlist_podlocal.patch76
-rw-r--r--perl-core/ExtUtils-MakeMaker/files/6.82-delete_packlist_podlocal.patch59
-rw-r--r--perl-core/ExtUtils-MakeMaker/files/7.04-delete_packlist_podlocal.patch63
-rw-r--r--perl-core/ExtUtils-MakeMaker/files/RUNPATH-6.54.patch17
-rw-r--r--perl-core/ExtUtils-MakeMaker/metadata.xml38
10 files changed, 465 insertions, 0 deletions
diff --git a/perl-core/ExtUtils-MakeMaker/ExtUtils-MakeMaker-7.40.0-r1.ebuild b/perl-core/ExtUtils-MakeMaker/ExtUtils-MakeMaker-7.40.0-r1.ebuild
new file mode 100644
index 00000000000..515f9ea437e
--- /dev/null
+++ b/perl-core/ExtUtils-MakeMaker/ExtUtils-MakeMaker-7.40.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+MODULE_AUTHOR=BINGOS
+MODULE_VERSION=7.04
+inherit eutils perl-module
+
+DESCRIPTION="Create a module Makefile"
+HOMEPAGE="http://makemaker.org ${HOMEPAGE}"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="
+ >=virtual/perl-ExtUtils-Command-1.160.0
+ >=virtual/perl-ExtUtils-Install-1.520.0
+ >=virtual/perl-ExtUtils-Manifest-1.700.0
+ >=virtual/perl-File-Spec-0.800.0
+"
+RDEPEND="${DEPEND}"
+PDEPEND="
+ >=virtual/perl-CPAN-Meta-2.143.240
+ >=virtual/perl-Parse-CPAN-Meta-1.441.400
+"
+
+PATCHES=(
+ "${FILESDIR}/7.04-delete_packlist_podlocal.patch"
+ "${FILESDIR}/6.58-RUNPATH.patch"
+)
+SRC_TEST=do
+
+src_prepare() {
+ edos2unix "${S}/lib/ExtUtils/MM_Unix.pm"
+ edos2unix "${S}/lib/ExtUtils/MM_Any.pm"
+
+ export BUILDING_AS_PACKAGE=1
+ perl-module_src_prepare
+}
diff --git a/perl-core/ExtUtils-MakeMaker/Manifest b/perl-core/ExtUtils-MakeMaker/Manifest
new file mode 100644
index 00000000000..da79a1263c3
--- /dev/null
+++ b/perl-core/ExtUtils-MakeMaker/Manifest
@@ -0,0 +1 @@
+DIST ExtUtils-MakeMaker-7.04.tar.gz 439960 SHA256 98126b012d70c2af0f8e33a07ebe0d6f2340281b2460981b959a9fb31d5ad97f SHA512 10b905dfdda2c6b4d59e6dac5a5da64db4674df51fc4d87af36fa8735fac93baa43fc9e083a37b09a3b66fe546d053224b2f1bfb5981ad1fa0f4fa6e61f2563c WHIRLPOOL ff6078394c488633adf3d1214c9379921a0c015215bab2ba2fb9305eb203f9fef95ce0aa95a5f9d274b348d74e7ea26a02ff5101a931e26df7700ce98133c2e9
diff --git a/perl-core/ExtUtils-MakeMaker/files/6.56-delete_packlist_podlocal.patch b/perl-core/ExtUtils-MakeMaker/files/6.56-delete_packlist_podlocal.patch
new file mode 100644
index 00000000000..c5763d16726
--- /dev/null
+++ b/perl-core/ExtUtils-MakeMaker/files/6.56-delete_packlist_podlocal.patch
@@ -0,0 +1,79 @@
+Don't install .packlist or perllocal.pod for perl or vendor.
+Extracted from the debian patchset.
+See also bug #241834
+
+---
+ cpan/ExtUtils-MakeMaker/lib/ExtUtils/MM_Unix.pm | 25 +----------------------
+ 1 files changed, 1 insertions(+), 24 deletions(-)
+
+diff --git a/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MM_Unix.pm b/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MM_Unix.pm
+index 239d6df..b4649ee 100644
+--- a/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MM_Unix.pm
++++ b/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MM_Unix.pm
+@@ -2047,8 +2047,6 @@ doc__install : doc_site_install
+
+ pure_perl_install :: all
+ $(NOECHO) $(MOD_INSTALL) \
+- read }.$self->catfile('$(PERL_ARCHLIB)','auto','$(FULLEXT)','.packlist').q{ \
+- write }.$self->catfile('$(DESTINSTALLARCHLIB)','auto','$(FULLEXT)','.packlist').q{ \
+ $(INST_LIB) $(DESTINSTALLPRIVLIB) \
+ $(INST_ARCHLIB) $(DESTINSTALLARCHLIB) \
+ $(INST_BIN) $(DESTINSTALLBIN) \
+@@ -2074,8 +2072,6 @@ pure_site_install :: all
+
+ pure_vendor_install :: all
+ $(NOECHO) $(MOD_INSTALL) \
+- read }.$self->catfile('$(VENDORARCHEXP)','auto','$(FULLEXT)','.packlist').q{ \
+- write }.$self->catfile('$(DESTINSTALLVENDORARCH)','auto','$(FULLEXT)','.packlist').q{ \
+ $(INST_LIB) $(DESTINSTALLVENDORLIB) \
+ $(INST_ARCHLIB) $(DESTINSTALLVENDORARCH) \
+ $(INST_BIN) $(DESTINSTALLVENDORBIN) \
+@@ -2084,15 +2080,6 @@ pure_vendor_install :: all
+ $(INST_MAN3DIR) $(DESTINSTALLVENDORMAN3DIR)
+
+ doc_perl_install :: all
+- $(NOECHO) $(ECHO) Appending installation info to $(DESTINSTALLARCHLIB)/perllocal.pod
+- -$(NOECHO) $(MKPATH) $(DESTINSTALLARCHLIB)
+- -$(NOECHO) $(DOC_INSTALL) \
+- "Module" "$(NAME)" \
+- "installed into" "$(INSTALLPRIVLIB)" \
+- LINKTYPE "$(LINKTYPE)" \
+- VERSION "$(VERSION)" \
+- EXE_FILES "$(EXE_FILES)" \
+- >> }.$self->catfile('$(DESTINSTALLARCHLIB)','perllocal.pod').q{
+
+ doc_site_install :: all
+ $(NOECHO) $(ECHO) Appending installation info to $(DESTINSTALLARCHLIB)/perllocal.pod
+@@ -2106,15 +2093,6 @@ doc_site_install :: all
+ >> }.$self->catfile('$(DESTINSTALLARCHLIB)','perllocal.pod').q{
+
+ doc_vendor_install :: all
+- $(NOECHO) $(ECHO) Appending installation info to $(DESTINSTALLARCHLIB)/perllocal.pod
+- -$(NOECHO) $(MKPATH) $(DESTINSTALLARCHLIB)
+- -$(NOECHO) $(DOC_INSTALL) \
+- "Module" "$(NAME)" \
+- "installed into" "$(INSTALLVENDORLIB)" \
+- LINKTYPE "$(LINKTYPE)" \
+- VERSION "$(VERSION)" \
+- EXE_FILES "$(EXE_FILES)" \
+- >> }.$self->catfile('$(DESTINSTALLARCHLIB)','perllocal.pod').q{
+
+ };
+
+@@ -2123,13 +2101,12 @@ uninstall :: uninstall_from_$(INSTALLDIRS)dirs
+ $(NOECHO) $(NOOP)
+
+ uninstall_from_perldirs ::
+- $(NOECHO) $(UNINSTALL) }.$self->catfile('$(PERL_ARCHLIB)','auto','$(FULLEXT)','.packlist').q{
+
+ uninstall_from_sitedirs ::
+ $(NOECHO) $(UNINSTALL) }.$self->catfile('$(SITEARCHEXP)','auto','$(FULLEXT)','.packlist').q{
+
+ uninstall_from_vendordirs ::
+- $(NOECHO) $(UNINSTALL) }.$self->catfile('$(VENDORARCHEXP)','auto','$(FULLEXT)','.packlist').q{
++
+ };
+
+ join("",@m);
+--
+tg: (b9ce030..) gentoo/MakeMaker-delete_packlist (depends on: upstream)
diff --git a/perl-core/ExtUtils-MakeMaker/files/6.58-RUNPATH.patch b/perl-core/ExtUtils-MakeMaker/files/6.58-RUNPATH.patch
new file mode 100644
index 00000000000..41f26098b2b
--- /dev/null
+++ b/perl-core/ExtUtils-MakeMaker/files/6.58-RUNPATH.patch
@@ -0,0 +1,16 @@
+--- a/lib/ExtUtils/MM_Any.pm
++++ b/lib/ExtUtils/MM_Any.pm
+@@ -1900,6 +1900,13 @@ CODE
+ # LD_RUN_PATH now computed by ExtUtils::Liblist
+ ($self->{EXTRALIBS}, $self->{BSLOADLIBS},
+ $self->{LDLOADLIBS}, $self->{LD_RUN_PATH}) = @libs;
++ # We do not want the build root in RPATH
++ if ( exists $ENV{PORTAGE_TMPDIR} ){
++ # If we have a PORTAGE_TMPDIR set, strip that, as just testing for
++ # /usr and /opt might not be sufficient.
++ $self->{LD_RUN_PATH} = join ':', grep !/^\Q$ENV{PORTAGE_TMPDIR}/,
++ split /:/, $self->{LD_RUN_PATH};
++ }
+ last;
+ }
+ }
diff --git a/perl-core/ExtUtils-MakeMaker/files/6.58-delete_packlist_podlocal.patch b/perl-core/ExtUtils-MakeMaker/files/6.58-delete_packlist_podlocal.patch
new file mode 100644
index 00000000000..c42d1d2c9f4
--- /dev/null
+++ b/perl-core/ExtUtils-MakeMaker/files/6.58-delete_packlist_podlocal.patch
@@ -0,0 +1,76 @@
+Don't install .packlist or perllocal.pod for perl or vendor.
+Extracted from the debian patchset.
+See also bug #241834
+---
+ lib/ExtUtils/MM_Unix.pm | 25 +------------------------
+ 1 files changed, 1 insertions(+), 24 deletions(-)
+
+diff --git a/lib/ExtUtils/MM_Unix.pm b/lib/ExtUtils/MM_Unix.pm
+index 10fcdf4..642b677 100644
+--- a/lib/ExtUtils/MM_Unix.pm
++++ b/lib/ExtUtils/MM_Unix.pm
+@@ -2047,8 +2047,6 @@ doc__install : doc_site_install
+
+ pure_perl_install :: all
+ $(NOECHO) $(MOD_INSTALL) \
+- read }.$self->catfile('$(PERL_ARCHLIB)','auto','$(FULLEXT)','.packlist').q{ \
+- write }.$self->catfile('$(DESTINSTALLARCHLIB)','auto','$(FULLEXT)','.packlist').q{ \
+ $(INST_LIB) $(DESTINSTALLPRIVLIB) \
+ $(INST_ARCHLIB) $(DESTINSTALLARCHLIB) \
+ $(INST_BIN) $(DESTINSTALLBIN) \
+@@ -2074,8 +2072,6 @@ pure_site_install :: all
+
+ pure_vendor_install :: all
+ $(NOECHO) $(MOD_INSTALL) \
+- read }.$self->catfile('$(VENDORARCHEXP)','auto','$(FULLEXT)','.packlist').q{ \
+- write }.$self->catfile('$(DESTINSTALLVENDORARCH)','auto','$(FULLEXT)','.packlist').q{ \
+ $(INST_LIB) $(DESTINSTALLVENDORLIB) \
+ $(INST_ARCHLIB) $(DESTINSTALLVENDORARCH) \
+ $(INST_BIN) $(DESTINSTALLVENDORBIN) \
+@@ -2084,15 +2080,6 @@ pure_vendor_install :: all
+ $(INST_MAN3DIR) $(DESTINSTALLVENDORMAN3DIR)
+
+ doc_perl_install :: all
+- $(NOECHO) $(ECHO) Appending installation info to $(DESTINSTALLARCHLIB)/perllocal.pod
+- -$(NOECHO) $(MKPATH) $(DESTINSTALLARCHLIB)
+- -$(NOECHO) $(DOC_INSTALL) \
+- "Module" "$(NAME)" \
+- "installed into" "$(INSTALLPRIVLIB)" \
+- LINKTYPE "$(LINKTYPE)" \
+- VERSION "$(VERSION)" \
+- EXE_FILES "$(EXE_FILES)" \
+- >> }.$self->catfile('$(DESTINSTALLARCHLIB)','perllocal.pod').q{
+
+ doc_site_install :: all
+ $(NOECHO) $(ECHO) Appending installation info to $(DESTINSTALLARCHLIB)/perllocal.pod
+@@ -2106,15 +2093,6 @@ doc_site_install :: all
+ >> }.$self->catfile('$(DESTINSTALLARCHLIB)','perllocal.pod').q{
+
+ doc_vendor_install :: all
+- $(NOECHO) $(ECHO) Appending installation info to $(DESTINSTALLARCHLIB)/perllocal.pod
+- -$(NOECHO) $(MKPATH) $(DESTINSTALLARCHLIB)
+- -$(NOECHO) $(DOC_INSTALL) \
+- "Module" "$(NAME)" \
+- "installed into" "$(INSTALLVENDORLIB)" \
+- LINKTYPE "$(LINKTYPE)" \
+- VERSION "$(VERSION)" \
+- EXE_FILES "$(EXE_FILES)" \
+- >> }.$self->catfile('$(DESTINSTALLARCHLIB)','perllocal.pod').q{
+
+ };
+
+@@ -2123,13 +2101,12 @@ uninstall :: uninstall_from_$(INSTALLDIRS)dirs
+ $(NOECHO) $(NOOP)
+
+ uninstall_from_perldirs ::
+- $(NOECHO) $(UNINSTALL) }.$self->catfile('$(PERL_ARCHLIB)','auto','$(FULLEXT)','.packlist').q{
+
+ uninstall_from_sitedirs ::
+ $(NOECHO) $(UNINSTALL) }.$self->catfile('$(SITEARCHEXP)','auto','$(FULLEXT)','.packlist').q{
+
+ uninstall_from_vendordirs ::
+- $(NOECHO) $(UNINSTALL) }.$self->catfile('$(VENDORARCHEXP)','auto','$(FULLEXT)','.packlist').q{
++
+ };
+
+ join("",@m);
diff --git a/perl-core/ExtUtils-MakeMaker/files/6.62-delete_packlist_podlocal.patch b/perl-core/ExtUtils-MakeMaker/files/6.62-delete_packlist_podlocal.patch
new file mode 100644
index 00000000000..9d8ee7e580a
--- /dev/null
+++ b/perl-core/ExtUtils-MakeMaker/files/6.62-delete_packlist_podlocal.patch
@@ -0,0 +1,76 @@
+--- a/lib/ExtUtils/MM_Unix.pm
++++ b/lib/ExtUtils/MM_Unix.pm
+@@ -2052,8 +2052,6 @@ doc__install : doc_site_install
+
+ pure_perl_install :: all
+ $(NOECHO) $(MOD_INSTALL) \
+- read }.$self->catfile('$(PERL_ARCHLIB)','auto','$(FULLEXT)','.packlist').q{ \
+- write }.$self->catfile('$(DESTINSTALLARCHLIB)','auto','$(FULLEXT)','.packlist').q{ \
+ $(INST_LIB) $(DESTINSTALLPRIVLIB) \
+ $(INST_ARCHLIB) $(DESTINSTALLARCHLIB) \
+ $(INST_BIN) $(DESTINSTALLBIN) \
+@@ -2079,8 +2077,6 @@ pure_site_install :: all
+
+ pure_vendor_install :: all
+ $(NOECHO) $(MOD_INSTALL) \
+- read }.$self->catfile('$(VENDORARCHEXP)','auto','$(FULLEXT)','.packlist').q{ \
+- write }.$self->catfile('$(DESTINSTALLVENDORARCH)','auto','$(FULLEXT)','.packlist').q{ \
+ $(INST_LIB) $(DESTINSTALLVENDORLIB) \
+ $(INST_ARCHLIB) $(DESTINSTALLVENDORARCH) \
+ $(INST_BIN) $(DESTINSTALLVENDORBIN) \
+@@ -2089,37 +2085,19 @@ pure_vendor_install :: all
+ $(INST_MAN3DIR) $(DESTINSTALLVENDORMAN3DIR)
+
+ doc_perl_install :: all
+- $(NOECHO) $(ECHO) Appending installation info to $(DESTINSTALLARCHLIB)/perllocal.pod
+- -$(NOECHO) $(MKPATH) $(DESTINSTALLARCHLIB)
+- -$(NOECHO) $(DOC_INSTALL) \
+- "Module" "$(NAME)" \
+- "installed into" "$(INSTALLPRIVLIB)" \
+- LINKTYPE "$(LINKTYPE)" \
+- VERSION "$(VERSION)" \
+- EXE_FILES "$(EXE_FILES)" \
+- >> }.$self->catfile('$(DESTINSTALLARCHLIB)','perllocal.pod').q{
+
+ doc_site_install :: all
+- $(NOECHO) $(ECHO) Appending installation info to $(DESTINSTALLARCHLIB)/perllocal.pod
+- -$(NOECHO) $(MKPATH) $(DESTINSTALLARCHLIB)
++ $(NOECHO) $(ECHO) Appending installation info to $(DESTINSTALLSITEARCH)/perllocal.pod
++ -$(NOECHO) $(MKPATH) $(DESTINSTALLSITEARCH)
+ -$(NOECHO) $(DOC_INSTALL) \
+ "Module" "$(NAME)" \
+ "installed into" "$(INSTALLSITELIB)" \
+ LINKTYPE "$(LINKTYPE)" \
+ VERSION "$(VERSION)" \
+ EXE_FILES "$(EXE_FILES)" \
+- >> }.$self->catfile('$(DESTINSTALLARCHLIB)','perllocal.pod').q{
++ >> }.$self->catfile('$(DESTINSTALLSITEARCH)','perllocal.pod').q{
+
+ doc_vendor_install :: all
+- $(NOECHO) $(ECHO) Appending installation info to $(DESTINSTALLARCHLIB)/perllocal.pod
+- -$(NOECHO) $(MKPATH) $(DESTINSTALLARCHLIB)
+- -$(NOECHO) $(DOC_INSTALL) \
+- "Module" "$(NAME)" \
+- "installed into" "$(INSTALLVENDORLIB)" \
+- LINKTYPE "$(LINKTYPE)" \
+- VERSION "$(VERSION)" \
+- EXE_FILES "$(EXE_FILES)" \
+- >> }.$self->catfile('$(DESTINSTALLARCHLIB)','perllocal.pod').q{
+
+ };
+
+@@ -2128,13 +2106,12 @@ uninstall :: uninstall_from_$(INSTALLDIRS)dirs
+ $(NOECHO) $(NOOP)
+
+ uninstall_from_perldirs ::
+- $(NOECHO) $(UNINSTALL) }.$self->catfile('$(PERL_ARCHLIB)','auto','$(FULLEXT)','.packlist').q{
+
+ uninstall_from_sitedirs ::
+ $(NOECHO) $(UNINSTALL) }.$self->catfile('$(SITEARCHEXP)','auto','$(FULLEXT)','.packlist').q{
+
+ uninstall_from_vendordirs ::
+- $(NOECHO) $(UNINSTALL) }.$self->catfile('$(VENDORARCHEXP)','auto','$(FULLEXT)','.packlist').q{
++
+ };
+
+ join("",@m);
diff --git a/perl-core/ExtUtils-MakeMaker/files/6.82-delete_packlist_podlocal.patch b/perl-core/ExtUtils-MakeMaker/files/6.82-delete_packlist_podlocal.patch
new file mode 100644
index 00000000000..657a6b68894
--- /dev/null
+++ b/perl-core/ExtUtils-MakeMaker/files/6.82-delete_packlist_podlocal.patch
@@ -0,0 +1,59 @@
+--- lib/ExtUtils/MakeMaker.pm.bak 2013-11-25 20:48:18.119741749 +0400
++++ lib/ExtUtils/MakeMaker.pm 2013-11-25 20:49:26.798740829 +0400
+@@ -2246,13 +2246,13 @@
+ When true, suppresses the generation of MYMETA.yml and MYMETA.json module
+ meta-data files during 'perl Makefile.PL'.
+
+-Defaults to false.
++Defaults to true.
+
+ =item NO_PACKLIST
+
+ When true, suppresses the writing of C<packlist> files for installs.
+
+-Defaults to false.
++Defaults to true.
+
+ =item NO_PERLLOCAL
+
+--- lib/ExtUtils/MM_Unix.pm.bak 2013-11-25 20:48:24.903741658 +0400
++++ lib/ExtUtils/MM_Unix.pm 2013-11-25 20:50:54.662739652 +0400
+@@ -1574,6 +1574,16 @@
+ $self->{FULLEXT} = $self->catdir(split /::/, $self->{NAME});
+
+
++ # Workaround for https://bugs.gentoo.org/show_bug.cgi?id=221179
++ if (!exists($self->{NO_PERLLOCAL})) {
++ $self->{NO_PERLLOCAL} = 1;
++ }
++
++ if (!exists($self->{NO_PACKLIST})) {
++ $self->{NO_PACKLIST} = 1;
++ }
++
++
+ # Copied from DynaLoader:
+
+ my(@modparts) = split(/::/,$self->{NAME});
+--- t/basic.t.bak 2013-11-25 20:48:29.919741591 +0400
++++ t/basic.t 2013-11-25 20:51:15.437739373 +0400
+@@ -43,7 +43,7 @@
+ ok( chdir('Big-Dummy'), "chdir'd to Big-Dummy" ) ||
+ diag("chdir failed: $!");
+
+-my @mpl_out = run(qq{$perl Makefile.PL "PREFIX=../dummy-install"});
++my @mpl_out = run(qq{$perl Makefile.PL "PREFIX=../dummy-install" NO_PERLLOCAL=0 NO_PACKLIST=0});
+ END { rmtree '../dummy-install'; }
+
+ cmp_ok( $?, '==', 0, 'Makefile.PL exited with zero' ) ||
+--- t/INSTALL_BASE.t.bak 2013-11-25 20:48:48.119741347 +0400
++++ t/INSTALL_BASE.t 2013-11-25 20:51:42.549739010 +0400
+@@ -35,7 +35,7 @@
+
+ ok( chdir('Big-Dummy'), "chdir'd to Big-Dummy") || diag("chdir failed; $!");
+
+-my @mpl_out = run(qq{$perl Makefile.PL "INSTALL_BASE=../dummy-install"});
++my @mpl_out = run(qq{$perl Makefile.PL "INSTALL_BASE=../dummy-install" NO_PERLLOCAL=0 NO_PACKLIST=0});
+ END { rmtree '../dummy-install'; }
+
+ cmp_ok( $?, '==', 0, 'Makefile.PL exited with zero' ) || \ No newline at end of file
diff --git a/perl-core/ExtUtils-MakeMaker/files/7.04-delete_packlist_podlocal.patch b/perl-core/ExtUtils-MakeMaker/files/7.04-delete_packlist_podlocal.patch
new file mode 100644
index 00000000000..266d5d240c0
--- /dev/null
+++ b/perl-core/ExtUtils-MakeMaker/files/7.04-delete_packlist_podlocal.patch
@@ -0,0 +1,63 @@
+diff -ruN ExtUtils-MakeMaker-7.04.orig/lib/ExtUtils/MM_Unix.pm ExtUtils-MakeMaker-7.04/lib/ExtUtils/MM_Unix.pm
+--- ExtUtils-MakeMaker-7.04.orig/lib/ExtUtils/MM_Unix.pm 2014-12-02 13:44:33.000000000 +0100
++++ ExtUtils-MakeMaker-7.04/lib/ExtUtils/MM_Unix.pm 2015-02-25 23:54:03.373862321 +0100
+@@ -1606,6 +1606,16 @@
+ $self->{FULLEXT} = $self->catdir(split /::/, $self->{NAME});
+
+
++ # Workaround for https://bugs.gentoo.org/show_bug.cgi?id=221179
++ if (!exists($self->{NO_PERLLOCAL})) {
++ $self->{NO_PERLLOCAL} = 1;
++ }
++
++ if (!exists($self->{NO_PACKLIST})) {
++ $self->{NO_PACKLIST} = 1;
++ }
++
++
+ # Copied from DynaLoader:
+
+ my(@modparts) = split(/::/,$self->{NAME});
+diff -ruN ExtUtils-MakeMaker-7.04.orig/lib/ExtUtils/MakeMaker.pm ExtUtils-MakeMaker-7.04/lib/ExtUtils/MakeMaker.pm
+--- ExtUtils-MakeMaker-7.04.orig/lib/ExtUtils/MakeMaker.pm 2014-12-02 13:44:33.000000000 +0100
++++ ExtUtils-MakeMaker-7.04/lib/ExtUtils/MakeMaker.pm 2015-02-25 23:54:03.373862321 +0100
+@@ -2348,13 +2348,13 @@
+ When true, suppresses the generation of MYMETA.yml and MYMETA.json module
+ meta-data files during 'perl Makefile.PL'.
+
+-Defaults to false.
++Defaults to true.
+
+ =item NO_PACKLIST
+
+ When true, suppresses the writing of C<packlist> files for installs.
+
+-Defaults to false.
++Defaults to true.
+
+ =item NO_PERLLOCAL
+
+diff -ruN ExtUtils-MakeMaker-7.04.orig/t/INSTALL_BASE.t ExtUtils-MakeMaker-7.04/t/INSTALL_BASE.t
+--- ExtUtils-MakeMaker-7.04.orig/t/INSTALL_BASE.t 2014-11-11 14:50:52.000000000 +0100
++++ ExtUtils-MakeMaker-7.04/t/INSTALL_BASE.t 2015-02-25 23:59:00.383878929 +0100
+@@ -42,7 +42,7 @@
+ ok( chdir('Big-Dummy'), "chdir'd to Big-Dummy") || diag("chdir failed; $!");
+
+ for my $instdir (@INSTDIRS) {
+- my @mpl_out = run(qq{$perl Makefile.PL "INSTALL_BASE=$instdir"});
++ my @mpl_out = run(qq{$perl Makefile.PL "INSTALL_BASE=$instdir" NO_PERLLOCAL=0 NO_PACKLIST=0});
+
+ cmp_ok( $?, '==', 0, 'Makefile.PL exited with zero' ) ||
+ diag(@mpl_out);
+diff -ruN ExtUtils-MakeMaker-7.04.orig/t/basic.t ExtUtils-MakeMaker-7.04/t/basic.t
+--- ExtUtils-MakeMaker-7.04.orig/t/basic.t 2014-11-11 14:50:52.000000000 +0100
++++ ExtUtils-MakeMaker-7.04/t/basic.t 2015-02-25 23:56:51.161871703 +0100
+@@ -59,7 +59,7 @@
+
+ sub extrachar { $] > 5.008 && !$ENV{PERL_CORE} ? utf8::decode(my $c='š') : 's' }
+ my $DUMMYINST = '../dummy-in'.extrachar().'tall';
+-my @mpl_out = run(qq{$perl Makefile.PL "PREFIX=$DUMMYINST"});
++my @mpl_out = run(qq{$perl Makefile.PL "PREFIX=$DUMMYINST" NO_PERLLOCAL=0 NO_PACKLIST=0});
+ END { rmtree $DUMMYINST; }
+
+ cmp_ok( $?, '==', 0, 'Makefile.PL exited with zero' ) ||
diff --git a/perl-core/ExtUtils-MakeMaker/files/RUNPATH-6.54.patch b/perl-core/ExtUtils-MakeMaker/files/RUNPATH-6.54.patch
new file mode 100644
index 00000000000..13852078691
--- /dev/null
+++ b/perl-core/ExtUtils-MakeMaker/files/RUNPATH-6.54.patch
@@ -0,0 +1,17 @@
+diff -Naur ExtUtils-MakeMaker-6.54/lib/ExtUtils/MM_Any.pm ExtUtils-MakeMaker-6.54.new/lib/ExtUtils/MM_Any.pm
+--- ExtUtils-MakeMaker-6.54/lib/ExtUtils/MM_Any.pm 2009-07-08 11:49:05.000000000 +1200
++++ ExtUtils-MakeMaker-6.54.new/lib/ExtUtils/MM_Any.pm 2009-08-19 21:37:31.494655658 +1200
+@@ -1799,6 +1799,13 @@
+ # LD_RUN_PATH now computed by ExtUtils::Liblist
+ ($self->{EXTRALIBS}, $self->{BSLOADLIBS},
+ $self->{LDLOADLIBS}, $self->{LD_RUN_PATH}) = @libs;
++ # We do not want the build root in RPATH
++ if (exists $ENV{PORTAGE_TMPDIR}) {
++ # If we have PORTAGE_TMPDIR set, strip that, as just testing for
++ # /usr and /opt might not be sufficient
++ $self->{LD_RUN_PATH} = join ':', grep !/^\Q$ENV{PORTAGE_TMPDIR}/,
++ split /:/, $self->{LD_RUN_PATH};
++ }
+ last;
+ }
+ }
diff --git a/perl-core/ExtUtils-MakeMaker/metadata.xml b/perl-core/ExtUtils-MakeMaker/metadata.xml
new file mode 100644
index 00000000000..61cc819ccab
--- /dev/null
+++ b/perl-core/ExtUtils-MakeMaker/metadata.xml
@@ -0,0 +1,38 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">ExtUtils-MakeMaker</remote-id>
+ <remote-id type="cpan-module">DynaLoader</remote-id>
+ <remote-id type="cpan-module">ExtUtils::Command::MM</remote-id>
+ <remote-id type="cpan-module">ExtUtils::Liblist</remote-id>
+ <remote-id type="cpan-module">ExtUtils::Liblist::Kid</remote-id>
+ <remote-id type="cpan-module">ExtUtils::MM</remote-id>
+ <remote-id type="cpan-module">ExtUtils::MM_AIX</remote-id>
+ <remote-id type="cpan-module">ExtUtils::MM_Any</remote-id>
+ <remote-id type="cpan-module">ExtUtils::MM_BeOS</remote-id>
+ <remote-id type="cpan-module">ExtUtils::MM_Cygwin</remote-id>
+ <remote-id type="cpan-module">ExtUtils::MM_DOS</remote-id>
+ <remote-id type="cpan-module">ExtUtils::MM_Darwin</remote-id>
+ <remote-id type="cpan-module">ExtUtils::MM_MacOS</remote-id>
+ <remote-id type="cpan-module">ExtUtils::MM_NW5</remote-id>
+ <remote-id type="cpan-module">ExtUtils::MM_OS2</remote-id>
+ <remote-id type="cpan-module">ExtUtils::MM_QNX</remote-id>
+ <remote-id type="cpan-module">ExtUtils::MM_UWIN</remote-id>
+ <remote-id type="cpan-module">ExtUtils::MM_Unix</remote-id>
+ <remote-id type="cpan-module">ExtUtils::MM_VMS</remote-id>
+ <remote-id type="cpan-module">ExtUtils::MM_VOS</remote-id>
+ <remote-id type="cpan-module">ExtUtils::MM_Win32</remote-id>
+ <remote-id type="cpan-module">ExtUtils::MM_Win95</remote-id>
+ <remote-id type="cpan-module">ExtUtils::MY</remote-id>
+ <remote-id type="cpan-module">ExtUtils::MakeMaker</remote-id>
+ <remote-id type="cpan-module">ExtUtils::MakeMaker::Config</remote-id>
+ <remote-id type="cpan-module">ExtUtils::MakeMaker::_version</remote-id>
+ <remote-id type="cpan-module">ExtUtils::Mkbootstrap</remote-id>
+ <remote-id type="cpan-module">ExtUtils::Mksymlists</remote-id>
+ <remote-id type="cpan-module">ExtUtils::testlib</remote-id>
+ <remote-id type="cpan-module">MM</remote-id>
+ <remote-id type="cpan-module">MY</remote-id>
+ </upstream>
+</pkgmetadata>