summaryrefslogtreecommitdiff
path: root/perl-core/ExtUtils-MakeMaker
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-03-19 02:31:43 +1300
committerKent Fredric <kentnl@gentoo.org>2017-03-19 13:39:04 +1300
commitd74acdddf5bcfb560ebac072d948952ca9cf8a3d (patch)
tree3eeaf3e0d176a48cb7a50caed570ea1f0fc99e7f /perl-core/ExtUtils-MakeMaker
parent9bbdf01e066b7d5cdacf5e3c6c747663b1bb84d2 (diff)
downloadgentoo-d74acdddf5bcfb560ebac072d948952ca9cf8a3d.tar.gz
gentoo-d74acdddf5bcfb560ebac072d948952ca9cf8a3d.tar.xz
perl-core/ExtUtils-MakeMaker,virtual/perl-ExtUtils-MakeMaker: Bump to version 7.240.0 (masked)
Adding to tree for roll out and testing purposes, but should stay masked until its deemed critical, in order to avoid side effects with users installing perl-core/ and having it block world updates. Ideally the virtual can be unmasked when 5.26 rolls out in the next few months. Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'perl-core/ExtUtils-MakeMaker')
-rw-r--r--perl-core/ExtUtils-MakeMaker/ExtUtils-MakeMaker-7.240.0.ebuild44
-rw-r--r--perl-core/ExtUtils-MakeMaker/Manifest1
-rw-r--r--perl-core/ExtUtils-MakeMaker/files/7.24-RUNPATH.patch30
-rw-r--r--perl-core/ExtUtils-MakeMaker/files/7.24-delete_podlocal.patch74
4 files changed, 149 insertions, 0 deletions
diff --git a/perl-core/ExtUtils-MakeMaker/ExtUtils-MakeMaker-7.240.0.ebuild b/perl-core/ExtUtils-MakeMaker/ExtUtils-MakeMaker-7.240.0.ebuild
new file mode 100644
index 00000000000..19eafc253dd
--- /dev/null
+++ b/perl-core/ExtUtils-MakeMaker/ExtUtils-MakeMaker-7.240.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+DIST_AUTHOR=BINGOS
+DIST_VERSION=7.24
+inherit eutils perl-module
+
+DESCRIPTION="Create a module Makefile"
+HOMEPAGE="http://makemaker.org ${HOMEPAGE}"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-ExtUtils-Command-1.160.0
+ >=virtual/perl-ExtUtils-Install-1.520.0
+ >=virtual/perl-ExtUtils-Manifest-1.700.0
+ >=virtual/perl-File-Spec-0.800.0
+"
+DEPEND="${RDEPEND}
+ test? (
+ >=virtual/perl-File-Temp-0.220.0
+ >=virtual/perl-Scalar-List-Utils-1.130.0
+ )
+"
+PDEPEND="
+ >=virtual/perl-CPAN-Meta-2.143.240
+ >=virtual/perl-Parse-CPAN-Meta-1.441.400
+ virtual/perl-Test-Harness
+"
+
+PATCHES=(
+ "${FILESDIR}/7.24-delete_podlocal.patch"
+ "${FILESDIR}/7.24-RUNPATH.patch"
+)
+
+src_prepare() {
+ edos2unix "${S}/lib/ExtUtils/MM_Unix.pm"
+ edos2unix "${S}/lib/ExtUtils/MM_Any.pm"
+
+ export BUILDING_AS_PACKAGE=1
+ perl-module_src_prepare
+}
diff --git a/perl-core/ExtUtils-MakeMaker/Manifest b/perl-core/ExtUtils-MakeMaker/Manifest
index da79a1263c3..a198b608198 100644
--- a/perl-core/ExtUtils-MakeMaker/Manifest
+++ b/perl-core/ExtUtils-MakeMaker/Manifest
@@ -1 +1,2 @@
DIST ExtUtils-MakeMaker-7.04.tar.gz 439960 SHA256 98126b012d70c2af0f8e33a07ebe0d6f2340281b2460981b959a9fb31d5ad97f SHA512 10b905dfdda2c6b4d59e6dac5a5da64db4674df51fc4d87af36fa8735fac93baa43fc9e083a37b09a3b66fe546d053224b2f1bfb5981ad1fa0f4fa6e61f2563c WHIRLPOOL ff6078394c488633adf3d1214c9379921a0c015215bab2ba2fb9305eb203f9fef95ce0aa95a5f9d274b348d74e7ea26a02ff5101a931e26df7700ce98133c2e9
+DIST ExtUtils-MakeMaker-7.24.tar.gz 467714 SHA256 416abc97c3bb2cc72bef28852522f2859de53e37bf3d0ae8b292067d78755e69 SHA512 f57f8407aea6101af964f105fb9ddd6567262fa2bad91456573c8fc019cdf1469563945029f5078e20d2f7d1d736a63586e7cde3bb72cb9ae80ad0b8ebe818d5 WHIRLPOOL 1f5856ddf97a9529736513fed672d25456270e6c1305fda709348a0f5ee63ef7ab99ddf50ad93ba0900ffcfd65d16bbf510a36f9c2b7e834efd490d02f1aa0e8
diff --git a/perl-core/ExtUtils-MakeMaker/files/7.24-RUNPATH.patch b/perl-core/ExtUtils-MakeMaker/files/7.24-RUNPATH.patch
new file mode 100644
index 00000000000..6f21f2c733b
--- /dev/null
+++ b/perl-core/ExtUtils-MakeMaker/files/7.24-RUNPATH.patch
@@ -0,0 +1,30 @@
+From 5da957658fba21be51b638bcfee32b97090ad0da Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Sun, 19 Mar 2017 01:55:56 +1300
+Subject: Prevent build root appearing in RPATH
+
+---
+ lib/ExtUtils/MM_Any.pm | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+diff --git a/lib/ExtUtils/MM_Any.pm b/lib/ExtUtils/MM_Any.pm
+index 433a8dd..ebcb6fc 100644
+--- a/lib/ExtUtils/MM_Any.pm
++++ b/lib/ExtUtils/MM_Any.pm
+@@ -2422,6 +2422,13 @@ sub init_others {
+ # LD_RUN_PATH now computed by ExtUtils::Liblist
+ ($self->{EXTRALIBS}, $self->{BSLOADLIBS},
+ $self->{LDLOADLIBS}, $self->{LD_RUN_PATH}) = @libs;
++ # We do not want the build root in RPATH
++ if ( exists $ENV{PORTAGE_TMPDIR} ){
++ # If we have a PORTAGE_TMPDIR set, strip that, as just testing for
++ # /usr and /opt might not be sufficient.
++ $self->{LD_RUN_PATH} = join ':', grep !/^\Q$ENV{PORTAGE_TMPDIR}/,
++ split /:/, $self->{LD_RUN_PATH};
++ }
+ last;
+ }
+ }
+--
+2.12.0
+
diff --git a/perl-core/ExtUtils-MakeMaker/files/7.24-delete_podlocal.patch b/perl-core/ExtUtils-MakeMaker/files/7.24-delete_podlocal.patch
new file mode 100644
index 00000000000..8277e0d37c2
--- /dev/null
+++ b/perl-core/ExtUtils-MakeMaker/files/7.24-delete_podlocal.patch
@@ -0,0 +1,74 @@
+From f1939e044183c711f23468eb1aa068435add42c6 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Sun, 19 Mar 2017 01:52:52 +1300
+Subject: Inhibit generation of perllocal.pod
+
+---
+ lib/ExtUtils/MM_Unix.pm | 5 +++++
+ t/INSTALL_BASE.t | 2 +-
+ t/basic.t | 6 +++---
+ 3 files changed, 9 insertions(+), 4 deletions(-)
+
+diff --git a/lib/ExtUtils/MM_Unix.pm b/lib/ExtUtils/MM_Unix.pm
+index 66a24d7..82d7b42 100644
+--- a/lib/ExtUtils/MM_Unix.pm
++++ b/lib/ExtUtils/MM_Unix.pm
+@@ -1682,6 +1682,11 @@ sub init_main {
+ ### $self->{NAME}) =~ s!::!/!g ; #eg. BSD/Foo/Socket
+ $self->{FULLEXT} = $self->catdir(split /::/, $self->{NAME});
+
++ # Workaround for https://bugs.gentoo.org/show_bug.cgi?id=221179
++ if (!exists($self->{NO_PERLLOCAL})) {
++ $self->{NO_PERLLOCAL} = 1;
++ }
++
+
+ # Copied from DynaLoader:
+
+diff --git a/t/INSTALL_BASE.t b/t/INSTALL_BASE.t
+index 6939811..f7cf8d4 100644
+--- a/t/INSTALL_BASE.t
++++ b/t/INSTALL_BASE.t
+@@ -49,7 +49,7 @@ ok( chdir(File::Spec->catdir($SPACEDIR, 'Big-Dummy')), "chdir'd to Big-Dummy") |
+ for my $instdir (@INSTDIRS) {
+ $instdir = File::Spec->rel2abs($instdir);
+ $instdir = VMS::Filespec::unixpath($instdir) if $Is_VMS;
+- my @mpl_out = run(qq{$perl Makefile.PL "INSTALL_BASE=$instdir"});
++ my @mpl_out = run(qq{$perl Makefile.PL "INSTALL_BASE=$instdir" NO_PERLLOCAL=0 NO_PACKLIST=0});
+
+ cmp_ok( $?, '==', 0, 'Makefile.PL exited with zero' ) ||
+ diag(@mpl_out);
+diff --git a/t/basic.t b/t/basic.t
+index c98e28c..97db20a 100644
+--- a/t/basic.t
++++ b/t/basic.t
+@@ -24,7 +24,7 @@ use ExtUtils::MM;
+ use Test::More
+ !MM->can_run(make()) && $ENV{PERL_CORE} && $Config{'usecrosscompile'}
+ ? (skip_all => "cross-compiling and make not available")
+- : (tests => 186);
++ : (tests => 180);
+ use File::Find;
+ use File::Spec;
+ use File::Path;
+@@ -79,7 +79,7 @@ sub extrachar {
+ 'ลก';
+ }
+ my $DUMMYINST = '../dummy-in'.extrachar().'tall';
+-my @mpl_out = run(qq{$perl Makefile.PL "PREFIX=$DUMMYINST"});
++my @mpl_out = run(qq{$perl Makefile.PL "PREFIX=$DUMMYINST" NO_PERLLOCAL=0 NO_PACKLIST=0});
+
+ cmp_ok( $?, '==', 0, 'Makefile.PL exited with zero' ) ||
+ diag(@mpl_out);
+@@ -196,7 +196,7 @@ sub check_dummy_inst {
+ ok( $files{'liar.pm'}, ' Liar.pm installed' ) unless $skipsubdir;
+ ok( $files{'program'}, ' program installed' );
+ ok( $files{'.packlist'}, ' packlist created' );
+- ok( $files{'perllocal.pod'},' perllocal.pod created' );
++# ok( $files{'perllocal.pod'},' perllocal.pod created' );
+ \%files;
+ }
+
+--
+2.12.0
+