summaryrefslogtreecommitdiff
path: root/perl-core/Math-BigInt
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-11-27 14:49:46 +1300
committerKent Fredric <kentnl@gentoo.org>2016-11-27 14:54:55 +1300
commit2a1b411345ce81e94771ce2653bea591c703ed91 (patch)
tree93c9a612ba4b4dc48b58ea0f56225c42f257ba81 /perl-core/Math-BigInt
parent1bf1ceeb04a2f57e1e5e1636a8c288c4d0db6682 (diff)
downloadgentoo-2a1b411345ce81e94771ce2653bea591c703ed91.tar.gz
gentoo-2a1b411345ce81e94771ce2653bea591c703ed91.tar.xz
perl-core/Math-BigInt: Bump to version 1.999.801 (masked)
Upstream: - All mathematical methods except ->blog() no longer accept `undef` as operands. - Add _lcm function to Math::BigInt::Lib - Remove internal __lcm() - BigInt and BigFloat can now use bgcd() and blcm() as class-methods. - Prefer getting config values via `->config('name')` instead of `->config()->{name}` - Lock tests to their target libraries Package-Manager: portage-2.3.2
Diffstat (limited to 'perl-core/Math-BigInt')
-rw-r--r--perl-core/Math-BigInt/Manifest1
-rw-r--r--perl-core/Math-BigInt/Math-BigInt-1.999.801.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/perl-core/Math-BigInt/Manifest b/perl-core/Math-BigInt/Manifest
index d74c7bdebf8..dfede0f41ff 100644
--- a/perl-core/Math-BigInt/Manifest
+++ b/perl-core/Math-BigInt/Manifest
@@ -2,3 +2,4 @@ DIST Math-BigInt-1.9993.tar.gz 215143 SHA256 d937c0d1afbb3ddd9b666177faf56471b6c
DIST Math-BigInt-1.999710.tar.gz 225641 SHA256 879514c3dda33b6f05816569ca1a0f31b650df87660ecf80afbd60e396118610 SHA512 a5f938f5f2c61fd1b4c5c01caa99104aea2a009c8f6e089b465d52948a631cd7cb2df2c54917d9e4bd0bc34281c3a8aa865eb3bf7e6e84f15cff1eb79ccf358d WHIRLPOOL 73e26895de11824008b41e39968903c9a7b888a5b199e64f235e2b86e2360df8b095e6a9f2e29c3c29a385025e33cbbd88dc3f84220c6fd89add49596a1814ee
DIST Math-BigInt-1.999715.tar.gz 252193 SHA256 cfae5c43c4cabe92a940f13e4a23515be4e0dbe72cba8d448a3e96f869794987 SHA512 85d5e168e41f53a37cfcdbef3a2b9a998be7344e828675cda5e3d9db320d4d617555aa9611ecabd6a13974d3a3eee8ec624e9f839bc6ac7a3abecc6a67305bc7 WHIRLPOOL a0a293278391031948e0e5914f239bc6fb92297eefa4fcec92c540ebdfb796f5f60fe22c0f3dde76f9779a9a3b05c74d3da153d7b83a273b05053f308ac49fd5
DIST Math-BigInt-1.999800.tar.gz 2727031 SHA256 216096d1f937252bfc449b1de01b760ffaab46e753e150cc2a685f4935bd030d SHA512 fa86e85b8cf9cef0fcd69bb692e75e690480b6a8778759f524614e70d42d515422079e36f28dc3a3cdbb654591b9a8eb93160a42f93df87cd837b94b191a97ef WHIRLPOOL 1d0b6ddfab3c3b41bef7b7707bae1d83d0dd8ba7640933394d8ec564e1afdeafa103b3822e2e2a8c3a6341d17d891e6bbe467cb08664f2fe03544d39574bb8fb
+DIST Math-BigInt-1.999801.tar.gz 2761631 SHA256 41deb23d453f5a376759fff155e4947988a6b6713a4164f21aedac8238089e57 SHA512 fd0dd80a8b495ecbfc61ca089793d66b9e9c9edde6dccbd25a18725bd8ee097a0c8e58f66d340e4a9e9ccce84f9d1f70f755eb65c2f4ecc8ba7cba83692a0cc1 WHIRLPOOL e860edb664a0b2fbdd7040694213d6b3606d488a26c7913cee0efa9945937849cbd47d73244fd0c35a4579fed6da721943408e893e4ea67dd20a4d352320af2e
diff --git a/perl-core/Math-BigInt/Math-BigInt-1.999.801.ebuild b/perl-core/Math-BigInt/Math-BigInt-1.999.801.ebuild
new file mode 100644
index 00000000000..77e4931fe30
--- /dev/null
+++ b/perl-core/Math-BigInt/Math-BigInt-1.999.801.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=PJACKLAM
+DIST_VERSION=1.999801
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="Arbitrary size floating point math package"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~ppc-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Math-Complex-1.390.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.590.0
+ test? ( >=virtual/perl-Test-Simple-0.940.0 )
+"
+
+PDEPEND="
+ >=virtual/perl-Math-BigInt-FastCalc-0.270.0
+ >=virtual/perl-bignum-0.220.0
+ >=virtual/perl-Math-BigRat-0.260.200
+"
+# where does this come from?
+
+src_test() {
+ perl_rm_files t/author-*.t t/03podcov.t t/00sig.t t/02pod.t
+ perl-module_src_test
+}