summaryrefslogtreecommitdiff
path: root/ros-meta/vision_visp
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-24 10:42:56 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-24 10:43:09 +0200
commit39242f787cace0156ea912c144af8cb3f8c88d61 (patch)
tree36f3434080b286646acec28435783e15b05d803f /ros-meta/vision_visp
parent23819b04b47f6294a165acb7e3ae782094344631 (diff)
downloadgentoo-39242f787cace0156ea912c144af8cb3f8c88d61.tar.gz
gentoo-39242f787cace0156ea912c144af8cb3f8c88d61.tar.xz
ros-meta/vision_visp: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'ros-meta/vision_visp')
-rw-r--r--ros-meta/vision_visp/Manifest1
-rw-r--r--ros-meta/vision_visp/metadata.xml5
-rw-r--r--ros-meta/vision_visp/vision_visp-0.8.0.ebuild28
-rw-r--r--ros-meta/vision_visp/vision_visp-9999.ebuild28
4 files changed, 62 insertions, 0 deletions
diff --git a/ros-meta/vision_visp/Manifest b/ros-meta/vision_visp/Manifest
new file mode 100644
index 00000000000..b77350371ba
--- /dev/null
+++ b/ros-meta/vision_visp/Manifest
@@ -0,0 +1 @@
+DIST vision_visp-0.8.0.tar.gz 1010996 SHA256 5166e1f17601328d09716879ceb66135e07bdb71a375765a937e3b78a12b0e54 SHA512 2bf2d69b6e19de21b34869858672662162703ff8b2aea85fdb9a6dafa88d8fe1f97d18587e863f3f7c088697e931a1b6e4e2e37f31fc7caff0906e98debbad1a WHIRLPOOL 015778e4cff63a9dbb5bf5812e38f7564b68cb71886e472062be15ec31a87a7299bff7ef9df50124294e22906420f60075cf6cc69f77df1cd29267b401f655e5
diff --git a/ros-meta/vision_visp/metadata.xml b/ros-meta/vision_visp/metadata.xml
new file mode 100644
index 00000000000..c42ea5b15cf
--- /dev/null
+++ b/ros-meta/vision_visp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/ros-meta/vision_visp/vision_visp-0.8.0.ebuild b/ros-meta/vision_visp/vision_visp-0.8.0.ebuild
new file mode 100644
index 00000000000..ed46d3fd369
--- /dev/null
+++ b/ros-meta/vision_visp/vision_visp-0.8.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/lagadic/vision_visp"
+KEYWORDS="~amd64 ~arm"
+VER_PREFIX="jade-"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Virtual package providing ViSP related packages"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/visp_auto_tracker
+ dev-ros/visp_bridge
+ dev-ros/visp_camera_calibration
+ dev-ros/visp_hand2eye_calibration
+ dev-ros/visp_tracker
+"
+DEPEND=""
+if [ "${PV#9999}" = "${PV}" ] ; then
+ S="${WORKDIR}/vision_visp-jade-${PV}/${ROS_SUBDIR}"
+fi
diff --git a/ros-meta/vision_visp/vision_visp-9999.ebuild b/ros-meta/vision_visp/vision_visp-9999.ebuild
new file mode 100644
index 00000000000..ed46d3fd369
--- /dev/null
+++ b/ros-meta/vision_visp/vision_visp-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/lagadic/vision_visp"
+KEYWORDS="~amd64 ~arm"
+VER_PREFIX="jade-"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Virtual package providing ViSP related packages"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/visp_auto_tracker
+ dev-ros/visp_bridge
+ dev-ros/visp_camera_calibration
+ dev-ros/visp_hand2eye_calibration
+ dev-ros/visp_tracker
+"
+DEPEND=""
+if [ "${PV#9999}" = "${PV}" ] ; then
+ S="${WORKDIR}/vision_visp-jade-${PV}/${ROS_SUBDIR}"
+fi