summaryrefslogtreecommitdiff
path: root/sci-astronomy/stellarium
diff options
context:
space:
mode:
authorGerhard Bräunlich <wippbox@gmx.net>2017-01-13 18:24:58 +0100
committerDavid Seifert <soap@gentoo.org>2017-01-15 11:11:48 +0100
commit9395b364a5a40f9b48de080561152de89659307b (patch)
tree236a35662175667240ba9c031277383a7102f8ae /sci-astronomy/stellarium
parent19ef4252dcd197dc976982b0ca2ea44344036a4e (diff)
downloadgentoo-9395b364a5a40f9b48de080561152de89659307b.tar.gz
gentoo-9395b364a5a40f9b48de080561152de89659307b.tar.xz
sci-astronomy/stellarium: Version bump to 0.15.1
Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/3453
Diffstat (limited to 'sci-astronomy/stellarium')
-rw-r--r--sci-astronomy/stellarium/Manifest1
-rw-r--r--sci-astronomy/stellarium/stellarium-0.15.1.ebuild107
2 files changed, 108 insertions, 0 deletions
diff --git a/sci-astronomy/stellarium/Manifest b/sci-astronomy/stellarium/Manifest
index cbf5e138569..4a3add15f65 100644
--- a/sci-astronomy/stellarium/Manifest
+++ b/sci-astronomy/stellarium/Manifest
@@ -12,3 +12,4 @@ DIST stellarium-0.12.4.tar.gz 79343617 SHA256 0fae1b6e2231ccfaba8fd00abf816a88bd
DIST stellarium-0.14.2.tar.gz 139069181 SHA256 aa04a5ae44ed177bc187d20e27a87cc11fc2f465036d673f02ec07b333a0b1f7 SHA512 401dc8f88779119f0fef9d2e24cb5440c16a1f1d4a79ff80c51cfef848f6b1d881f5144acd599f8b709d099b120420c18bba9f50f3518c44bf815021f7efc2ed WHIRLPOOL 8cb4dc54f91bffda6e4bab76efa855bc43e2440d9e6408a1028bc118d27971c17d9ec2106748ec7df5f6b47da4db6938b359490659092bb5169e15f5eed14d21
DIST stellarium-0.14.3.tar.gz 137661611 SHA256 de41c5b14fdf0c5f6e73bab2975f380554487b1817f2c5a2ebad3bb8e9e729a4 SHA512 83d9a1c53f118c143e81d31e7f87dbf73368bfa981311c8bc41a51307fe6108c9169b43ad1fdde1cec84b9b1e8a4ef51d4de3b91d7aa676be38302b2223a6675 WHIRLPOOL 441302d93778185c9743451bd04148bd4a8a599eaff4f5a7b90025df9eb9873e1a203f0a82f687b7d2fb53fcf811e16903000d7179c6508738935518a2bbe966
DIST stellarium-0.15.0.tar.gz 147160785 SHA256 74d0e3a69fcbaf1c6278f601a44497fd3e9f2de7dfa11a60197d3afb68288746 SHA512 3e91cb565343814c96f30a75767ecd56d93ec463cb1e925d169b30a8e0fddd285217193c8a24053aa1ce22e6e842a97c7a4b59c3ee7d65ec33308fa045e905c7 WHIRLPOOL 8a5ad7c8e4755b90976ad8f659668f5cbe49ea4023c0cabf7ae75afe3b4ebbfdd677556d92bf5999b7375e15fa91530787658a338b01dd7dafe4dfb962434e12
+DIST stellarium-0.15.1.tar.gz 155860125 SHA256 0fe52fc496c11d92728742ae6d71bac116746dca7885d34d17b1a288fe8b5b11 SHA512 42b23546e4e2dde8c0fbc5cac8e11204fe63727544356979978c9a820aa28aac48c4a285b40e49a867bf469be89a424d2f6134b97cf0717be6818ce89f20d36f WHIRLPOOL cb0807a5a0a3658aaba1f894383de9e3bd84447b25c513e14c6f5fa16978132e0ca603641759f0e104ea767322c3c08b3e3e07e6fc6e89a0deea5d182cedbdae
diff --git a/sci-astronomy/stellarium/stellarium-0.15.1.ebuild b/sci-astronomy/stellarium/stellarium-0.15.1.ebuild
new file mode 100644
index 00000000000..e50465e726f
--- /dev/null
+++ b/sci-astronomy/stellarium/stellarium-0.15.1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit cmake-utils eutils flag-o-matic gnome2-utils
+
+DESCRIPTION="3D photo-realistic skies in real time"
+HOMEPAGE="http://www.stellarium.org/"
+SRC_URI="
+ mirror://sourceforge/stellarium/${P}.tar.gz
+ stars? (
+ mirror://sourceforge/stellarium/stars_4_1v0_1.cat
+ mirror://sourceforge/stellarium/stars_5_2v0_1.cat
+ mirror://sourceforge/stellarium/stars_6_2v0_1.cat
+ mirror://sourceforge/stellarium/stars_7_2v0_1.cat
+ mirror://sourceforge/stellarium/stars_8_2v0_1.cat
+ )"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug media nls stars"
+
+RESTRICT="test" # There are no tests
+
+RDEPEND="
+ media-fonts/dejavu
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtscript:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ virtual/opengl
+ sys-libs/zlib
+ media? ( dev-qt/qtmultimedia:5[widgets] )"
+DEPEND="${RDEPEND}
+ dev-qt/qttest:5
+ dev-qt/qtconcurrent:5
+ nls? ( dev-qt/linguist-tools:5 )"
+
+LANGS=(
+ af am ar as ast az be bg bn bo br bs ca cs
+ cy da de el en en-GB en-US eo es et eu fa fi fil fr
+ ga gd gl gu he hi hr hu hy ia id is it ja ka kk kn ko ky
+ la lb lo lt lv mk ml mn mr ms nb nl nn oc pa pl pt pt-BR ro
+ ru se si sk sl sq sr sv sw ta te tg th tl tr tt uk uz vi
+ zh-CN zh-HK zh-TW zu
+ )
+
+for X in "${LANGS[@]}" ; do
+ IUSE+=" l10n_${X}"
+done
+unset X
+
+src_prepare() {
+ cmake-utils_src_prepare
+ if [[ -n ${L10N} ]] ; then
+ sed -i\
+ -e 's/STRING(REGEX REPLACE ".po" "" \([a-z]*\).*$/SET(\1 '"${L10N//-/_})/" \
+ po/stellarium{,-skycultures,-remotecontrol}/CMakeLists.txt || die #403647
+ fi
+ # Turn off TelescopeControl since dev-qt/qtserialport isn't
+ # marked stable and is missing keywords besides.
+ sed -i \
+ -e '/SimpleDrawLine/ s:0:1:g' \
+ -e '/TelescopeControl/s:1:0:g' \
+ CMakeLists.txt || die
+ use debug || append-cppflags -DQT_NO_DEBUG #415769
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_NLS="$(usex nls)"
+ -DENABLE_MEDIA="$(usex media)"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ # use the more up-to-date system fonts
+ rm "${ED%/}"/usr/share/stellarium/data/DejaVuSans{Mono,}.ttf || die
+ dosym ../../fonts/dejavu/DejaVuSans.ttf /usr/share/stellarium/data/DejaVuSans.ttf
+ dosym ../../fonts/dejavu/DejaVuSansMono.ttf /usr/share/stellarium/data/DejaVuSansMono.ttf
+
+ if use stars ; then
+ insinto /usr/share/${PN}/stars/default
+ doins "${DISTDIR}"/stars_[45678]_[12]v0_1*.cat
+ fi
+ newicon doc/images/stellarium-logo.png ${PN}.png
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}