summaryrefslogtreecommitdiff
path: root/sci-astronomy/wcslib
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-astronomy/wcslib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-astronomy/wcslib')
-rw-r--r--sci-astronomy/wcslib/Manifest3
-rw-r--r--sci-astronomy/wcslib/metadata.xml20
-rw-r--r--sci-astronomy/wcslib/wcslib-4.21.ebuild74
-rw-r--r--sci-astronomy/wcslib/wcslib-4.22.ebuild74
-rw-r--r--sci-astronomy/wcslib/wcslib-4.23.ebuild74
5 files changed, 245 insertions, 0 deletions
diff --git a/sci-astronomy/wcslib/Manifest b/sci-astronomy/wcslib/Manifest
new file mode 100644
index 00000000000..41f86ff1c31
--- /dev/null
+++ b/sci-astronomy/wcslib/Manifest
@@ -0,0 +1,3 @@
+DIST wcslib-4.21.tar.bz2 1865628 SHA256 530eb67e432ce0d881f91e9b08734a346a98cee06233433da79ad0c7d5f144ae SHA512 0fdd7b6cb234565e2dc3b619ec219918103c7a14916294004c12c709be803b10f064fa01c9647a46d2588d4f880ed7db6e65758b510d1a556b3b46f7bc836cdd WHIRLPOOL daaa3ba60cab0aac0619d317ea338f8d734a6d924c49d806a509560e6cd89a896f4594d48e760997d1289d2639c6a81b8802f65a2d95a3cd82efa533476a354a
+DIST wcslib-4.22.tar.bz2 1866676 SHA256 afafdf772cb0fe97ae886cbf512fb114d842ca358cce7df9fa93449d1b556950 SHA512 9288314d842a9b54536b5f512900933e2ac307ef81003172fa511c8334f430161f28084309cde7ad2d94d39020eacec33cf8944d30d78abb51f3e7ff01be2bc4 WHIRLPOOL 629bbca2672d0d9ac03696deadfcea155c912c14ef115defac48966c41714ae692fe5cd60587a733ce691612bea9f48d212587dd0a2327739839328b90eae399
+DIST wcslib-4.23.tar.bz2 1876150 SHA256 baf0fc85fb290e8a575eab4b7046517818a12754a0f01da74db9483467dde5a2 SHA512 cc82818b1aa88d325b72c5a7967b688060c9d0bfd6ba4fef39c0e9dab00bab547282b1c301dafb1331156c69e6266ef80c39f0dc44b894a977d2b2b3cafb9c87 WHIRLPOOL 90ca6e91511371c4e791b7e31b395a6cfda29d1f613176282960896170651b7d5ca7b215254befab1021b18e03e283a88820a248c9c4e6e07edef1bed3adca03
diff --git a/sci-astronomy/wcslib/metadata.xml b/sci-astronomy/wcslib/metadata.xml
new file mode 100644
index 00000000000..8d2a6dc47df
--- /dev/null
+++ b/sci-astronomy/wcslib/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-astronomy</herd>
+<longdescription lang="en">
+ WCSLIB is a C library, supplied with a full set of Fortran wrappers,
+ that implements the "World Coordinate System" (WCS) convention in FITS
+ (Flexible Image Transport System). It also includes a PGPLOT-based routine,
+ PGSBOX, for drawing general curvilinear coordinate graticules and a number of
+ utility programs.
+</longdescription>
+<use>
+ <flag name="fits">
+ Enable support for the FITS format through <pkg>sci-libs/cfitsio</pkg>
+ </flag>
+ <flag name="pgplot">
+ Builds PGBSOX routines, needs <pkg>sci-libs/pgplot</pkg> library
+ </flag>
+</use>
+</pkgmetadata>
diff --git a/sci-astronomy/wcslib/wcslib-4.21.ebuild b/sci-astronomy/wcslib/wcslib-4.21.ebuild
new file mode 100644
index 00000000000..f8d333a25e1
--- /dev/null
+++ b/sci-astronomy/wcslib/wcslib-4.21.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+FORTRAN_NEEDED=fortran
+
+inherit eutils fortran-2 multilib
+
+DESCRIPTION="Astronomical World Coordinate System transformations library"
+HOMEPAGE="http://www.atnf.csiro.au/people/mcalabre/WCS/"
+SRC_URI="ftp://ftp.atnf.csiro.au/pub/software/${PN}/${P}.tar.bz2"
+
+SLOT="0/4"
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc fortran fits pgplot static-libs"
+
+RDEPEND="
+ fits? ( sci-libs/cfitsio:0= )
+ pgplot? ( sci-libs/pgplot:0= )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i -e 's/COPYING\*//' GNUmakefile || die
+}
+
+src_configure() {
+ local myconf=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable static-libs static)
+ $(use_enable fortran)
+ )
+ # hacks because cfitsio and pgplot directories are hard-coded
+ if use fits; then
+ myconf+=(
+ --with-cfitsioinc="${EPREFIX}/usr/include"
+ --with-cfitsiolib="${EPREFIX}/usr/$(get_libdir)"
+ )
+ else
+ myconf+=( --without-cfitsio )
+ fi
+ if use pgplot; then
+ myconf+=(
+ --with-pgplotinc="${EPREFIX}/usr/include"
+ --with-pgplotlib="${EPREFIX}/usr/$(get_libdir)"
+ )
+ else
+ myconf+=( --without-pgplot )
+ fi
+ econf ${myconf[@]}
+}
+
+src_compile() {
+ # nasty makefile, debugging means full rewrite
+ emake -j1
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install () {
+ default
+ # static libs are same as shared (compiled with PIC)
+ # so they are not compiled twice
+ use static-libs || rm "${ED}"/usr/$(get_libdir)/lib*.a
+ use doc || rm -r \
+ "${ED}"/usr/share/doc/${PF}/html \
+ "${ED}"/usr/share/doc/${PF}/*.pdf
+}
diff --git a/sci-astronomy/wcslib/wcslib-4.22.ebuild b/sci-astronomy/wcslib/wcslib-4.22.ebuild
new file mode 100644
index 00000000000..3b29c1c5ba8
--- /dev/null
+++ b/sci-astronomy/wcslib/wcslib-4.22.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+FORTRAN_NEEDED=fortran
+
+inherit eutils fortran-2 multilib
+
+DESCRIPTION="Astronomical World Coordinate System transformations library"
+HOMEPAGE="http://www.atnf.csiro.au/people/mcalabre/WCS/"
+SRC_URI="ftp://ftp.atnf.csiro.au/pub/software/${PN}/${P}.tar.bz2"
+
+SLOT="0/4"
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc fortran fits pgplot static-libs"
+
+RDEPEND="
+ fits? ( sci-libs/cfitsio:0= )
+ pgplot? ( sci-libs/pgplot:0= )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i -e 's/COPYING\*//' GNUmakefile || die
+}
+
+src_configure() {
+ local myconf=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable static-libs static)
+ $(use_enable fortran)
+ )
+ # hacks because cfitsio and pgplot directories are hard-coded
+ if use fits; then
+ myconf+=(
+ --with-cfitsioinc="${EPREFIX}/usr/include"
+ --with-cfitsiolib="${EPREFIX}/usr/$(get_libdir)"
+ )
+ else
+ myconf+=( --without-cfitsio )
+ fi
+ if use pgplot; then
+ myconf+=(
+ --with-pgplotinc="${EPREFIX}/usr/include"
+ --with-pgplotlib="${EPREFIX}/usr/$(get_libdir)"
+ )
+ else
+ myconf+=( --without-pgplot )
+ fi
+ econf ${myconf[@]}
+}
+
+src_compile() {
+ # nasty makefile, debugging means probably full rewrite
+ emake -j1
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install () {
+ default
+ # static libs are same as shared (compiled with PIC)
+ # so they are not compiled twice
+ use static-libs || rm "${ED}"/usr/$(get_libdir)/lib*.a
+ use doc || rm -r \
+ "${ED}"/usr/share/doc/${PF}/html \
+ "${ED}"/usr/share/doc/${PF}/*.pdf
+}
diff --git a/sci-astronomy/wcslib/wcslib-4.23.ebuild b/sci-astronomy/wcslib/wcslib-4.23.ebuild
new file mode 100644
index 00000000000..3b29c1c5ba8
--- /dev/null
+++ b/sci-astronomy/wcslib/wcslib-4.23.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+FORTRAN_NEEDED=fortran
+
+inherit eutils fortran-2 multilib
+
+DESCRIPTION="Astronomical World Coordinate System transformations library"
+HOMEPAGE="http://www.atnf.csiro.au/people/mcalabre/WCS/"
+SRC_URI="ftp://ftp.atnf.csiro.au/pub/software/${PN}/${P}.tar.bz2"
+
+SLOT="0/4"
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc fortran fits pgplot static-libs"
+
+RDEPEND="
+ fits? ( sci-libs/cfitsio:0= )
+ pgplot? ( sci-libs/pgplot:0= )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i -e 's/COPYING\*//' GNUmakefile || die
+}
+
+src_configure() {
+ local myconf=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable static-libs static)
+ $(use_enable fortran)
+ )
+ # hacks because cfitsio and pgplot directories are hard-coded
+ if use fits; then
+ myconf+=(
+ --with-cfitsioinc="${EPREFIX}/usr/include"
+ --with-cfitsiolib="${EPREFIX}/usr/$(get_libdir)"
+ )
+ else
+ myconf+=( --without-cfitsio )
+ fi
+ if use pgplot; then
+ myconf+=(
+ --with-pgplotinc="${EPREFIX}/usr/include"
+ --with-pgplotlib="${EPREFIX}/usr/$(get_libdir)"
+ )
+ else
+ myconf+=( --without-pgplot )
+ fi
+ econf ${myconf[@]}
+}
+
+src_compile() {
+ # nasty makefile, debugging means probably full rewrite
+ emake -j1
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install () {
+ default
+ # static libs are same as shared (compiled with PIC)
+ # so they are not compiled twice
+ use static-libs || rm "${ED}"/usr/$(get_libdir)/lib*.a
+ use doc || rm -r \
+ "${ED}"/usr/share/doc/${PF}/html \
+ "${ED}"/usr/share/doc/${PF}/*.pdf
+}