summaryrefslogtreecommitdiff
path: root/sci-biology/GBrowse
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/GBrowse
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/GBrowse')
-rw-r--r--sci-biology/GBrowse/GBrowse-2.48-r1.ebuild72
-rw-r--r--sci-biology/GBrowse/Manifest1
-rw-r--r--sci-biology/GBrowse/files/GBrowseInstall.pm-2.39.patch72
-rw-r--r--sci-biology/GBrowse/metadata.xml8
4 files changed, 153 insertions, 0 deletions
diff --git a/sci-biology/GBrowse/GBrowse-2.48-r1.ebuild b/sci-biology/GBrowse/GBrowse-2.48-r1.ebuild
new file mode 100644
index 00000000000..a3c0228b819
--- /dev/null
+++ b/sci-biology/GBrowse/GBrowse-2.48-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=LDS
+inherit perl-module webapp
+
+DESCRIPTION="Generic Model Organism Database Project - The Generic Genome Browser"
+HOMEPAGE="http://gmod.org/wiki/GBrowse"
+KEYWORDS="~amd64 ~x86"
+IUSE="-minimal mysql postgres +sqlite"
+
+SLOT="0"
+WEBAPP_MANUAL_SLOT="yes"
+
+CDEPEND="!<sci-biology/GBrowse-2.44-r1
+ >=sci-biology/bioperl-1.6.9
+ >=dev-perl/Bio-Graphics-2.09
+ >=dev-perl/GD-2.07
+ >=dev-perl/CGI-Session-4.02
+ dev-perl/IO-String
+ dev-perl/JSON
+ dev-perl/libwww-perl
+ dev-perl/Statistics-Descriptive
+ !minimal? (
+ dev-perl/Bio-Das
+ >=dev-perl/Bio-SamTools-1.20
+ dev-perl/Crypt-SSLeay
+ dev-perl/DB_File-Lock
+ dev-perl/DBI
+ mysql? ( dev-perl/DBD-mysql )
+ postgres? ( dev-perl/DBD-Pg )
+ sqlite? ( dev-perl/DBD-SQLite )
+ dev-perl/FCGI
+ dev-perl/File-NFSLock
+ dev-perl/GD-SVG
+ dev-perl/Net-OpenID-Consumer
+ dev-perl/Net-SMTP-SSL
+ )"
+# >=dev-perl/Bio-DB-BigFile-1.00 - requires jklib to compile
+DEPEND="dev-perl/Module-Build
+ dev-perl/Capture-Tiny
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}"
+
+PATCHES=( "${FILESDIR}"/GBrowseInstall.pm-2.39.patch )
+
+src_configure() {
+ webapp_src_preinst
+
+# myconf="--install_base=${D}/usr" or "--install_base=/opt/gbrowse"
+ myconf="--conf=/etc/gbrowse2"
+ myconf="${myconf} --htdocs=${MY_HTDOCSDIR}"
+ myconf="${myconf} --cgibin=${MY_CGIBINDIR}"
+ myconf="${myconf} --tmp=/var/tmp/gbrowse2"
+ myconf="${myconf} --persistent=/var/db/gbrowse2"
+ myconf="${myconf} --databases=/var/db/gbrowse2/databases"
+ myconf="${myconf} --installconf=no"
+ myconf="${myconf} --installetc=no"
+ perl-module_src_configure
+}
+
+src_install() {
+ dodir /var/tmp/gbrowse2
+ dodir /var/db/gbrowse2/sessions
+ dodir /var/db/gbrowse2/userdata
+ webapp_serverowned -R /var/tmp/gbrowse2 /var/db/gbrowse2
+ perl-module_src_install
+ webapp_src_install
+}
diff --git a/sci-biology/GBrowse/Manifest b/sci-biology/GBrowse/Manifest
new file mode 100644
index 00000000000..204fe59d5aa
--- /dev/null
+++ b/sci-biology/GBrowse/Manifest
@@ -0,0 +1 @@
+DIST GBrowse-2.48.tar.gz 11958127 SHA256 02772c5a7a31ed87733e21278efec2edd3bd6ee8a4bec9b002233e57f6dc9681 SHA512 d5a07caf1517fb15741e8e6056669763eb04678a42637a9e90788c91e74fb34515b5f86aac10a00f29d8848aceb19d6f5f7258d2dda0e281feee550e9e2fb3db WHIRLPOOL 5a3ec31de1582c4c551c76908ca8e8024c8d3311404f0c94f7b75a391c340da0ededd80df34be3f10f581902ba1408d84e3e65218f46322546623e15a1020135
diff --git a/sci-biology/GBrowse/files/GBrowseInstall.pm-2.39.patch b/sci-biology/GBrowse/files/GBrowseInstall.pm-2.39.patch
new file mode 100644
index 00000000000..5aa0be9df91
--- /dev/null
+++ b/sci-biology/GBrowse/files/GBrowseInstall.pm-2.39.patch
@@ -0,0 +1,72 @@
+diff -durr GBrowse-2.39-orig/install_util/GBrowseInstall.pm GBrowse-2.39/install_util/GBrowseInstall.pm
+--- GBrowse-2.39-orig/install_util/GBrowseInstall.pm 2011-07-19 20:14:52.434608020 +0000
++++ GBrowse-2.39/install_util/GBrowseInstall.pm 2011-07-19 21:02:13.685107753 +0000
+@@ -454,33 +454,33 @@
+ $gid =~ /^(\d+)$/;
+ $gid = $1;
+
+- unless (chown $uid,$gid,$tmp) {
+- $self->ownership_warning($tmp,$user);
+- }
++# unless (chown $uid,$gid,$tmp) {
++# $self->ownership_warning($tmp,$user);
++# }
+
+ my $htdocs_i = File::Spec->catfile($self->install_path->{htdocs},'i');
+ my $images = File::Spec->catfile($tmp,'images');
+ my $htdocs = $self->install_path->{htdocs};
+- chown $uid,-1,$htdocs;
++# chown $uid,-1,$htdocs;
+ {
+ local $> = $uid;
+- symlink($images,$htdocs_i); # so symlinkifowner match works!
++# symlink($images,$htdocs_i); # so symlinkifowner match works!
+ }
+- chown $>,-1,$self->install_path->{htdocs};
++# chown $>,-1,$self->install_path->{htdocs};
+
+ my $persistent = $self->install_path->{'persistent'};
+ my $sessions = File::Spec->catfile($persistent,'sessions');
+ my $userdata = File::Spec->catfile($persistent,'userdata');
+- mkpath([$sessions,$userdata],0711);
++# mkpath([$sessions,$userdata],0711);
+
+ my $databases = $self->install_path->{'databases'};
+
+- unless (chown $uid,$gid,glob(File::Spec->catfile($databases,'').'*')) {
+- $self->ownership_warning($databases,$user);
+- }
++# unless (chown $uid,$gid,glob(File::Spec->catfile($databases,'').'*')) {
++# $self->ownership_warning($databases,$user);
++# }
+
+- chmod 0755,File::Spec->catfile($self->install_path->{'etc'},'init.d','gbrowse-slave');
+- $self->fix_selinux;
++ # chmod 0755,File::Spec->catfile($self->install_path->{'etc'},'init.d','gbrowse-slave');
++ # $self->fix_selinux;
+
+ my $base = basename($self->install_path->{htdocs});
+
+@@ -489,14 +489,14 @@
+ my $metadb_script = File::Spec->catfile("bin", "gbrowse_metadb_config.pl");
+ my $perl = $self->perl;
+ my @inc = map{"-I$_"} split ':',$self->added_to_INC;
+- system $perl,@inc,$metadb_script;
+- system 'sudo','chown','-R',"$uid.$gid",$sessions,$userdata;
++# system $perl,@inc,$metadb_script;
++# system 'sudo','chown','-R',"$uid.$gid",$sessions,$userdata;
+
+- if (Module::Build->y_n(
+- "It is recommended that you restart Apache. Shall I try this for you?",'y'
+- )) {
+- system "sudo /etc/init.d/apache2 restart";
+- }
++# if (Module::Build->y_n(
++# "It is recommended that you restart Apache. Shall I try this for you?",'y'
++# )) {
++# system "sudo /etc/init.d/apache2 restart";
++# }
+
+ print STDERR "\n***INSTALLATION COMPLETE***\n";
+ print STDERR "Load http://localhost/$base for demo and documentation.\n";
+Only in GBrowse-2.39/install_util: GBrowseInstall.pm~
diff --git a/sci-biology/GBrowse/metadata.xml b/sci-biology/GBrowse/metadata.xml
new file mode 100644
index 00000000000..32b15c723f9
--- /dev/null
+++ b/sci-biology/GBrowse/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-biology</herd>
+<upstream>
+ <remote-id type="cpan">GBrowse</remote-id>
+</upstream>
+</pkgmetadata>