summaryrefslogtreecommitdiff
path: root/sci-biology/amap
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/amap
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/amap')
-rw-r--r--sci-biology/amap/Manifest1
-rw-r--r--sci-biology/amap/amap-2.2-r2.ebuild50
-rw-r--r--sci-biology/amap/files/amap-2.2-includes.patch44
-rw-r--r--sci-biology/amap/files/amap-2.2-makefile.patch35
-rw-r--r--sci-biology/amap/metadata.xml5
5 files changed, 135 insertions, 0 deletions
diff --git a/sci-biology/amap/Manifest b/sci-biology/amap/Manifest
new file mode 100644
index 00000000000..35e082de93b
--- /dev/null
+++ b/sci-biology/amap/Manifest
@@ -0,0 +1 @@
+DIST amap.2.2.tar.gz 102861 RMD160 6b47b66ab5095e35bcb14a599a25687fef8e799c SHA1 618e498581302e140270a0e029ab87d378c450ef SHA256 81f8c7328c59775a5430d2210f1e4cbed7072bfd8a37f62c8d387db15b7757f4
diff --git a/sci-biology/amap/amap-2.2-r2.ebuild b/sci-biology/amap/amap-2.2-r2.ebuild
new file mode 100644
index 00000000000..389102a8e75
--- /dev/null
+++ b/sci-biology/amap/amap-2.2-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils toolchain-funcs java-pkg-opt-2 java-ant-2
+
+MY_P=${PN}.${PV}
+
+DESCRIPTION="Protein multiple-alignment-based sequence annealing"
+HOMEPAGE="http://bio.math.berkeley.edu/amap/"
+SRC_URI="http://baboon.math.berkeley.edu/${PN}/download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="java"
+
+RDEPEND="java? ( >=virtual/jre-1.5 )"
+DEPEND="java? ( >=virtual/jdk-1.5 )"
+
+S=${WORKDIR}/${PN}-align
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch \
+ "${FILESDIR}"/${P}-includes.patch
+}
+
+src_compile() {
+ emake -C align CXX="$(tc-getCXX)" \
+ OPT_CXXFLAGS="${CXXFLAGS}" || die "make failed"
+
+ if use java; then
+ pushd "${S}"/display
+ eant -Ddisplay all || die
+ popd
+ fi
+}
+
+src_install() {
+ dobin align/${PN} || die
+ dodoc align/{README,PROBCONS.README} || die
+ insinto /usr/share/${PN}/examples
+ doins examples/* || die
+ if use java; then
+ java-pkg_newjar "${S}"/display/AmapDisplay.jar amapdisplay.jar
+ java-pkg_dolauncher amapdisplay --jar amapdisplay.jar
+ fi
+}
diff --git a/sci-biology/amap/files/amap-2.2-includes.patch b/sci-biology/amap/files/amap-2.2-includes.patch
new file mode 100644
index 00000000000..77c4261db5c
--- /dev/null
+++ b/sci-biology/amap/files/amap-2.2-includes.patch
@@ -0,0 +1,44 @@
+Fixes build with gcc 4.3 and 4.6
+
+http://bugs.gentoo.org/217921
+http://bugs.gentoo.org/360517
+
+--- amap-align/align/Amap.cc
++++ amap-align/align/Amap.cc
+@@ -12,6 +12,8 @@
+ #include "ProbabilisticModel.h"
+ #include "EvolutionaryTree.h"
+ #include "SparseMatrix.h"
++#include <limits>
++#include <climits>
+ #include <string>
+ #include <sstream>
+ #include <iomanip>
+@@ -23,6 +25,7 @@
+ #include <cstdlib>
+ #include <cerrno>
+ #include <iomanip>
++#include <cstring>
+
+ string parametersInputFilename = "";
+ string parametersOutputFilename = "no training";
+--- amap-align/align/MultiSequenceDag.h
++++ amap-align/align/MultiSequenceDag.h
+@@ -13,6 +13,7 @@
+ #include <map>
+ #include <queue>
+ #include <iostream>
++#include <limits>
+ #include "MultiSequence.h"
+ #include "SparseMatrix.h"
+
+--- amap-align/align/SafeVector.h.org 2011-03-26 11:50:11.935069583 +0100
++++ amap-align/align/SafeVector.h 2011-03-26 11:50:21.112553151 +0100
+@@ -9,6 +9,7 @@
+ #define SAFEVECTOR_H
+
+ #include <cassert>
++#include <cstddef>
+ #include <vector>
+
+ /////////////////////////////////////////////////////////////////
diff --git a/sci-biology/amap/files/amap-2.2-makefile.patch b/sci-biology/amap/files/amap-2.2-makefile.patch
new file mode 100644
index 00000000000..5a9841c9825
--- /dev/null
+++ b/sci-biology/amap/files/amap-2.2-makefile.patch
@@ -0,0 +1,35 @@
+Respect {CXX,LD}FLAGS
+
+http://bugs.gentoo.org/332009
+
+--- amap-align/align/Makefile
++++ amap-align/align/Makefile
+@@ -15,6 +15,8 @@
+ # c) RELEASE mode
+ ################################################################################
+
++OPT_CXXFLAGS = -O3 -W -Wall -pedantic -funroll-loops
++
+ OTHERFLAGS = -DNumInsertStates=1 -DVERSION='"AMAP.2.2"'
+
+ # debug mode
+@@ -26,8 +28,7 @@
+
+ # release mode
+ #CXXFLAGS = -O3 -W -Wall -pedantic -DNDEBUG $(OTHERFLAGS) -mmmx -msse -msse2 -mfpmath=sse -march=pentium4 -mcpu=pentium4 -funroll-loops -fomit-frame-pointer
+-CXXFLAGS = -O3 -W -Wall -pedantic -DNDEBUG $(OTHERFLAGS) -funroll-loops
+-
++CXXFLAGS = $(OPT_CXXFLAGS) -DNDEBUG $(OTHERFLAGS)
+ ################################################################################
+ # 3) Dependencies
+ ################################################################################
+
+@@ -38,7 +37,7 @@
+ all : $(TARGETS)
+
+ amap : MultiSequenceDag.h MultiSequence.h ProbabilisticModel.h ScoreType.h Sequence.h FileBuffer.h SparseMatrix.h EvolutionaryTree.h Defaults.h SafeVector.h Amap.cc
+- $(CXX) $(CXXFLAGS) -lm -o amap Amap.cc
++ $(CXX) $(LDFLAGS) $(CXXFLAGS) -o amap Amap.cc -lm
+
+ .PHONY : clean
+ clean:
diff --git a/sci-biology/amap/metadata.xml b/sci-biology/amap/metadata.xml
new file mode 100644
index 00000000000..34294c65ca0
--- /dev/null
+++ b/sci-biology/amap/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-biology</herd>
+</pkgmetadata>