summaryrefslogtreecommitdiff
path: root/sci-biology/ariadne
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/ariadne
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/ariadne')
-rw-r--r--sci-biology/ariadne/Manifest1
-rw-r--r--sci-biology/ariadne/ariadne-1.3-r1.ebuild38
-rw-r--r--sci-biology/ariadne/ariadne-1.3-r2.ebuild40
-rw-r--r--sci-biology/ariadne/files/ariadne-1.3-gcc4.patch10
-rw-r--r--sci-biology/ariadne/files/ariadne-1.3-implicits.patch23
-rw-r--r--sci-biology/ariadne/metadata.xml17
6 files changed, 129 insertions, 0 deletions
diff --git a/sci-biology/ariadne/Manifest b/sci-biology/ariadne/Manifest
new file mode 100644
index 00000000000..a4bf86d55d3
--- /dev/null
+++ b/sci-biology/ariadne/Manifest
@@ -0,0 +1 @@
+DIST ariadne-1.3.tar.Z 69427 SHA256 8b6b0acb6e8d02b1303d94b20906bf2bf1dee3de4eceeb1b927cfba7a96fd00d SHA512 6c803f945bbcf36c08407e907ad716dc7cd01c7bed555777af46a5dc626b56ca3d1de7d16cab82bfa8bd5a91e06f42c590c0489594251405999459459e9c7289 WHIRLPOOL 460d8acf2bb49e097a9544ecc089ca60c3478b64ab4d903bd6ee801eccd62fc560bdccf1454c9f22632081cbf1df35de09a4f81d6c131d3f52f36753bc692927
diff --git a/sci-biology/ariadne/ariadne-1.3-r1.ebuild b/sci-biology/ariadne/ariadne-1.3-r1.ebuild
new file mode 100644
index 00000000000..80a05b612ca
--- /dev/null
+++ b/sci-biology/ariadne/ariadne-1.3-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Protein sequences and profiles comparison"
+
+HOMEPAGE="http://www.well.ox.ac.uk/ariadne/"
+SRC_URI="http://www.well.ox.ac.uk/${PN}/${P}.tar.Z"
+
+LICENSE="ARIADNE"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+DEPEND=">=sci-biology/ncbi-tools-0.20041020-r1"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/SRC-${PV}"
+
+src_unpack(){
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc4.patch
+ sed -e "s/CC = gcc/CC = $(tc-getCC)/" \
+ -e "s/OPTIMISE = -O2/OPTIMISE = ${CFLAGS}/" \
+ -i Makefile || die
+ sed -e "s/blosum62/BLOSUM62/" -i prospero.c || die
+}
+
+src_install() {
+ dobin Linux/{ariadne,prospero} || die
+ dolib Linux/libseq.a || die
+ insinto /usr/include/${PN}
+ doins Include/*.h || die
+ dodoc README || die
+}
diff --git a/sci-biology/ariadne/ariadne-1.3-r2.ebuild b/sci-biology/ariadne/ariadne-1.3-r2.ebuild
new file mode 100644
index 00000000000..1fa55ce322d
--- /dev/null
+++ b/sci-biology/ariadne/ariadne-1.3-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Protein sequences and profiles comparison"
+HOMEPAGE="http://www.well.ox.ac.uk/ariadne/"
+SRC_URI="http://www.well.ox.ac.uk/${PN}/${P}.tar.Z"
+
+LICENSE="ARIADNE"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND=">=sci-biology/ncbi-tools-0.20041020-r1"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/SRC-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc4.patch \
+ "${FILESDIR}"/${P}-implicits.patch
+ sed -i -e "s/\$(CFLAGS)/\$(LDFLAGS) &/" Makefile || die #359045
+ sed -e "s/blosum62/BLOSUM62/" -i prospero.c || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" OPTIMISE="${CFLAGS}"
+}
+
+src_install() {
+ dobin Linux/{ariadne,prospero}
+ use static-libs && dolib.a Linux/libseq.a
+ insinto /usr/include/${PN}
+ doins Include/*.h || die
+ dodoc README || die
+}
diff --git a/sci-biology/ariadne/files/ariadne-1.3-gcc4.patch b/sci-biology/ariadne/files/ariadne-1.3-gcc4.patch
new file mode 100644
index 00000000000..0192efd4db5
--- /dev/null
+++ b/sci-biology/ariadne/files/ariadne-1.3-gcc4.patch
@@ -0,0 +1,10 @@
+--- cl.c.old 2006-09-12 17:13:02.000000000 -0400
++++ cl.c 2006-09-12 17:13:34.000000000 -0400
+@@ -658,6 +658,7 @@
+ fclose(fp);
+ if ( ! stat( filename, &buf ) )
+ {
++ char *ctime(), *t;
+ sprintf( date, "%s", ctime(&buf.st_mtime) );
+ t = date;
+ while ( *t )
diff --git a/sci-biology/ariadne/files/ariadne-1.3-implicits.patch b/sci-biology/ariadne/files/ariadne-1.3-implicits.patch
new file mode 100644
index 00000000000..31c442b1226
--- /dev/null
+++ b/sci-biology/ariadne/files/ariadne-1.3-implicits.patch
@@ -0,0 +1,23 @@
+topalign.c:96:5: warning: implicit declaration of function ‘toupper’
+prospero.c:63:3: warning: implicit declaration of function ‘strcpy’
+
+--- SRC-1.3/prospero.c
++++ SRC-1.3/prospero.c
+@@ -26,6 +26,7 @@
+ */
+
+ #include<stdio.h>
++#include<string.h>
+ #include<math.h>
+ #include"cl.h"
+ #include"seq_util.h"
+--- SRC-1.3/topalign.c
++++ SRC-1.3/topalign.c
+@@ -26,6 +26,7 @@
+ */
+
+ #include<stdio.h>
++#include<ctype.h>
+ #include<math.h>
+ #include"seq_util.h"
+ #include"ariadne.h"
diff --git a/sci-biology/ariadne/metadata.xml b/sci-biology/ariadne/metadata.xml
new file mode 100644
index 00000000000..3e55c00f9d7
--- /dev/null
+++ b/sci-biology/ariadne/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <longdescription>
+ ARIADNE is a package of two programs, ariadne and prospero, that
+ compare protein sequences and profiles using the Smith-Waterman
+ algorithm, and assesses statistical significance using a new accurate
+ formula, described in Mott, 2000, "Accurate Formula for P-values of
+ gapped local sequence and profile alignments" J. Mol Biol. 300:649-659.
+ The sequence/profile comparison algorithms used in ARIADNE are
+ standard, and are probably not the fastest implementations available.
+ The novel part is the method for determining statistical significance,
+ which will give thresholds of significance that are accurate to within
+ 5% 95% of the time.
+ </longdescription>
+</pkgmetadata>