summaryrefslogtreecommitdiff
path: root/sci-biology/bioperl-db
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/bioperl-db
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/bioperl-db')
-rw-r--r--sci-biology/bioperl-db/Manifest1
-rw-r--r--sci-biology/bioperl-db/bioperl-db-1.6.9.ebuild34
-rw-r--r--sci-biology/bioperl-db/bioperl-db-9999-r1.ebuild39
-rw-r--r--sci-biology/bioperl-db/metadata.xml8
4 files changed, 82 insertions, 0 deletions
diff --git a/sci-biology/bioperl-db/Manifest b/sci-biology/bioperl-db/Manifest
new file mode 100644
index 00000000000..b189a8ae405
--- /dev/null
+++ b/sci-biology/bioperl-db/Manifest
@@ -0,0 +1 @@
+DIST BioPerl-DB-1.006900.tar.gz 492799 SHA256 50df2447b7f3e26aebcf02ed7344d3ef562c3f5393c1584a8ae086185c8c9139 SHA512 e06b8b9aa4188a83128f910d7b4a031f69d36f75e4f2d7210357366379024ef39b58eca97112b5b419f141c82b7518086273cc97c9637382ee5e0ddb9ce28746 WHIRLPOOL b484ce9f464a7189e5b2fffd6facdd426e8b9009ffca5e1661986490bc45dc0269faec5e9eeebdb23ec5c706f62a670fbb6bfc5a60b11c268c7e6f34bf1f03f2
diff --git a/sci-biology/bioperl-db/bioperl-db-1.6.9.ebuild b/sci-biology/bioperl-db/bioperl-db-1.6.9.ebuild
new file mode 100644
index 00000000000..b78237d1e43
--- /dev/null
+++ b/sci-biology/bioperl-db/bioperl-db-1.6.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+BIOPERL_RELEASE=1.6.9
+
+MY_PN=BioPerl-DB
+MODULE_AUTHOR=CJFIELDS
+MODULE_VERSION=1.006900
+inherit perl-module
+
+DESCRIPTION="Perl tools for bioinformatics - Perl API that accesses the BioSQL schema"
+HOMEPAGE="http://www.bioperl.org/"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+SRC_TEST="do"
+
+CDEPEND="
+ >=sci-biology/bioperl-${PV}
+ dev-perl/DBD-mysql
+ dev-perl/DBI
+ sci-biology/biosql"
+DEPEND="${CDEPEND}
+ dev-perl/Module-Build"
+RDEPEND="${CDEPEND}"
+
+src_install() {
+ mydoc="AUTHORS BUGS FAQ"
+ perl-module_src_install
+}
diff --git a/sci-biology/bioperl-db/bioperl-db-9999-r1.ebuild b/sci-biology/bioperl-db/bioperl-db-9999-r1.ebuild
new file mode 100644
index 00000000000..aad5b6e4abe
--- /dev/null
+++ b/sci-biology/bioperl-db/bioperl-db-9999-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit perl-module git-2
+
+DESCRIPTION="Perl tools for bioinformatics - Perl API that accesses the BioSQL schema"
+HOMEPAGE="http://www.bioperl.org/"
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/bioperl/${PN}.git
+ https://github.com/bioperl/${PN}.git"
+
+LICENSE="Artistic GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+CDEPEND=">=sci-biology/bioperl-${PV}
+ dev-perl/DBI
+ sci-biology/biosql"
+DEPEND="dev-perl/Module-Build
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}"
+
+S="${WORKDIR}/BioPerl-db-${PV}"
+
+src_configure() {
+ # This disables tests. TODO: Enable tests
+ sed -i -e '/biosql_conf();/d' \
+ -e '/skip.*DBHarness.biosql.conf/d' "${S}/Build.PL" || die
+ perl-module_src_configure
+}
+
+src_install() {
+ mydoc="AUTHORS BUGS FAQ"
+ perl-module_src_install
+}
diff --git a/sci-biology/bioperl-db/metadata.xml b/sci-biology/bioperl-db/metadata.xml
new file mode 100644
index 00000000000..642468c809b
--- /dev/null
+++ b/sci-biology/bioperl-db/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <upstream>
+ <remote-id type="cpan">BioPerl-DB</remote-id>
+ </upstream>
+</pkgmetadata>