summaryrefslogtreecommitdiff
path: root/sci-biology/mira
diff options
context:
space:
mode:
authorNicholas Vinson <nvinson234@gmail.com>2017-01-12 06:28:07 -0800
committerLars Wendler <polynomial-c@gentoo.org>2017-01-13 17:13:39 +0100
commit2f68c7a59f7e94579b72450618e1e7e799fcffe4 (patch)
tree1af8e7a78607e353f79976b6a240a7ede43cd15b /sci-biology/mira
parent1ff60456aa75b7d92b48e863455549e44057e9d0 (diff)
downloadgentoo-2f68c7a59f7e94579b72450618e1e7e799fcffe4.tar.gz
gentoo-2f68c7a59f7e94579b72450618e1e7e799fcffe4.tar.xz
sci-biology/mira: Update flex-2.6.3 fix; add cmath header
Another round of testing discovered that caf_flexer.cc is also a pre-generated lexer. The commit updates the ebuild to remove that file as well. The file abs.C fails to find the pow() function. Modern versions of C++ store the header for that function in cmath. The file is updated to include that header. Gentoo-bug: 585942 Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3442
Diffstat (limited to 'sci-biology/mira')
-rw-r--r--sci-biology/mira/files/mira-4.0.2-cmath.patch14
-rw-r--r--sci-biology/mira/mira-4.0.2.ebuild6
2 files changed, 18 insertions, 2 deletions
diff --git a/sci-biology/mira/files/mira-4.0.2-cmath.patch b/sci-biology/mira/files/mira-4.0.2-cmath.patch
new file mode 100644
index 00000000000..a4a020177af
--- /dev/null
+++ b/sci-biology/mira/files/mira-4.0.2-cmath.patch
@@ -0,0 +1,14 @@
+--- mira-4.0.2/src/mira/ads.C
++++ mira-4.0.2/src/mira/ads.C
+@@ -31,10 +31,11 @@
+ * Routines for computing scores and some other classification number are
+ * provided, too.
+ *
+ */
+
++#include <cmath>
+
+ #include "ads.H"
+
+ #include "errorhandling/errorhandling.H"
+ #include "util/dptools.H"
diff --git a/sci-biology/mira/mira-4.0.2.ebuild b/sci-biology/mira/mira-4.0.2.ebuild
index 3814d2dbd74..758e30b28e3 100644
--- a/sci-biology/mira/mira-4.0.2.ebuild
+++ b/sci-biology/mira/mira-4.0.2.ebuild
@@ -41,7 +41,8 @@ src_prepare() {
find -name 'configure*' -or -name 'Makefile*' | xargs sed -i 's/flex++/flex -+/' || die
epatch \
"${FILESDIR}"/${PN}-3.4.0.2-boost-1.50.patch \
- "${FILESDIR}"/${P}-cout.patch
+ "${FILESDIR}"/${P}-cout.patch \
+ "${FILESDIR}"/${P}-cmath.patch
sed \
-e "s:-O[23]::g" \
@@ -50,9 +51,10 @@ src_prepare() {
eautoreconf
- # Remove C++ source files that were built with flex by upstream.
+ # Remove C++ source files that upstream built with flex.
local f
local PREBUILT_CXX_LEXER_FILES=(
+ "$S"/src/caf/caf_flexer.cc
"$S"/src/io/exp_flexer.cc
"$S"/src/mira/parameters_flexer.cc
)