summaryrefslogtreecommitdiff
path: root/sci-biology/stride
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/stride
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/stride')
-rw-r--r--sci-biology/stride/Manifest2
-rw-r--r--sci-biology/stride/files/stride-LDFLAGS.patch11
-rw-r--r--sci-biology/stride/metadata.xml5
-rw-r--r--sci-biology/stride/stride-20011129-r1.ebuild38
4 files changed, 56 insertions, 0 deletions
diff --git a/sci-biology/stride/Manifest b/sci-biology/stride/Manifest
new file mode 100644
index 00000000000..cd6e1754804
--- /dev/null
+++ b/sci-biology/stride/Manifest
@@ -0,0 +1,2 @@
+DIST stride-20060723-update.patch.bz2 5621 SHA256 8d48627c294b4efba67acba10fba47b20c0a8d5f7e06c2775a2d7eaaa0aa7b81 SHA512 e06eb68b907615e12dc1a9981be157400e9ffed9391a906cb4eb3ef4067b7027c26cc600298053bfc5d2bbbebbbfefe0e6b18d0e4f6fef2172768e6f95498af1 WHIRLPOOL fbe19cd7da96a845a001f5fcfb6c0aed7b9c4c152b48ef9ab9df63b1d72c9a97e545c9a6e12c5c58823210dd48050392b0a9c0758c1d57c3677ac5092de863f9
+DIST stride.tar.gz 56441 SHA256 d272700bccd046199f6ea1faed31a2a2662a7d5f13b7663736a1818ac18c87b9 SHA512 cbd40fce4684728f363520540132fc1a0003126954a145d59aeff48adb20fdaa66520bd12b56ee5d2906e8ea97bf78a225204105b820f7f368aee5e790a6471b WHIRLPOOL 843c789eda18da69a670a134f8a19103381ac86d611a3e1f0b47e17c3d171a195b8064d131ec3f81a561a65d8536d5f8a8c3a490776646b50ecb6aee36c46536
diff --git a/sci-biology/stride/files/stride-LDFLAGS.patch b/sci-biology/stride/files/stride-LDFLAGS.patch
new file mode 100644
index 00000000000..1761b12129b
--- /dev/null
+++ b/sci-biology/stride/files/stride-LDFLAGS.patch
@@ -0,0 +1,11 @@
+--- Makefile 2009-10-27 21:18:45.000000000 +0100
++++ Makefile.new 2009-10-27 21:19:00.000000000 +0100
+@@ -12,7 +12,7 @@
+
+
+ stride : $(OBJECT)
+- $(CC) $(OBJECT) $(FLAGS) $(BINDIR)/stride
++ $(CC) $(LDFLAGS) $(OBJECT) $(FLAGS) $(BINDIR)/stride
+
+ $(OBJECT) : stride.h protot.h
+
diff --git a/sci-biology/stride/metadata.xml b/sci-biology/stride/metadata.xml
new file mode 100644
index 00000000000..f17a827e310
--- /dev/null
+++ b/sci-biology/stride/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+</pkgmetadata>
diff --git a/sci-biology/stride/stride-20011129-r1.ebuild b/sci-biology/stride/stride-20011129-r1.ebuild
new file mode 100644
index 00000000000..0848427631a
--- /dev/null
+++ b/sci-biology/stride/stride-20011129-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Protein secondary structure assignment from atomic coordinates"
+HOMEPAGE="http://webclu.bio.wzw.tum.de/stride/"
+SRC_URI="
+ ftp://ftp.ebi.ac.uk/pub/software/unix/${PN}/src/${PN}.tar.gz
+ http://dev.gentoo.org/~jlec/distfiles/${PN}-20060723-update.patch.bz2"
+
+SLOT="0"
+LICENSE="STRIDE"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+S="${WORKDIR}"
+
+RESTRICT="mirror bindist"
+
+src_prepare() {
+ # this patch updates the source to the most recent
+ # version which was kindly provided by the author
+ epatch \
+ "${DISTDIR}/${PN}-20060723-update.patch.bz2" \
+ "${FILESDIR}"/${PN}-LDFLAGS.patch
+
+ # fix makefile
+ sed -e "/^CC/s|gcc -g|$(tc-getCC) ${CFLAGS}|" -i Makefile || \
+ die "Failed to fix Makefile"
+}
+
+src_install() {
+ dobin ${PN}
+}