summaryrefslogtreecommitdiff
path: root/sci-biology/uchime
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/uchime
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/uchime')
-rw-r--r--sci-biology/uchime/Manifest1
-rw-r--r--sci-biology/uchime/files/CMakeLists.txt11
-rw-r--r--sci-biology/uchime/metadata.xml15
-rw-r--r--sci-biology/uchime/uchime-4.2.40.ebuild24
4 files changed, 51 insertions, 0 deletions
diff --git a/sci-biology/uchime/Manifest b/sci-biology/uchime/Manifest
new file mode 100644
index 00000000000..e17b1c93e22
--- /dev/null
+++ b/sci-biology/uchime/Manifest
@@ -0,0 +1 @@
+DIST uchime4.2.40_src.tar.gz 66772 SHA256 cb6a3aea4e8b4343a6e0ddde3b2755bbec53492bae5d6252ce8a7091061f353d SHA512 c3afecb23d164d9c3db6229f54faa13120ac4d88132d9aef707f8d043091099db4205ac80f60242920af6efc23813b3e7e4966d562bdb75ff53244fd525e656b WHIRLPOOL 28ad19892ac8b4db03e93fd1fca39b05d6675c241a97f7a2ab241765589b34c56684ab4923eaf568a5f9b0e1583ce1460be7f0edf9d9201e5d3db3da0efb0ee6
diff --git a/sci-biology/uchime/files/CMakeLists.txt b/sci-biology/uchime/files/CMakeLists.txt
new file mode 100644
index 00000000000..54b0a3ba0d3
--- /dev/null
+++ b/sci-biology/uchime/files/CMakeLists.txt
@@ -0,0 +1,11 @@
+cmake_minimum_required(VERSION 2.6)
+project(UCHIME)
+
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -D_FILE_OFFSET_BITS=64 -DUCHIMES=1")
+
+# Simply copy the source files from the mk script
+add_executable(uchime
+ addtargets2.cpp alignchime.cpp alignchimel.cpp alnparams.cpp alpha.cpp alpha2.cpp fractid.cpp getparents.cpp globalalign2.cpp make3way.cpp mx.cpp myutils.cpp path.cpp searchchime.cpp seqdb.cpp setnucmx.cpp sfasta.cpp tracebackbit.cpp uchime_main.cpp usort.cpp viterbifast.cpp writechhit.cpp)
+
+INSTALL(TARGETS uchime
+ DESTINATION bin)
diff --git a/sci-biology/uchime/metadata.xml b/sci-biology/uchime/metadata.xml
new file mode 100644
index 00000000000..a3c0f91c8a0
--- /dev/null
+++ b/sci-biology/uchime/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <longdescription>
+UCHIME is a new algorithm for detecting chimeric sequences. It was developed in
+collaboration with Brian Haas, Jose Carlos Clemente, Chris Quince and Rob
+Knight. Chimeras are commonly created during DNA sample amplification by
+PCR, especially in community sequencing experiments using single regions
+such as the 16S rRNA gene in bacteria or the fungal ITS region. UCHIME can
+detect chimeras using a reference database or de novo using abundance
+information on the assumption that chimeras are less abundant than their
+parents because they must have undergone fewer rounds of amplification.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-biology/uchime/uchime-4.2.40.ebuild b/sci-biology/uchime/uchime-4.2.40.ebuild
new file mode 100644
index 00000000000..19b55f5039e
--- /dev/null
+++ b/sci-biology/uchime/uchime-4.2.40.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit cmake-utils
+
+MY_P="${PN}${PV}_src"
+
+DESCRIPTION="Fast, accurate chimera detection"
+HOMEPAGE="http://www.drive5.com/uchime/"
+SRC_URI="http://drive5.com/${PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="public-domain"
+KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ cp "${FILESDIR}"/CMakeLists.txt . || die
+}