summaryrefslogtreecommitdiff
path: root/sci-calculators/datamash/datamash-1.4.ebuild
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-12-23 15:57:13 +0100
committerJeroen Roovers <jer@gentoo.org>2018-12-23 15:57:25 +0100
commit58091b79c335334031dd177c04e6ffa65f2f1ec6 (patch)
treedd3ada1bf4718db5c8802cf537ba4ef7eaf4c5ed /sci-calculators/datamash/datamash-1.4.ebuild
parent8b1e4301b36cb4f8e7949a5780788f3f94f22270 (diff)
downloadgentoo-58091b79c335334031dd177c04e6ffa65f2f1ec6.tar.gz
gentoo-58091b79c335334031dd177c04e6ffa65f2f1ec6.tar.xz
sci-calculators/datamash: Version 1.4
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'sci-calculators/datamash/datamash-1.4.ebuild')
-rw-r--r--sci-calculators/datamash/datamash-1.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-calculators/datamash/datamash-1.4.ebuild b/sci-calculators/datamash/datamash-1.4.ebuild
new file mode 100644
index 00000000000..4e17c0dbba4
--- /dev/null
+++ b/sci-calculators/datamash/datamash-1.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="command-line program for basic numeric, textual and statistical operations"
+HOMEPAGE="https://www.gnu.org/software/datamash/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls openssl"
+
+CDEPEND="
+ openssl? ( dev-libs/openssl )
+"
+RDEPEND="
+ ${CDEPEND}
+ nls? ( virtual/libintl )
+"
+BDEPEND="
+ ${CDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(usex openssl --with-openssl={yes,no})
+}