summaryrefslogtreecommitdiff
path: root/sci-chemistry/ball
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/ball
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/ball')
-rw-r--r--sci-chemistry/ball/Manifest1
-rw-r--r--sci-chemistry/ball/ball-1.4.2.ebuild83
-rw-r--r--sci-chemistry/ball/files/ball-1.4.1-BondOrder.xml.patch30
-rw-r--r--sci-chemistry/ball/files/ball-1.4.1-missing-signed.patch26
-rw-r--r--sci-chemistry/ball/files/ball-1.4.1-multilib.patch39
-rw-r--r--sci-chemistry/ball/files/ball-1.4.2-Fix-compilation-of-sipModularWidget.patch40
-rw-r--r--sci-chemistry/ball/files/ball-1.4.2-PDBFile-Fix-compilation-with-gcc-4.8.patch28
-rw-r--r--sci-chemistry/ball/files/ball-1.4.2-QT4_EXTRACT_OPTIONS-CMake-macro-changed-in-CMake-2.8.patch44
-rw-r--r--sci-chemistry/ball/files/ball-1.4.2-underlinking.patch16
-rw-r--r--sci-chemistry/ball/metadata.xml32
10 files changed, 339 insertions, 0 deletions
diff --git a/sci-chemistry/ball/Manifest b/sci-chemistry/ball/Manifest
new file mode 100644
index 00000000000..f7919da9098
--- /dev/null
+++ b/sci-chemistry/ball/Manifest
@@ -0,0 +1 @@
+DIST BALL-1.4.2.tar.xz 16080664 SHA256 053931b2e050d7d5bceaa21ad3617a1ad0af00f94de56076ce02d544383cbf91 SHA512 c719af4ef2dc1076818d59b72350b704fbffea06bd44737519fb50d88da113ea509333d407f2330aa59bf1c4e6b81adfd3d28e05459f66d7c9707f8d85db7a87 WHIRLPOOL ba7ae340833ea5703d047a9dbc0ce50d9b9dc2b0047a0c6d9f9a17946956c684a09e0860f25c7214a2aa0adee9beb1d01eac38b0ab08259a2934f97cbef91379
diff --git a/sci-chemistry/ball/ball-1.4.2.ebuild b/sci-chemistry/ball/ball-1.4.2.ebuild
new file mode 100644
index 00000000000..bc1005204c0
--- /dev/null
+++ b/sci-chemistry/ball/ball-1.4.2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="Biochemical Algorithms Library"
+HOMEPAGE="http://www.ball-project.org/"
+SRC_URI="http://www.ball-project.org/Downloads/v${PV}/BALL-${PV}.tar.xz"
+
+SLOT="0"
+LICENSE="LGPL-2 GPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cuda mpi +python sql test +threads +webkit"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-cpp/eigen:3
+ dev-libs/boost
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtopengl:4
+ dev-qt/qttest:4
+ dev-qt/qtwebkit:4
+ media-libs/glew
+ sci-libs/fftw:3.0[threads?]
+ sci-libs/gsl
+ sci-libs/libsvm
+ sci-mathematics/lpsolve
+ virtual/opengl
+ x11-libs/libX11
+ cuda? ( dev-util/nvidia-cuda-toolkit )
+ mpi? ( virtual/mpi )
+ python? ( ${PYTHON_DEPS} )
+ sql? ( dev-qt/qtsql:4 )
+ webkit? ( dev-qt/qtwebkit:4 )"
+DEPEND="${RDEPEND}
+ dev-python/sip
+ sys-devel/bison
+ virtual/yacc"
+
+S="${WORKDIR}"/BALL-${PV}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.1-multilib.patch
+ "${FILESDIR}"/${PN}-1.4.1-missing-signed.patch
+ "${FILESDIR}"/${P}-PDBFile-Fix-compilation-with-gcc-4.8.patch
+ "${FILESDIR}"/${P}-QT4_EXTRACT_OPTIONS-CMake-macro-changed-in-CMake-2.8.patch
+ "${FILESDIR}"/${PN}-1.4.1-BondOrder.xml.patch
+ "${FILESDIR}"/${P}-Fix-compilation-of-sipModularWidget.patch
+ "${FILESDIR}"/${P}-underlinking.patch
+ )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_use threads FFTW_THREADS)
+ $(cmake-utils_use cuda MT_ENABLE_CUDA)
+ $(cmake-utils_use mpi MT_ENABLE_MPI)
+ $(cmake-utils_use sql BALL_HAS_QTSQL)
+ $(cmake-utils_use_use webkit USE_QTWEBKIT)
+ $(cmake-utils_use python BALL_PYTHON_SUPPORT)
+ )
+ cmake-utils_src_configure
+ local i
+ for i in "${S}"/data/*; do
+ ln -sf "${i}" "${BUILD_DIR}"/source/TEST/ || die
+ ln -sf "${i}" "${S}"/source/TEST/ || die
+ done
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use test && cmake-utils_src_make build_tests
+}
diff --git a/sci-chemistry/ball/files/ball-1.4.1-BondOrder.xml.patch b/sci-chemistry/ball/files/ball-1.4.1-BondOrder.xml.patch
new file mode 100644
index 00000000000..51e59280699
--- /dev/null
+++ b/sci-chemistry/ball/files/ball-1.4.1-BondOrder.xml.patch
@@ -0,0 +1,30 @@
+ source/STRUCTURE/assignBondOrderProcessor.C | 2 +-
+ source/TEST/AssignBondOrderProcessor_test.C | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/source/STRUCTURE/assignBondOrderProcessor.C b/source/STRUCTURE/assignBondOrderProcessor.C
+index f8acc4f..035fffc 100644
+--- a/source/STRUCTURE/assignBondOrderProcessor.C
++++ b/source/STRUCTURE/assignBondOrderProcessor.C
+@@ -100,7 +100,7 @@ namespace BALL
+ const bool AssignBondOrderProcessor::Default::KEKULIZE_RINGS = true;
+
+ const char* AssignBondOrderProcessor::Option::INIFile = "iniFile";
+- const String AssignBondOrderProcessor::Default::INIFile = "/bond_lengths/BondOrder.xml";
++ const String AssignBondOrderProcessor::Default::INIFile = "bond_lengths/BondOrder.xml";
+
+ const char* AssignBondOrderProcessor::Option::MAX_BOND_ORDER = "max_bond_order";
+ const int AssignBondOrderProcessor::Default::MAX_BOND_ORDER = 3;
+diff --git a/source/TEST/AssignBondOrderProcessor_test.C b/source/TEST/AssignBondOrderProcessor_test.C
+index 6dfafcc..3405ef5 100644
+--- a/source/TEST/AssignBondOrderProcessor_test.C
++++ b/source/TEST/AssignBondOrderProcessor_test.C
+@@ -1834,7 +1834,7 @@ CHECK(Option::INIFile)
+ // There is really not much we can test here, so we just execute the processor
+ // to have a chance of catching bugs with valgrind if they sneak in
+ AssignBondOrderProcessor abop;
+- abop.options.set(AssignBondOrderProcessor::Option::INIFile, "/bond_lengths/BondOrderGAFF.xml");
++ abop.options.set(AssignBondOrderProcessor::Option::INIFile, "bond_lengths/BondOrderGAFF.xml");
+
+ System sys40;
+ MOL2File mol40(BALL_TEST_DATA_PATH(AssignBondOrderProcessor_test_C4_input.mol2), std::ios::in);
diff --git a/sci-chemistry/ball/files/ball-1.4.1-missing-signed.patch b/sci-chemistry/ball/files/ball-1.4.1-missing-signed.patch
new file mode 100644
index 00000000000..6868871b3dc
--- /dev/null
+++ b/sci-chemistry/ball/files/ball-1.4.1-missing-signed.patch
@@ -0,0 +1,26 @@
+Index: ball/include/BALL/DATATYPE/hashGrid.h
+===================================================================
+--- ball.orig/include/BALL/DATATYPE/hashGrid.h 2011-12-09 13:49:26.000000000 +0100
++++ ball/include/BALL/DATATYPE/hashGrid.h 2011-12-09 13:51:09.000000000 +0100
+@@ -37,7 +37,7 @@
+ {
+ namespace __private
+ {
+- extern const char BALL_EXPORT neighbour_table_[27][3];
++ extern const signed char BALL_EXPORT neighbour_table_[27][3];
+ }
+
+ template <typename Item> class HashGrid3;
+Index: ball/source/DATATYPE/hashGrid.C
+===================================================================
+--- ball.orig/source/DATATYPE/hashGrid.C 2011-12-09 13:49:26.000000000 +0100
++++ ball/source/DATATYPE/hashGrid.C 2011-12-09 13:50:49.000000000 +0100
+@@ -9,7 +9,7 @@
+ {
+ namespace __private
+ {
+- const char neighbour_table_[27][3] =
++ const signed char neighbour_table_[27][3] =
+ {
+ { 0, 0, 0 }, { 0, 0, -1 }, { 0, 0, 1 },
+ { 0, -1, -1 }, { 0, -1, 0 }, { 0, -1, 1 },
diff --git a/sci-chemistry/ball/files/ball-1.4.1-multilib.patch b/sci-chemistry/ball/files/ball-1.4.1-multilib.patch
new file mode 100644
index 00000000000..317c4029c67
--- /dev/null
+++ b/sci-chemistry/ball/files/ball-1.4.1-multilib.patch
@@ -0,0 +1,39 @@
+From 5b8f4e58b4e54bcdfa6f287e01f91d9dfd4e5a14 Mon Sep 17 00:00:00 2001
+From: Justin Lecher <jlec@gentoo.org>
+Date: Sun, 25 Mar 2012 14:12:21 +0200
+Subject: [PATCH] Correct path for multilib installation.
+
+Libraries should go into lib64 not lib on native 64bit. Therefore we can use the LIBDIR detected by cmake.
+---
+ CMakeLists.txt | 8 ++++----
+ 1 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 940ebf4..7eb3db4 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -426,8 +426,8 @@ SET(CMAKE_RUNTIME_OUTPUT_DIRECTORY "${PROJECT_BINARY_DIR}/bin")
+ ## These variables are used in all install-targets
+ IF (NOT ${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
+ SET(BALL_RUNTIME_INSTALL_DIRECTORY "bin")
+- SET(BALL_LIBRARY_INSTALL_DIRECTORY "lib")
+- SET(BALL_ARCHIVE_INSTALL_DIRECTORY "lib")
++ SET(BALL_LIBRARY_INSTALL_DIRECTORY ${CMAKE_INSTALL_LIBDIR})
++ SET(BALL_ARCHIVE_INSTALL_DIRECTORY ${CMAKE_INSTALL_LIBDIR})
+ SET(BALL_HEADER_INSTALL_DIRECTORY ".")
+ SET(BALL_DATA_INSTALL_DIRECTORY "share/BALL")
+ SET(BALL_DOCUMENTATION_INSTALL_DIRECTORY "share/BALL/doc")
+@@ -435,8 +435,8 @@ IF (NOT ${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
+ SET(BALL_PYTHON_INSTALL_DIRECTORY "bin")
+ SET(BALL_PLUGIN_INSTALL_DIRECTORY "bin")
+ ELSE()
+- SET(BALL_PYTHON_INSTALL_DIRECTORY "lib")
+- SET(BALL_PLUGIN_INSTALL_DIRECTORY "lib")
++ SET(BALL_PYTHON_INSTALL_DIRECTORY ${CMAKE_INSTALL_LIBDIR})
++ SET(BALL_PLUGIN_INSTALL_DIRECTORY ${CMAKE_INSTALL_LIBDIR})
+ ENDIF()
+ ELSE()
+ SET(BALL_BUNDLE_INSTALL_DIRECTORY "Applications")
+--
+1.7.8.5
+
diff --git a/sci-chemistry/ball/files/ball-1.4.2-Fix-compilation-of-sipModularWidget.patch b/sci-chemistry/ball/files/ball-1.4.2-Fix-compilation-of-sipModularWidget.patch
new file mode 100644
index 00000000000..3ec2f6e983a
--- /dev/null
+++ b/sci-chemistry/ball/files/ball-1.4.2-Fix-compilation-of-sipModularWidget.patch
@@ -0,0 +1,40 @@
+From da49802f8620562f91ac2c947520dccd223ee26b Mon Sep 17 00:00:00 2001
+From: Andreas Hildebrandt <andreas.hildebrandt@uni-mainz.de>
+Date: Wed, 15 Jan 2014 17:42:01 +0100
+Subject: [PATCH] Fix compilation of sipModularWidget
+
+---
+ source/PYTHON/EXTENSIONS/VIEW/modularWidget.sip | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/source/PYTHON/EXTENSIONS/VIEW/modularWidget.sip b/source/PYTHON/EXTENSIONS/VIEW/modularWidget.sip
+index 522b0ed..7b8ba3e 100644
+--- a/source/PYTHON/EXTENSIONS/VIEW/modularWidget.sip
++++ b/source/PYTHON/EXTENSIONS/VIEW/modularWidget.sip
+@@ -22,18 +22,18 @@ class ModularWidget
+ static Size countInstances();
+ static ModularWidget* getInstance(Position);
+
+- ModularWidget(const char* = "<ModularWidget>") throw();
+- ModularWidget(const ModularWidget&) throw();
++ ModularWidget(const char* = "<ModularWidget>");
++ ModularWidget(const ModularWidget&);
+ ~ModularWidget() throw();
+
+- virtual void destroy() throw();
+- virtual void clear() throw();
++// virtual void destroy();
++ virtual void clear();
+
+ static void registerWidget(ModularWidget*) throw(NullPointer);
+ // virtual void initializeWidget(MainControl&);
+ // virtual void finalizeWidget(MainControl&);
+ virtual void checkMenu(MainControl&) throw();
+-// virtual void initializePreferencesTab(Preferences&) throw();
++// virtual void initializePreferencesTab(Preferences&);
+ // virtual void finalizePreferencesTab(Preferences&) throw();
+ virtual void applyPreferences() throw();
+ virtual void fetchPreferences(INIFile&) throw();
+--
+1.9.1
+
diff --git a/sci-chemistry/ball/files/ball-1.4.2-PDBFile-Fix-compilation-with-gcc-4.8.patch b/sci-chemistry/ball/files/ball-1.4.2-PDBFile-Fix-compilation-with-gcc-4.8.patch
new file mode 100644
index 00000000000..f6b8ff45fa7
--- /dev/null
+++ b/sci-chemistry/ball/files/ball-1.4.2-PDBFile-Fix-compilation-with-gcc-4.8.patch
@@ -0,0 +1,28 @@
+From e7cc50705bed20e160bd4b637b23f57270f580a8 Mon Sep 17 00:00:00 2001
+From: Daniel Stoeckel <dstoeckel@bioinf.uni-sb.de>
+Date: Sat, 6 Apr 2013 01:06:55 +0200
+Subject: [PATCH] PDBFile:Fix compilation with gcc 4.8
+
+Apparently the automatic conversion from boost::shared_ptr<CrystalInfo>
+to boost::shared_ptr<PersistentObject> is no longer supported.
+Just change the type of the pointer and work around this issue.
+---
+ source/FORMAT/PDBFileDetails.C | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/source/FORMAT/PDBFileDetails.C b/source/FORMAT/PDBFileDetails.C
+index 97c2572..aedc5db 100644
+--- a/source/FORMAT/PDBFileDetails.C
++++ b/source/FORMAT/PDBFileDetails.C
+@@ -901,7 +901,7 @@ namespace BALL
+ {
+ if (!(current_protein_->hasProperty("CRYSTALINFO")))
+ {
+- boost::shared_ptr<CrystalInfo> temp_ptr(new CrystalInfo());
++ boost::shared_ptr<PersistentObject> temp_ptr(new CrystalInfo());
+ current_protein_->setProperty(NamedProperty("CRYSTALINFO", temp_ptr));
+ }
+
+--
+1.9.1
+
diff --git a/sci-chemistry/ball/files/ball-1.4.2-QT4_EXTRACT_OPTIONS-CMake-macro-changed-in-CMake-2.8.patch b/sci-chemistry/ball/files/ball-1.4.2-QT4_EXTRACT_OPTIONS-CMake-macro-changed-in-CMake-2.8.patch
new file mode 100644
index 00000000000..615a9229080
--- /dev/null
+++ b/sci-chemistry/ball/files/ball-1.4.2-QT4_EXTRACT_OPTIONS-CMake-macro-changed-in-CMake-2.8.patch
@@ -0,0 +1,44 @@
+From 1e76c9cb1920e9176b725269985c7eb43126d188 Mon Sep 17 00:00:00 2001
+From: Luis de la Garza <delagarza@informatik.uni-tuebingen.de>
+Date: Fri, 22 Nov 2013 15:18:55 +0100
+Subject: [PATCH] QT4_EXTRACT_OPTIONS CMake macro changed in CMake 2.8.12;
+ fixed BALLMacros.cmake
+
+---
+ cmake/BALLMacros.cmake | 14 ++++++++++----
+ 1 file changed, 10 insertions(+), 4 deletions(-)
+
+diff --git a/cmake/BALLMacros.cmake b/cmake/BALLMacros.cmake
+index f81ab89..0ac1b87 100644
+--- a/cmake/BALLMacros.cmake
++++ b/cmake/BALLMacros.cmake
+@@ -6,16 +6,22 @@
+ ### minor modifications (marked with ## BALL ###)
+ ###
+ MACRO(QT4_WRAP_UI_BALL outfiles )
+- QT4_EXTRACT_OPTIONS(ui_files ui_options ${ARGN})
+-
+- ### BALL ###
++ # since 2.8.12 qt4_extract_options has an additional argument
++ # copied fix from OpenMS
++ IF(${CMAKE_VERSION} VERSION_LESS "2.8.12")
++ QT4_EXTRACT_OPTIONS(ui_files ui_options ${ARGN})
++ ELSE()
++ QT4_EXTRACT_OPTIONS(ui_files ui_options ui_target ${ARGN})
++ ENDIF()
++
++ ### BALL ###
+ # create output directory (will not exist for out-of-source builds)
+ FILE(MAKE_DIRECTORY ${PROJECT_BINARY_DIR}/include/BALL/VIEW/UIC/)
+
+ FOREACH (it ${ui_files})
+ GET_FILENAME_COMPONENT(outfile ${it} NAME_WE)
+ GET_FILENAME_COMPONENT(infile ${it} ABSOLUTE)
+- ### BALL ###
++ ### BALL ###
+ SET(outfile ${PROJECT_BINARY_DIR}/include/BALL/VIEW/UIC/ui_${outfile}.h)
+ ADD_CUSTOM_COMMAND(OUTPUT ${outfile}
+ COMMAND ${QT_UIC_EXECUTABLE}
+--
+1.9.1
+
diff --git a/sci-chemistry/ball/files/ball-1.4.2-underlinking.patch b/sci-chemistry/ball/files/ball-1.4.2-underlinking.patch
new file mode 100644
index 00000000000..825f41978c1
--- /dev/null
+++ b/sci-chemistry/ball/files/ball-1.4.2-underlinking.patch
@@ -0,0 +1,16 @@
+ source/APPLICATIONS/BALLVIEW/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/source/APPLICATIONS/BALLVIEW/CMakeLists.txt b/source/APPLICATIONS/BALLVIEW/CMakeLists.txt
+index 6d16212..f94ce76 100644
+--- a/source/APPLICATIONS/BALLVIEW/CMakeLists.txt
++++ b/source/APPLICATIONS/BALLVIEW/CMakeLists.txt
+@@ -85,7 +85,7 @@ IF (UNIX)
+ LIST(APPEND BALLVIEW_SUPPORT_LIBRARIES "pthread")
+ ENDIF ()
+
+-TARGET_LINK_LIBRARIES(BALLView BALL VIEW ${BALLVIEW_SUPPORT_LIBRARIES})
++TARGET_LINK_LIBRARIES(BALLView BALL VIEW ${BALLVIEW_SUPPORT_LIBRARIES} X11)
+
+ #Setup the translations
+ INCLUDE(${CMAKE_SOURCE_DIR}/cmake/BALLViewTranslations.cmake)
diff --git a/sci-chemistry/ball/metadata.xml b/sci-chemistry/ball/metadata.xml
new file mode 100644
index 00000000000..066e13dd4a5
--- /dev/null
+++ b/sci-chemistry/ball/metadata.xml
@@ -0,0 +1,32 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+Rapid Software Prototyping can significantly reduce development times in the
+field of Computational Molecular Biology and Molecular Modeling.
+BALL (Biochemical Algorithms Library) is an application framework in C++ that
+has been specifically designed for this purpose. It provides an extensive set
+of data structures as well as classes for Molecular Mechanics, advanced
+solvation methods, comparison and analysis of protein structures, file
+import/export, and visualization .
+
+BALL has been carefully designed to be robust, easy to use, and open to
+extensions. Especially its extensibility which results from an object-oriented
+and generic programming approach distinguishes it from other software packages.
+BALL is well suited to serve as a public repository for reliable data
+structures and algorithms.
+
+Based on BALL we have developed a stand-alone tool for molecular visualization,
+BALLView . BALLView makes the broad functionality available through an
+integrated user-friendly GUI.
+</longdescription>
+ <use>
+ <flag name="sql">Include SQL database support</flag>
+ <flag name="cuda">Include cuda support</flag>
+ <flag name="webkit">Uses <pkg>dev-qt/qtwebkit</pkg> for drawing</flag>
+ </use>
+</pkgmetadata>