summaryrefslogtreecommitdiff
path: root/sci-chemistry/cara-bin
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/cara-bin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/cara-bin')
-rw-r--r--sci-chemistry/cara-bin/Manifest2
-rw-r--r--sci-chemistry/cara-bin/cara-bin-1.8.4-r1.ebuild49
-rw-r--r--sci-chemistry/cara-bin/metadata.xml7
3 files changed, 58 insertions, 0 deletions
diff --git a/sci-chemistry/cara-bin/Manifest b/sci-chemistry/cara-bin/Manifest
new file mode 100644
index 00000000000..12c0fa6dee5
--- /dev/null
+++ b/sci-chemistry/cara-bin/Manifest
@@ -0,0 +1,2 @@
+DIST Start1.2.cara.xz 43124 SHA256 c28321b051902bc020ea04a46b33ceb19b1b3d902264956474c90798f2d60d25 SHA512 26874d634491558dc593a0ec32e83d5cfceedc69bbf901f4d25d6b9515b84aebffbf495d1ac34b3664b8b5822954edf62c5b88dcca6bcfcb152715caa88f5f03 WHIRLPOOL 034e8b73354e7244e4fcc21c03da7b99c02019ebef1e0754dd9cb8249fe68b82be1e78db9848912fc48c8625b0f2acf0f41242d83949a117f0b8a648a930445e
+DIST cara_1.8.4_linux.gz 6677463 SHA256 5ba34cc8b0782e1791186cde5a02ec036665769df7f5c559db27377b6f3cc6d6 SHA512 e264cfbef640f267132dfd48b940203a319c8f34de71c5b786c6bfc2ab561bdf3fbd79516d619ca52b2aca64a2887f770fabfabedb76433c5f78aa02c65f898f WHIRLPOOL 5619c70bc31dfb328a72233c8fc3e3d8dcfdccc3db4e5a67430f0ebe8a0a474f998abb2a0ec56f4a3c2e6e4b95e324ec3c667864c81cb3531a1e162439c780da
diff --git a/sci-chemistry/cara-bin/cara-bin-1.8.4-r1.ebuild b/sci-chemistry/cara-bin/cara-bin-1.8.4-r1.ebuild
new file mode 100644
index 00000000000..d17c035cd3b
--- /dev/null
+++ b/sci-chemistry/cara-bin/cara-bin-1.8.4-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN="${PN%%-bin}"
+MY_P="${MY_PN}_${PV}"
+
+DESCRIPTION="Analysis of NMR spectra and Computer Aided Resonance Assignment"
+SRC_URI="
+ http://www.cara.nmr-software.org/downloads/${MY_P}_linux.gz
+ http://dev.gentoo.org/~jlec/distfiles//Start1.2.cara.xz"
+HOMEPAGE="http://www.nmr.ch"
+
+LICENSE="CARA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="lua"
+
+RDEPEND="
+ !prefix? (
+ >=media-libs/fontconfig-2.10.92[abi_x86_32(-)]
+ >=media-libs/freetype-2.5.0.1[abi_x86_32(-)]
+ >=x11-libs/libICE-1.0.8-r1[abi_x86_32(-)]
+ >=x11-libs/libSM-1.2.1-r1[abi_x86_32(-)]
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXcursor-1.1.14[abi_x86_32(-)]
+ >=x11-libs/libXext-1.3.2[abi_x86_32(-)]
+ >=x11-libs/libXi-1.7.2[abi_x86_32(-)]
+ >=x11-libs/libXrandr-1.4.2[abi_x86_32(-)]
+ >=x11-libs/libXrender-0.9.8[abi_x86_32(-)]
+ )
+ virtual/libstdc++
+ lua? ( dev-lang/lua )"
+DEPEND=""
+
+RESTRICT="mirror"
+
+QA_PREBUILT="opt/cara/*"
+
+S="${WORKDIR}"
+
+src_install() {
+ exeinto /opt/cara
+ doexe ${MY_P}_linux
+ dosym ../cara/${MY_P}_linux /opt/bin/cara
+ dodoc Start1.2.cara
+}
diff --git a/sci-chemistry/cara-bin/metadata.xml b/sci-chemistry/cara-bin/metadata.xml
new file mode 100644
index 00000000000..4a00a64b40a
--- /dev/null
+++ b/sci-chemistry/cara-bin/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>