summaryrefslogtreecommitdiff
path: root/sci-chemistry/ccp4i
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/ccp4i
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/ccp4i')
-rw-r--r--sci-chemistry/ccp4i/Manifest3
-rw-r--r--sci-chemistry/ccp4i/ccp4i-6.1.3-r4.ebuild99
-rw-r--r--sci-chemistry/ccp4i/files/6.1.3-fix-baubles.patch22
-rw-r--r--sci-chemistry/ccp4i/files/6.1.3-rename-rapper.patch61
-rw-r--r--sci-chemistry/ccp4i/files/6.1.3-rename-superpose.patch26
-rw-r--r--sci-chemistry/ccp4i/files/6.1.3-rename-truncate.patch91
-rw-r--r--sci-chemistry/ccp4i/metadata.xml5
7 files changed, 307 insertions, 0 deletions
diff --git a/sci-chemistry/ccp4i/Manifest b/sci-chemistry/ccp4i/Manifest
new file mode 100644
index 00000000000..e082cb44f7f
--- /dev/null
+++ b/sci-chemistry/ccp4i/Manifest
@@ -0,0 +1,3 @@
+DIST 6.1.3-oasis4.0.patch.bz2 946 SHA256 12d7c5965e0c46b0f482514d9083d6be94d65eeb14ba29c17d507d5f9669f84b SHA512 7c7bf4ef90550708bf41b1831dbe71c38418b46455adb3d42ec609d287894ac9260d9671f1759f71c713ced72fa004b9808391ea6874007ac8b7d7637f349d32 WHIRLPOOL a2bc27e1e054e1717c387f3800533fa490c03d1d18d3fe3cff4676f0ec47799a1681a206e01013c1b8f8e41162303446a824b86effeef2ed73f059feb07fb820
+DIST ccp4-6.1.3-core-src.tar.gz 242134076 SHA256 1e529c660e7f390ec0feca9d45caa00a2813d23156c10a2747c427117293c324 SHA512 413eba806107ebcdbd93e9122275463709133d9b2a9ce44ae57a6c2350465a47ba66ad9875237aead74f5d422c0104f58f728ab37a757b10d82cde92af444c20 WHIRLPOOL faebf8ee7920013bc3d0e83565207dca1f31ba0b5c92fe1eae4b740f70ff2031d95787fa0d545b09c853d25657c08973527e43de02fddc086988123ca2a6339c
+DIST ccp4i-6.1.3-arpwarp.patch.bz2 58498 SHA256 297e6f75354f3a1932302f7039bf449484c95eb41b8634ae96d93c754b47c687 SHA512 0bf18d9768b722c553e79eed04de316f6b0b4695f7678e1d850d5e22735ecc79cdb961ea76b6482457fff232892b81ce191cd48fa588ded8058184a871dffb65 WHIRLPOOL f24625941e31e951f13c94cf31e2ca061840b016aa3fd038d29710d9ca400d364467dc3fa1e42a55944d63ac7e42a0a6baa39a596c55b18610eeb552d232d1b8
diff --git a/sci-chemistry/ccp4i/ccp4i-6.1.3-r4.ebuild b/sci-chemistry/ccp4i/ccp4i-6.1.3-r4.ebuild
new file mode 100644
index 00000000000..f5ac55ef17f
--- /dev/null
+++ b/sci-chemistry/ccp4i/ccp4i-6.1.3-r4.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils multilib python-single-r1 virtualx
+
+MY_PN="${PN%i}"
+MY_P="${MY_PN}-${PV}"
+
+#UPDATE="04_03_09"
+#PATCHDATE="090511"
+
+SRC="ftp://ftp.ccp4.ac.uk/ccp4"
+
+DESCRIPTION="Protein X-ray crystallography toolkit -- graphical interface"
+HOMEPAGE="http://www.ccp4.ac.uk/"
+SRC_URI="
+ ${SRC}/${PV}/${MY_P}-core-src.tar.gz
+ mirror://gentoo/${P}-arpwarp.patch.bz2
+ http://dev.gentoo.org/~jlec/distfiles/${PV}-oasis4.0.patch.bz2"
+[[ -n ${UPDATE} ]] && SRC_URI="${SRC_URI} ${SRC}/${PV}/updates/${P}-src-patch-${UPDATE}.tar.gz"
+[[ -n ${PATCHDATE} ]] && SRC_URI="${SRC_URI} http://dev.gentoo.org/~jlec/science-dist/${PV}-${PATCHDATE}-updates.patch.bz2"
+
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux"
+LICENSE="ccp4"
+IUSE=""
+
+RDEPEND="
+ app-shells/tcsh
+ media-gfx/graphviz
+ >=dev-lang/tk-8.3:0
+ >=dev-tcltk/blt-2.4
+ sci-libs/ccp4-libs"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-fix-baubles.patch
+ "${WORKDIR}"/${P}-arpwarp.patch
+ )
+
+src_prepare() {
+ epatch ${PATCHES[@]}
+
+ [[ ! -z ${PATCHDATE} ]] && epatch "${WORKDIR}"/${PV}-${PATCHDATE}-updates.patch
+
+ epatch "${WORKDIR}"/${PV}-oasis4.0.patch
+ python_fix_shebang ccp4i/ share/dbccp4i/
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ # rm imosflm stuff
+ rm -rf "${S}"/ccp4i/{bin/imosflm,imosflm} || die
+
+ rm -rf "${S}"/ccp4i/{bin,etc}/WINDOWS || die
+
+ # This is installed by mrbump
+ rm -rf "${S}"/ccp4i/{tasks/{dbviewer.tcl,mrbump.*},templates/mrbump.com,scripts/mrbump.script} || die
+
+ # CCP4Interface - GUI
+ insinto /usr/$(get_libdir)/ccp4
+ doins -r "${S}"/ccp4i
+ exeinto /usr/$(get_libdir)/ccp4/ccp4i/bin
+ doexe "${S}"/ccp4i/bin/*
+ dosym ../$(get_libdir)/ccp4/ccp4i/bin/ccp4i /usr/bin/ccp4i
+
+ dodir /usr/$(get_libdir)/ccp4/ccp4i/unix
+
+ # dbccp4i
+ insinto /usr/share/ccp4
+ doins -r "${S}"/share/dbccp4i
+}
+
+pkg_postinst() {
+ _ccp4-setup() {
+ source "${EPREFIX}/etc/profile"
+ export USER=root
+ bash "${EPREFIX}"/usr/$(get_libdir)/ccp4/ccp4i/bin/ccp4i -h > /dev/null
+ }
+ VIRTUALX_COMMAND="_ccp4-setup" virtualmake
+ echo ""
+ elog "ccp4i needs some enviromental settings. So please"
+ elog "\t source ${EPREFIX}/etc/profile"
+ echo ""
+}
diff --git a/sci-chemistry/ccp4i/files/6.1.3-fix-baubles.patch b/sci-chemistry/ccp4i/files/6.1.3-fix-baubles.patch
new file mode 100644
index 00000000000..2c5f659b801
--- /dev/null
+++ b/sci-chemistry/ccp4i/files/6.1.3-fix-baubles.patch
@@ -0,0 +1,22 @@
+--- ccp4i/etc/configure.def.dist 2009-01-09 16:45:08.000000000 +0100
++++ ccp4i/etc/configure.def.dist.new 2009-07-07 23:17:26.000000000 +0200
+@@ -53,8 +53,8 @@
+ RUN_IMOSFLM _text "ccp4iwish [file join [GetEnvPath CCP4I_TOP] imosflm imosflm.tcl] project [GetCurrentProjectDir [GetCurrentProject]]"
+ RUN_CCP4MG _text "ccp4mg"
+ RUN_COOT _text "coot"
+-RUN_BAUBLES _text "python [file join [GetEnvPath CCP4] share smartie baubles.py]"
+-RUN_DBVIEWER _text "wish [file join [GetEnvPath CCP4] share dbccp4i application viewer.tcl]"
++RUN_BAUBLES _text "python [file join [GetEnvPath CCP4] share ccp4 smartie baubles.py]"
++RUN_DBVIEWER _text "wish [file join [GetEnvPath DBCCP4I_TOP] application viewer.tcl]"
+ ENABLE_BUBBLE_HELP _logical 1
+ DISABLE_TASKS _logical 1
+ CCP4_SETUP_COMMAND _text setup_ccp4
+@@ -62,7 +62,7 @@
+ BLT_LIBRARY _text ""
+ MENU_LENGTH _positiveint 25
+ HYPERTEXT_VIEWER _text firefox
+-START_NETSCAPE _text netscape
++START_NETSCAPE _text firefox
+ O_MAPMAN _text mapman
+ MAPMAN_MAXSIZE _positiveint 4194304
+ QUANTA_MBKALL _text mbkall
diff --git a/sci-chemistry/ccp4i/files/6.1.3-rename-rapper.patch b/sci-chemistry/ccp4i/files/6.1.3-rename-rapper.patch
new file mode 100644
index 00000000000..9f5cfb4b635
--- /dev/null
+++ b/sci-chemistry/ccp4i/files/6.1.3-rename-rapper.patch
@@ -0,0 +1,61 @@
+diff --git a/ccp4i/scripts/check.script b/ccp4i/scripts/check.script
+index def44bc..dd4bb7e 100755
+--- a/ccp4i/scripts/check.script
++++ b/ccp4i/scripts/check.script
+@@ -24,7 +24,7 @@
+ if $RUN_RAMPAGE {
+
+ # Generate command line
+- set cmd "[BinPath rapper]"
++ set cmd "[BinPath rappermc]"
+
+ set rapperdatadir [FileJoin [GetEnvPath CCP4] share rapper]
+ set paramsfile [FileJoin $rapperdatadir params.xml]
+diff --git a/ccp4i/scripts/rapper.script b/ccp4i/scripts/rapper.script
+index cdae1e2..faae226 100755
+--- a/ccp4i/scripts/rapper.script
++++ b/ccp4i/scripts/rapper.script
+@@ -17,7 +17,7 @@
+
+ #set up command line
+
+-set cmd "[BinPath rapper]"
++set cmd "[BinPath rappermc]"
+
+ set rapperdatadir [FileJoin [GetEnvPath CCP4] share rapper]
+ set paramsfile [FileJoin [GetEnvPath CCP4] share rapper params.xml]
+@@ -180,7 +180,7 @@ append outfiles " $XYZOUT PROJECT"
+
+ # Run RAPPER to join loop back to framework and out put to defined pdb file
+ # Also need to sort out multimodel files join - FIX ME
+-set cmd2 "[BinPath rapper]"
++set cmd2 "[BinPath rappermc]"
+ append cmd2 " $paramsfile joinpdb "
+ append cmd2 " --pdb2 \"$root\-loop.pdb\" "
+ append cmd2 " --pdb \"$root\-framework.pdb\" "
+diff --git a/ccp4i/tasks/check.tcl b/ccp4i/tasks/check.tcl
+index ae88ff2..ee3307b 100755
+--- a/ccp4i/tasks/check.tcl
++++ b/ccp4i/tasks/check.tcl
+@@ -46,7 +46,7 @@ proc check_run { arrayname } {
+ # Check for Rampage program. If it is not found, we switch off the option.
+ # If it was the only option, script will fail with next check.
+ if { $array(RUN_RAMPAGE) == 1 } {
+- if { [FindExecutable "rapper"] == "" } {
++ if { [FindExecutable "rappermc"] == "" } {
+ WarningMessage "Input Error: Rapper_Rampage program not found in system path."
+ set array(RUN_RAMPAGE) 0
+ }
+diff --git a/ccp4i/tasks/rapper.tcl b/ccp4i/tasks/rapper.tcl
+index e299057..8843a3f 100755
+--- a/ccp4i/tasks/rapper.tcl
++++ b/ccp4i/tasks/rapper.tcl
+@@ -28,7 +28,7 @@ proc rapper_run { arrayname } {
+ # Check for RAPPER program. If it is not found, we switch off the option.
+ # If it was the only option, script will fail with next check.
+ if { [regexp MODEL $build_type ] && $prog_type == "RAPPER"} {
+- if { [FindExecutable "rapper"] == "" } {
++ if { [FindExecutable "rappermc"] == "" } {
+ WarningMessage "Input Error: RAPPER program not found in system path."
+ set build_type 0
+ }
diff --git a/sci-chemistry/ccp4i/files/6.1.3-rename-superpose.patch b/sci-chemistry/ccp4i/files/6.1.3-rename-superpose.patch
new file mode 100644
index 00000000000..74cd2b94660
--- /dev/null
+++ b/sci-chemistry/ccp4i/files/6.1.3-rename-superpose.patch
@@ -0,0 +1,26 @@
+diff --git a/ccp4i/scripts/superpose.script b/ccp4i/scripts/superpose.script
+index 3483c97..5027536 100755
+--- a/ccp4i/scripts/superpose.script
++++ b/ccp4i/scripts/superpose.script
+@@ -21,7 +21,7 @@
+
+ if { [regexp SSM $SUPERPOSE_MODE ] } {
+
+- set cmd "[BinPath superpose] \"$XYZIN2\" -s $SSM_MOVING \"$XYZIN1\" -s $SSM_FIXED \"$XYZOUT_LOCAL\""
++ set cmd "[BinPath superpose-ccp4] \"$XYZIN2\" -s $SSM_MOVING \"$XYZIN1\" -s $SSM_FIXED \"$XYZOUT_LOCAL\""
+ set status [Execute $cmd "" program_status report ]
+
+ } elseif { [regexp TOP $SUPERPOSE_MODE ] } {
+diff --git a/ccp4i/tasks/superpose.tcl b/ccp4i/tasks/superpose.tcl
+index 748bf6e..c92122a 100755
+--- a/ccp4i/tasks/superpose.tcl
++++ b/ccp4i/tasks/superpose.tcl
+@@ -100,7 +100,7 @@ proc superpose_run { arrayname } {
+ # If user is match equivalent named residues/atoms then fit in the match fields
+ switch [GetValue $arrayname SUPERPOSE_MODE] \
+ SSM {
+- if { ![file exists [FindExecutable superpose]] } {
++ if { ![file exists [FindExecutable superpose-ccp4]] } {
+ WarningMessage "The program \"superpose\" is not on your path.
+ Check your installation for \"superpose\" program and \"ssm\" library."
+ return 0
diff --git a/sci-chemistry/ccp4i/files/6.1.3-rename-truncate.patch b/sci-chemistry/ccp4i/files/6.1.3-rename-truncate.patch
new file mode 100644
index 00000000000..9af60b7c515
--- /dev/null
+++ b/sci-chemistry/ccp4i/files/6.1.3-rename-truncate.patch
@@ -0,0 +1,91 @@
+diff --git a/ccp4i/crank/plugins/prep/crank_prep.tcl b/ccp4i/crank/plugins/prep/crank_prep.tcl
+index 7d05905..d01f1dc 100755
+--- a/ccp4i/crank/plugins/prep/crank_prep.tcl
++++ b/ccp4i/crank/plugins/prep/crank_prep.tcl
+@@ -226,7 +226,7 @@ proc run_truncate { i j } {
+ set script "$script\n$labout"
+ set script "$script\nEND\n"
+
+- set run_command "truncate $command << \"$script\""
++ set run_command "ftruncate $command << \"$script\""
+ puts $run_command
+ catch {eval exec $run_command } output
+ puts $output
+diff --git a/ccp4i/scripts/dtrek2mtz.script b/ccp4i/scripts/dtrek2mtz.script
+index e74aa0d..a2a1adb 100755
+--- a/ccp4i/scripts/dtrek2mtz.script
++++ b/ccp4i/scripts/dtrek2mtz.script
+@@ -36,7 +36,7 @@
+ set HKL_TRUNCATE [GetTmpFileName -ext mtz]
+
+ CreateComScript truncate truncate_script
+- set cmd "[BinPath truncate] HKLIN \"$HKLTMP\" HKLOUT \"$HKL_TRUNCATE\""
++ set cmd "[BinPath ftruncate] HKLIN \"$HKLTMP\" HKLOUT \"$HKL_TRUNCATE\""
+ set status [Execute $cmd $truncate_script program_status report]
+
+ HandleHarvestFile $HARVEST_MODE $HARVEST_PNAME $HARVEST_DNAME truncate
+diff --git a/ccp4i/scripts/import.script b/ccp4i/scripts/import.script
+index 90cba83..1c90c33 100755
+--- a/ccp4i/scripts/import.script
++++ b/ccp4i/scripts/import.script
+@@ -144,7 +144,7 @@ if { $FORMAT == "MTZ" } {
+
+ set truncatemtz [GetTmpFileName -ext mtz ]
+ CreateComScript truncate truncate_script
+- set cmd "[BinPath truncate] HKLIN \"$tmpmtz\" HKLOUT \"$truncatemtz\""
++ set cmd "[BinPath ftruncate] HKLIN \"$tmpmtz\" HKLOUT \"$truncatemtz\""
+ set status [Execute $cmd $truncate_script program_status report]
+
+
+diff --git a/ccp4i/scripts/import_scaled.script b/ccp4i/scripts/import_scaled.script
+index dcc619b..7250513 100755
+--- a/ccp4i/scripts/import_scaled.script
++++ b/ccp4i/scripts/import_scaled.script
+@@ -62,7 +62,7 @@
+
+ } else {
+ CreateComScript truncate truncate_script
+- set cmd "[BinPath truncate] HKLIN \"$HKLTMP\" HKLOUT \"$HKL_TRUNCATE\""
++ set cmd "[BinPath ftruncate] HKLIN \"$HKLTMP\" HKLOUT \"$HKL_TRUNCATE\""
+ set status [Execute $cmd $truncate_script program_status report]
+
+ HandleHarvestFile $HARVEST_MODE $HARVEST_PNAME $HARVEST_DNAME truncate
+diff --git a/ccp4i/scripts/scala.script b/ccp4i/scripts/scala.script
+index 6940ccd..bde10d6 100755
+--- a/ccp4i/scripts/scala.script
++++ b/ccp4i/scripts/scala.script
+@@ -275,7 +275,7 @@ END"
+
+ } else {
+ CreateComScript truncate truncate_script
+- set cmd "[BinPath truncate] HKLIN \"$HKLTMP\" HKLOUT \"$HKL_TRUNCATE\""
++ set cmd "[BinPath ftruncate] HKLIN \"$HKLTMP\" HKLOUT \"$HKL_TRUNCATE\""
+ set status [Execute $cmd $truncate_script $LOG_FILE program_status report ]
+ }
+
+diff --git a/ccp4i/scripts/scalepack2mtz.script b/ccp4i/scripts/scalepack2mtz.script
+index 986e06c..a1947a6 100755
+--- a/ccp4i/scripts/scalepack2mtz.script
++++ b/ccp4i/scripts/scalepack2mtz.script
+@@ -35,7 +35,7 @@
+
+ set HKL_TRUNCATE [GetTmpFileName -ext mtz]
+ CreateComScript truncate truncate_script
+- set cmd "[BinPath truncate] HKLIN \"$HKLTMP\" HKLOUT \"$HKL_TRUNCATE\""
++ set cmd "[BinPath ftruncate] HKLIN \"$HKLTMP\" HKLOUT \"$HKL_TRUNCATE\""
+ set status [Execute $cmd $truncate_script program_status report]
+
+ HandleHarvestFile $HARVEST_MODE $HARVEST_PNAME $HARVEST_DNAME truncate
+diff --git a/ccp4i/scripts/truncate.script b/ccp4i/scripts/truncate.script
+index e0e09ce..2d448a2 100755
+--- a/ccp4i/scripts/truncate.script
++++ b/ccp4i/scripts/truncate.script
+@@ -45,7 +45,7 @@
+
+ CreateComScript truncate truncate_script
+
+- set cmd "[BinPath truncate] HKLIN \"$HKLIN\""
++ set cmd "[BinPath ftruncate] HKLIN \"$HKLIN\""
+ if { ![StringSame $INPUT_DATA AMPLITUDES] } {
+ append cmd " HKLOUT \"$HKL_TRUNCATE\""
+ }
diff --git a/sci-chemistry/ccp4i/metadata.xml b/sci-chemistry/ccp4i/metadata.xml
new file mode 100644
index 00000000000..51fdedab1b3
--- /dev/null
+++ b/sci-chemistry/ccp4i/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+</pkgmetadata>