summaryrefslogtreecommitdiff
path: root/sci-chemistry/mustang
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/mustang
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/mustang')
-rw-r--r--sci-chemistry/mustang/Manifest1
-rw-r--r--sci-chemistry/mustang/files/mustang-3-gcc43.patch55
-rw-r--r--sci-chemistry/mustang/files/mustang-3.2.1-gcc-4.7.patch16
-rw-r--r--sci-chemistry/mustang/metadata.xml5
-rw-r--r--sci-chemistry/mustang/mustang-3.2.1.ebuild49
5 files changed, 126 insertions, 0 deletions
diff --git a/sci-chemistry/mustang/Manifest b/sci-chemistry/mustang/Manifest
new file mode 100644
index 00000000000..46a7a80261e
--- /dev/null
+++ b/sci-chemistry/mustang/Manifest
@@ -0,0 +1 @@
+DIST mustang_v3.2.1.tgz 161216 RMD160 980dd41e24a65f02e77a4b0d60364bbb8423f0d0 SHA1 0a9b55633bfa836d9851be115e2815f8d17839ca SHA256 38f8ec10f15466a42ade770eb6c3ed0ed2449bb070a53b5e8d3125f2596b1556
diff --git a/sci-chemistry/mustang/files/mustang-3-gcc43.patch b/sci-chemistry/mustang/files/mustang-3-gcc43.patch
new file mode 100644
index 00000000000..ef2818b92ed
--- /dev/null
+++ b/sci-chemistry/mustang/files/mustang-3-gcc43.patch
@@ -0,0 +1,55 @@
+diff -u MUSTANG_v.3.orig/src/ew_2.cpp MUSTANG_v.3/src/ew_2.cpp
+--- MUSTANG_v.3.orig/src/ew_2.cpp 2008-01-15 11:18:34.000000000 -0700
++++ MUSTANG_v.3/src/ew_2.cpp 2008-12-09 10:47:22.000000000 -0700
+@@ -36,6 +36,7 @@
+ using std::ifstream;
+
+ #include<math.h>
++#include <cstdlib>
+ #include "macros.h"
+ #include "globals.h"
+ #include "ew.h"
+diff -u MUSTANG_v.3.orig/src/multiple_superposition.cpp MUSTANG_v.3/src/multiple_superposition.cpp
+--- MUSTANG_v.3.orig/src/multiple_superposition.cpp 2008-01-15 11:18:34.000000000 -0700
++++ MUSTANG_v.3/src/multiple_superposition.cpp 2008-12-09 10:49:00.000000000 -0700
+@@ -51,6 +51,7 @@
+ #include "alloc_routines.h"
+ #include "de_alloc_routines.h"
+ #include <cmath>
++#include <cstdlib>
+ #define THRESH 0.0001
+
+ void MOVE_TO_CENTER_OF_GRAVITY( int NSTRUC , int NRES , float ***R , float **CMs )
+diff -u MUSTANG_v.3.orig/src/multiple_superposition.h MUSTANG_v.3/src/multiple_superposition.h
+--- MUSTANG_v.3.orig/src/multiple_superposition.h 2008-01-15 11:18:34.000000000 -0700
++++ MUSTANG_v.3/src/multiple_superposition.h 2008-12-09 10:48:11.000000000 -0700
+@@ -25,3 +25,4 @@
+ #define MULT_SUPERPOSE
+ void M_SUPERPOSE( int , int , float***, float** , float*** ) ;
+ #endif
++#include <cstdlib>
+diff -u MUSTANG_v.3.orig/src/pdb_ripper.h MUSTANG_v.3/src/pdb_ripper.h
+--- MUSTANG_v.3.orig/src/pdb_ripper.h 2008-01-15 11:18:34.000000000 -0700
++++ MUSTANG_v.3/src/pdb_ripper.h 2008-12-09 10:46:47.000000000 -0700
+@@ -29,4 +29,5 @@
+ void PARSE_ENTIRE_PDB_STRUCTURE( char * , int ) ;
+
+ #endif
++#include <cstdlib>
+
+diff -u MUSTANG_v.3.orig/src/progress_align.h MUSTANG_v.3/src/progress_align.h
+--- MUSTANG_v.3.orig/src/progress_align.h 2008-01-15 11:18:34.000000000 -0700
++++ MUSTANG_v.3/src/progress_align.h 2008-12-09 10:47:50.000000000 -0700
+@@ -25,3 +25,4 @@
+ #define PROG_ALGN_H
+ void PROGRESSIVE_ALIGNMENT_USING_EXTENDED_EDGE_WEIGHTS() ;
+ #endif
++#include <cstdlib>
+diff -u MUSTANG_v.3.orig/src/read_structures.h MUSTANG_v.3/src/read_structures.h
+--- MUSTANG_v.3.orig/src/read_structures.h 2008-01-15 11:18:34.000000000 -0700
++++ MUSTANG_v.3/src/read_structures.h 2008-12-09 10:46:22.000000000 -0700
+@@ -26,3 +26,4 @@
+ void READ_STRUCTURES( char **paths );
+ void READ_ENTIRE_PDBS( char **paths) ;
+ #endif
++#include <cstdlib>
diff --git a/sci-chemistry/mustang/files/mustang-3.2.1-gcc-4.7.patch b/sci-chemistry/mustang/files/mustang-3.2.1-gcc-4.7.patch
new file mode 100644
index 00000000000..9e5dea85afe
--- /dev/null
+++ b/sci-chemistry/mustang/files/mustang-3.2.1-gcc-4.7.patch
@@ -0,0 +1,16 @@
+ src/superpose_on_core_2.cpp | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/src/superpose_on_core_2.cpp b/src/superpose_on_core_2.cpp
+index ae137de..059dfe3 100644
+--- a/src/superpose_on_core_2.cpp
++++ b/src/superpose_on_core_2.cpp
+@@ -55,6 +55,8 @@ using std::ofstream ;
+ #include "multiple_superposition.h"
+ #include "3D_manip_functions.h"
+
++#include <unistd.h>
++
+ int **core_columns ;
+ int *core_columns_2 , NCORE = 0 ;
+ int **algn_to_seq_hash ;
diff --git a/sci-chemistry/mustang/metadata.xml b/sci-chemistry/mustang/metadata.xml
new file mode 100644
index 00000000000..e42d0af60f4
--- /dev/null
+++ b/sci-chemistry/mustang/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+</pkgmetadata>
diff --git a/sci-chemistry/mustang/mustang-3.2.1.ebuild b/sci-chemistry/mustang/mustang-3.2.1.ebuild
new file mode 100644
index 00000000000..4486569db22
--- /dev/null
+++ b/sci-chemistry/mustang/mustang-3.2.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+MY_PN="MUSTANG"
+SRC_P="${PN}_v${PV}"
+MY_P="${MY_PN}_v${PV}"
+
+DESCRIPTION="MUltiple STructural AligNment AlGorithm"
+HOMEPAGE="http://www.csse.monash.edu.au/~karun/Site/mustang.html"
+SRC_URI="http://www.csse.unimelb.edu.au/~arun/${PN}/${SRC_P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc-4.7.patch
+}
+
+src_compile() {
+ emake \
+ CPP=$(tc-getCXX) \
+ CPPFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_test() {
+ ./bin/${P} -f ./data/test/test_zf-CCHH || die
+}
+
+src_install() {
+ newbin bin/${P} mustang
+ doman man/${PN}.1
+ dodoc README
+}
+
+pkg_postinst() {
+ elog "If you use this program for an academic paper, please cite:"
+ elog "Arun S. Konagurthu, James C. Whisstock, Peter J. Stuckey, and Arthur M. Lesk"
+ elog "Proteins: Structure, Function, and Bioinformatics. 64(3):559-574, Aug. 2006"
+}